New noscript interface

Ask for help about NoScript, no registration needed to post
MyNameHere
Junior Member
Posts: 24
Joined: Mon Apr 26, 2010 4:41 pm

Re: New noscript interface

Post by MyNameHere » Fri Nov 24, 2017 4:46 am

[Removed to start a new thread]
Last edited by MyNameHere on Fri Nov 24, 2017 4:00 pm, edited 1 time in total.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

Re: New noscript interface

Post by Peter 123 » Fri Nov 24, 2017 5:09 am

The first thing I would like to say:

A big thank to Giorgio for all the phantastic work he does for all of us, the users of NoScript!

He did so much for us already in the past - and as we can see, he continues his invaluable activity even now, under completely changed circumstances which exist after the release of Firefox 57 / Quantum.

To say this "official" Thank You was the main reason that at I decided to register here in the Forum (instead of writing only as a guest).

Now, concerning the new NoScript (NoScript 10) I was a little bit confused too at the beginning. But in the meantime (and after the update to version 10.1.2.) I have the impression that at least the basic function does not only work fine but even more comfortable and smoothly than with the "old" version. :D

The basic function (as I see it) is the prohibition or permission of scripts on a specific website. In order to use this central feature you only have to click on the NoScript icon. Then a window which looks e.g. like the following will open (it is the example of the website ebay.com):

Image

I gave every button a number (in dark blue).

There are five different scripts on this page. For each script separately you can do the following:

1: That's the default: The script is forbidden.

2: By clicking on this button you allow this script (permanently). [About temporary permission I will write afterwards.]
[Possibly the permission does not come automatically into effect after reloading the page. This may happen if you are on a simple http website (and not on a https). See for this my description of button 7.]

3: By clicking here you decide to regard this script as untrusted.

4: By clicking on this button you can specify some custom regulations what you want to allow. (But that's already more than the basic use of NoScript I assume.)

Buttons 5 and 6 are new in version 10.1.2:

5: With this button I assume that you can do what many users obviously missed: By clicking on it, it seems that you temporarily allow all the scripts on the page ("Temporarily allow all this page"). (I confess that until now I did not fully understand if it really works this way but I think so.)
6: As the description of this button says, by clicking on it you can revoke all the temporary permissions you have given ("Revoke temporary permissions").
(Perhaps it would be more logical to change the positions of buttons 5 and 6?)

7: The button in order to reload the page. (For me until know it does not work always. I have the impression that it has to do with the green respectively red padlock that appears at the left side of the script name after allowing/trusting this script. But this is something that until now I did not understand what it means and how it works.*)
*) See relating to this matter also the information given below by NoScriptian:
NoScriptian wrote: Did you visit a website that is http only [and not https]? If so, make sure you set the padlock to red because if left green, NS will switch back to default in order to prevent you from accessing an unsecure URL.
An example:
"directupload.net" (where I had originally uploaded my pictures for this posting) is such a http-only website. That means: So that the permission of the script for it works, you have (after clicking on button 2) to click also on the green padlock in order to change it to a red one.

Image

(So that's a little bit tricky procedure that hopefully will still be simplified.)

8: From this button you can go to the options.

9: The button to close the window of NoScript.

Something that is a little bit unusual is the way you can allow temporarily a certain script. (For allowing all scripts of a page, as written above, obviously is intended button 5.):

Step 1: You have to click on button 2 (so you permanently allow the script, just for a moment).
Then you will see the gray bar (with the word "TRUSTED ") and at the right end of this bar a tiny grey clock.

This clock is in the following picture button number 10:

Image

Step 2: By clicking on this clock the permanent permission becomes temporary. The clock becomes bigger and bright:

Image

I think these are the main functions within the window that opens when clicking on the NoScript symbol.

No doubt that there are still various weak points and some strange details. But concerning the basic concept, I think that the new interface of NoScript is clearly structured and easy and comfortable to handle. 8-)
Last edited by Peter 123 on Fri Nov 24, 2017 2:46 pm, edited 25 times in total.
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

KieranWalker

Re: New noscript interface

Post by KieranWalker » Fri Nov 24, 2017 5:18 am

Pansa wrote: either way, íf you click on trusted, what checkmarks are set?
All of them, like I said before. Everything is enabled for Trusted sites, but they're completely unusable anyway, unless I turn on Allow Scripts Globally.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

oldmoz

Re: New noscript interface

Post by oldmoz » Fri Nov 24, 2017 7:07 am

Peter 123 wrote:

Now, concerning the new NoScript (NoScript 10) I was a little bit confused too at the beginning. But in the meantime (and after the update to version 10.1.2.) I have the impression that at least the basic function does not only work fine but even more comfortable and smoothly than with the "old" version. :D

The basic function (as I see it)[...]

I think these are the main functions within the window that opens when clicking on the NoScript symbol.

No doubt that there are still various weak points and some strange details. But concerning the basic concept, I think that the new interface of NoScript is clearly structured and easy and comfortable to handle. 8-)
Such a good community contribution.
Das ist mein Lieblingsführer für Anfänger
This is my favourite guide for beginners.

Those secure locks need a lot more explanation for basic NS operation, but I think people will find if a main domain is given permission, it will often want to then load insecure stuff, so a person will need to turn that green icon red to get usability of some functions on some sites *after* allowing a main site.
CARE: this is not expert advice. Try before you buy! if security is paramount for you.

Mods: this peter guide belongs in a sticky.
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

Samiii

Re: New noscript interface

Post by Samiii » Fri Nov 24, 2017 10:39 am

The new interface is interesting but could be better (don't hesitate if I may help on this point as it's part of my job).
Currently, I've big bugs with the new interface :
- When I arrive a new site, everything is blocked => OK
- I unlock some scripts but nothing happens! I reload the page and noscipt says that everything is still locked despite my previous unlock action. I go to the preference page and I see that the scripts I previously unlocked are actuelly marked as unlocked!
- Conclusion, there are disconnected data between the popup and the preferences URL base.

The only way I found to workaround this problem is to disable NoScript :'(

Now, about the interface only: The permanent scrollbars are painful. The new swithes are quite good idea but complicated to read globally. The Red/Green colors for http/https is confusing as these colors should probably be used to indicate if a URL is blocked by NoScript or not, not to indicate secure/non secure URLS. The lock should be sufficiant for that. Many old feature are missing but I'm sure they will come back soon.

One feature is missing (even in the previous version): I'd like to allow a URL only on one website. I explain myself: I'd like to avoid some URLs like google, amazon, FB, etc. from all the websites I browse EXCEPT on Google, Amazon, FB, etc. and, sometimes, I need to allow them on some very painful websites to make them work. But in 90% of my browsing time, I'd like to avoid them. I think that there should be an option "Allow only for that website".

NoScript is for me the FF addon #1 I need have. I'm sad to see what it became with this fucking upgrade of FF. I completely understand that the poor (and great) Giorgio was not able to handle the full rewrite of the plugin and I don't blame him.
Never the less, I'm sad.

Maybe it's time to open the code of NoScript and allow people helping?

Thanks for that have be done until now and what will be in the future. You provide one of the most important security/privacy plugin on the web!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

NoScriptian

Re: New noscript interface

Post by NoScriptian » Fri Nov 24, 2017 11:09 am

Samiii wrote:The new interface is interesting but could be better (don't hesitate if I may help on this point as it's part of my job).
Currently, I've big bugs with the new interface :
- When I arrive a new site, everything is blocked => OK
- I unlock some scripts but nothing happens! I reload the page and noscipt says that everything is still locked despite my previous unlock action. I go to the preference page and I see that the scripts I previously unlocked are actuelly marked as unlocked!
- Conclusion, there are disconnected data between the popup and the preferences URL base.

The only way I found to workaround this problem is to disable NoScript :'(
Did you visit a website that is http only? If so, make sure you set the padlock to red because if left green, NS will switch back to default in order to prevent you from accessing an unsecure URL.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

Re: New noscript interface

Post by Peter 123 » Fri Nov 24, 2017 1:38 pm

@ oldmoz:
Thanks a lot for your friendly words. :D
Yes, I tried my best to help a little bit and at the same time to support and appreciate Giorgio's efforts in creating this new interface.

@ NoScriptian:
Thanks for your advice concerning the red/green padlock. I added it in my above posting.
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

notgoingdodoanymore

Re: New noscript interface

Post by notgoingdodoanymore » Fri Nov 24, 2017 2:46 pm

KieranWalker wrote:
notgoingdodoanymore wrote: @KieranWalker In your drop-down menu, even though you'd klicked Allow all this site temporarily - were there still individual URLs with automatically still on Default? (There always are a few.) If so, all you need to do is manually check them as Trusted and then hit the Temporary Clock icon and possibly refresh to get things working.
No. On YouTube for instance, the only URL that comes up regardless of how many scripts it's blocking is "...youtube.com," which is on the Trusted list. Same for Google. Clicking Temporarily Allow All refreshes the page but doesn't change anything.

It's breaking the Captcha here, too.
It is a tad tricky w/o screenshots. If you've ticked everything, allowed everything globally... Have you set the ominous "padlocks" from green to red?
I would hazard a guess that you've (much like I and a lot of others) tinkered everywhich way with the settings in the beginning, and now it's all a bit of a jumble. Honestly, if you haven't spent too much time on it, simply try uninstalling NS from FF, shut down and re-install it afresh. It worked a treat for me and things work without much hassle. Tried Google & YouTube as you mentioned, and all I have to do is basically Temporarily allow (once for Google, twice for YouTube) and just enough scripts run to make e.g. videos work. Haven't even got a whitelist, and set the Default-settings to unticked everything (=block all). And yet stuff work. So it must be the overtinkering as I jammed mine in the same way in the beginning before re-installing. Save yourself the headache mate.

For the rest Peter123's "Quick Guide" is a good, simple plan to follow if you do start afresh :) >> https://forums.informaction.com/viewtop ... 105#p92105

Unless some much more capable mind chimes in... Best of luck!
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa

Re: New noscript interface

Post by Pansa » Fri Nov 24, 2017 3:03 pm

notgoingdodoanymore wrote:
KieranWalker wrote:
notgoingdodoanymore wrote: @KieranWalker In your drop-down menu, even though you'd klicked Allow all this site temporarily - were there still individual URLs with automatically still on Default? (There always are a few.) If so, all you need to do is manually check them as Trusted and then hit the Temporary Clock icon and possibly refresh to get things working.
No. On YouTube for instance, the only URL that comes up regardless of how many scripts it's blocking is "...youtube.com," which is on the Trusted list. Same for Google. Clicking Temporarily Allow All refreshes the page but doesn't change anything.

It's breaking the Captcha here, too.
It is a tad tricky w/o screenshots. If you've ticked everything, allowed everything globally... Have you set the ominous "padlocks" from green to red?
I would hazard a guess that you've (much like I and a lot of others) tinkered everywhich way with the settings in the beginning, and now it's all a bit of a jumble. Honestly, if you haven't spent too much time on it, simply try uninstalling NS from FF, shut down and re-install it afresh. It worked a treat for me and things work without much hassle. Tried Google & YouTube as you mentioned, and all I have to do is basically Temporarily allow (once for Google, twice for YouTube) and just enough scripts run to make e.g. videos work. Haven't even got a whitelist, and set the Default-settings to unticked everything (=block all). And yet stuff work. So it must be the overtinkering as I jammed mine in the same way in the beginning before re-installing. Save yourself the headache mate.

For the rest Peter123's "Quick Guide" is a good, simple plan to follow if you do start afresh :) >> https://forums.informaction.com/viewtop ... 105#p92105

Unless some much more capable mind chimes in... Best of luck!
For this forum specifically it doesn't seem to be a "red lock" issue either. (I choose focusing on it, because it's less complex, and Kireanwalker mentioned captchas not working)

Browsing in "not private mode"
informaction is greenlock trusted.
Google is greenlock trusted.

All checkmarks checked for trusted.

Captcha works.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

notgoingdodoanymore

Re: New noscript interface

Post by notgoingdodoanymore » Fri Nov 24, 2017 3:20 pm

Pansa wrote: For this forum specifically it doesn't seem to be a "red lock" issue either. (I choose focusing on it, because it's less complex, and Kireanwalker mentioned captchas not working)

Browsing in "not private mode"
informaction is greenlock trusted.
Google is greenlock trusted.

All checkmarks checked for trusted.

Captcha works.
Pansa, are we both understanding the padlocks to be match https only (green locked) and http (red open)? Because if a site uses http in subs in order for some stuff to work, and you've set the padlock to green (=allow https match only), or it's automatically set to green, then it's not going to work and you'll experience what some people describe: basically nothing happens after your changes to allow this/that.

Of course this site's on https ;) so the green https match padlock isn't hindering anything. A simple trust or temp allow makes everything work.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

lancelot

Re: New noscript interface

Post by lancelot » Fri Nov 24, 2017 4:04 pm

It would be nice to have Revoke Temporary Permissions grayed out when there are no temporary permissions.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa

Re: New noscript interface

Post by Pansa » Fri Nov 24, 2017 4:06 pm

notgoingdodoanymore wrote:
Pansa wrote: For this forum specifically it doesn't seem to be a "red lock" issue either. (I choose focusing on it, because it's less complex, and Kireanwalker mentioned captchas not working)

Browsing in "not private mode"
informaction is greenlock trusted.
Google is greenlock trusted.

All checkmarks checked for trusted.

Captcha works.
Pansa, are we both understanding the padlocks to be match https only (green locked) and http (red open)? Because if a site uses http in subs in order for some stuff to work, and you've set the padlock to green (=allow https match only), or it's automatically set to green, then it's not going to work and you'll experience what some people describe: basically nothing happens after your changes to allow this/that.

Of course this site's on https ;) so the green https match padlock isn't hindering anything. A simple trust or temp allow makes everything work.
Actually red lock means "both" not just http.
And yes, but since we are trying to troubleshoot his problem...
On this forum both scripts that need to be able to run to display the capture are HTTPS scripts.

He has a problem. This problem exists either because something is seriously broken for him, or he has overlooked an aspect. Trying to troubleshoot it for EVERY site at the same time, when we can trouble shoot it in a "far more controlled" aspect is not easy.

The way his config runs doesn't show the captcha of this forum you need to fill out to submit something. It's a nicely limited problem.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

emac2510
Posts: 2
Joined: Fri Nov 24, 2017 4:08 pm

Re: New noscript interface

Post by emac2510 » Fri Nov 24, 2017 4:15 pm

...
Last edited by emac2510 on Mon Nov 27, 2017 8:22 am, edited 1 time in total.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

bl

Re: New noscript interface

Post by bl » Fri Nov 24, 2017 5:07 pm

I almost exclusively used the right-click drop-down menu to change settings on NoScript, but that seems to be gone in the current version. Going to the top bar every time I want to change anything is really tedious. I can tell that right-click menu items are still possible under current firefox, as uBlock certainly displays in there. Would it be possible to get the right-click functionality back?
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

whatnow
Posts: 3
Joined: Thu Nov 23, 2017 3:27 pm

Re: New noscript interface

Post by whatnow » Fri Nov 24, 2017 6:14 pm

I have sort of figured out how to use the new interface option except it only shows 5 lines. It tried to use web site Zillow but NoScript shows 19. The map that shows the locations of the house does not work because I can not see the scripts to turn on and allow the map to function.

I am sorry to see FF has caused Giorgio so much work in a short amount of time. I hope he can get NoScript back to as good as it was before FF 57 and take some well deserved time off. Even take some time off to catch your breath now if you need it.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply