The OCSP server experienced an internal error.

Discussion about the board itself, forums organization and site bugs.

The OCSP server experienced an internal error.

Postby dhouwn » Wed Jul 13, 2011 9:34 pm

I was downloading the newest dev build when got the following in a pop-up:
An error occurred during a connection to secure.informaction.com:443.

The OCSP server experienced an internal error.

(Error code: sec_error_ocsp_server_error)
Looks like your CA's OSCP server got over-strained?
Anyways, this was the first time (I also can't remember having this ever on any site before), let's see if it will ever happen again.


BTW, although security.OCSP.require was set to true the download started and completed. Possibly a Firefox bug?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
dhouwn
Bug Buster
 
Posts: 966
Joined: Thu Mar 19, 2009 12:51 pm

Re: The OCSP server experienced an internal error.

Postby GµårÐïåñ » Thu Jul 14, 2011 9:23 pm

I have seen this happen not just with this site, but also many others where it will time-out on the Fx side and so it assumes the default error and displays, but if you were to refresh it, it works fine, and often times the background download process triggers a refresh and continues while we are still observing an error page. Unfortunately the only way I could explain it as well would be a Fx bug, or more like a lag causing out of sync data/response because its ambiguous.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
[ Major's Blog ] .:. [ Security Pack ] .:. [ Productivity ]
Mozilla/6.9 (en-US; rv:6.9.6.9) Gecko/66666666 Firefox/6.6.6
User avatar
GµårÐïåñ
Lieutenant Colonel
 
Posts: 2980
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA

Re: The OCSP server experienced an internal error.

Postby dhouwn » Fri Jul 15, 2011 9:42 am

In case of a timeout? Ah, OK, so it's be also connection-depended. I thought this would come if the server returned HTTP error code 500 or something like that (which some servers do if they are overburdened).

/edit: Looks like there are many potential causes for this error message: Bug 495380 – SEC_ERROR_OCSP_SERVER_ERROR is grossly ambiguous
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
dhouwn
Bug Buster
 
Posts: 966
Joined: Thu Mar 19, 2009 12:51 pm

Re: The OCSP server experienced an internal error.

Postby GµårÐïåñ » Fri Jul 15, 2011 7:11 pm

Yeah there are alot of things that can cause it, I was trying to get that out but I might not have been clear (just focusing on the most likely) and its quiet ambiguous, yes. However, connection timeouts (either DSL/Cable/Modem/Router drops signal, recycles or whatever before the new internet information is propagated to your network and you hit it right during that time), server is overloaded and is having trouble processing its request queue (so it will simply timeout, fail, or respond with 500, 501, or even 430 occasionally) and the ambiguity comes when even an undefined error will cause it to respond with this error making it hard to pinpoint. I hope you figure it out and if something relevant comes my way, I will let you know.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
[ Major's Blog ] .:. [ Security Pack ] .:. [ Productivity ]
Mozilla/6.9 (en-US; rv:6.9.6.9) Gecko/66666666 Firefox/6.6.6
User avatar
GµårÐïåñ
Lieutenant Colonel
 
Posts: 2980
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA


Return to Metaforum

Who is online

Users browsing this forum: No registered users and 1 guest