Performance issues

Ask for help about NoScript, no registration needed to post
barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

Re: Performance issues

Post by barbaz » Sun Mar 17, 2019 5:19 pm

test836 wrote:
Sun Mar 17, 2019 4:01 pm
I use the same versions with new FF profile and my settins and my delay is 12 seconds stable.

specs of my computer:
CPU: Intel Core i7 4770 3.4 Ghz
RAM: 16 GB
SSD: Samsung SSD 840 PRO
Ok, now I really don't understand. Your computer should be significantly faster than mine.

Either there's some Windows-specific issue here, or you've got some external app(s) (antivirus maybe?) that's slowing your Firefox down.


EDIT
Based on CPU speed spec difference alone, making some assumptions, and using my results as a baseline, I would estimate that the delays on your end "should not" be noticeably longer than up to 3 seconds. And that number doesn't account for you having a SSD vs me having a hard disk.
*Always* check the changelogs BEFORE updating that important software!
-

test836
Posts: 9
Joined: Sat Dec 17, 2016 6:27 pm

Re: Performance issues

Post by test836 » Mon Mar 18, 2019 6:45 am

barbaz wrote:
Sun Mar 17, 2019 5:19 pm
Either there's some Windows-specific issue here, or you've got some external app(s) (antivirus maybe?) that's slowing your Firefox down.
There is no any external app or antiviruses.
I also tried it in clear VMware with nothing installed except Firefox and I have the same result. :(
Focusing our efforts on non-productive and non-creative endeavours wastes lives as surely as war.
© Jacque Fresco
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

User avatar
therube
Ambassador
Posts: 7469
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Performance issues

Post by therube » Wed Mar 20, 2019 1:29 am

Disable hardware acceleration & see if that makes any difference?
https://support.mozilla.org/en-US/kb/ha ... inds-crash
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

test836
Posts: 9
Joined: Sat Dec 17, 2016 6:27 pm

Re: Performance issues

Post by test836 » Wed Mar 20, 2019 8:18 pm

It doesn't help :(
Focusing our efforts on non-productive and non-creative endeavours wastes lives as surely as war.
© Jacque Fresco
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

Re: Performance issues

Post by barbaz » Wed Mar 20, 2019 10:57 pm

If you're planning to upgrade to Firefox 66, please let us know if that makes any difference. It changes the way WebExtensions storage is handled - viewtopic.php?f=18&t=25102
*Always* check the changelogs BEFORE updating that important software!
-

musonius
Senior Member
Posts: 109
Joined: Sun Jul 08, 2018 5:38 pm

Re: Performance issues

Post by musonius » Thu Mar 21, 2019 6:36 am

I imported the sites of Peter Lowe's list of ad and tracking servers as UNTRUSTED sites last summer and this made Firefox quite slow. Some pages needed seconds to be loaded, but it was still not that slow as reported here.

To test, if there is an improvement in Firefox 66, I have done that again now and the performance issues seem to be mostly gone (file "noscript_data.txt" is about 80 KB). It's just a little bit slower than before and there is a slight delay when I swith tabs in the NoScript options page. I am curious, if updating to Firefox 66 helps you.

I am currently using Firefox 66 and NoScript 10.2.4.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
therube
Ambassador
Posts: 7469
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Performance issues

Post by therube » Thu Mar 21, 2019 11:27 am

Sorry, but I see no difference between... hmm... wonder if anything did actually change on the NoScript end?

Well, simply by copying the 65 "upgraded" to 66 Profile into a new directory, then opening that with 65...
And looking at new 65 Profile...

Sorry, but I see no difference between 65 & 66 (using the 100K list).
Likewise, on my lessor machine, I see nowhere near the delay that the OP is getting.

So...


NoScript already used storage-sync.sqlite as it was...
I'm thinking these changes made to 66 didn't really affect NoScript?
Yes, I'm thinking that is right - NoScript is totally unaffected by these "storage" changes implemented for FF 66.
Oh... wait a minute...
Well it does set up in /storage/ (something like, moz-extension+++31f7607b-daed-498e-a03e-34b10111d853^userContextId=4294967295) [I wonder if userContextId is used for tracking?] but it's (essentially) empty (as in no real data ends up there), is irrelevant to NoScript.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

test836
Posts: 9
Joined: Sat Dec 17, 2016 6:27 pm

Re: Performance issues

Post by test836 » Sun Mar 24, 2019 10:53 am

Sorry, but I see no difference between 65 & 66 (using the 100K list).
So do I. No difference :(
Focusing our efforts on non-productive and non-creative endeavours wastes lives as surely as war.
© Jacque Fresco
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
therube
Ambassador
Posts: 7469
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Performance issues

Post by therube » Sun Mar 24, 2019 12:02 pm

Do you have a different computer (lessor or greater) that you can test on?
Copy existing Profile, in its entirety (should work just as well as any method), onto the different computer.
(Or create a new Profile, install only NoScript, then Import your 100K list.)

Have FF 66 open that Profile.

What results do you get with that?
A small delay or are you back to 12 seconds?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

Post Reply