[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Ask for help about NoScript, no registration needed to post

[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Postby join2 » Fri Oct 13, 2017 6:03 pm

FF 56.0.1
After latest update NoScript 5.1.2 the pictogram disappeared. Can't get back. Any advice.....?

UPDATE WITH A FIX
  1. Firefox menu > Help (?) > Restart with Add-ons disabled
  2. Click the [Continue in Safe Mode] button
  3. Restart the browser again normally: NoScript UI should be back now :)
  4. Please report here the list of your add-ons as shown in about:support no need for this anymore, we've got enough data, thank you all!
Thanks and sorry for the inconvenience, we're trying to figure out what exactly is happening and how to make sure it doesn't happen again.
Furthermore, if you feel extra adventurous and helpful, please install 5.1.3rc1 from https://noscript.net/getit#devel, to provide us with some indication on what to expect on next update.
-- Giorgio
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
join2
 

Re: Pictogram NoScript

Postby therube » Fri Oct 13, 2017 6:12 pm

Try...

restarting browser
restarting browser in Safe Mode, then normally
installing NoScript again
... ?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1
User avatar
therube
Ambassador
 
Posts: 6733
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Pictogram NoScript

Postby Luke17 » Fri Oct 13, 2017 6:39 pm

I confirm that, icon is missing after upgrade to 5.1.2.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Luke17
 

Re: Pictogram NoScript

Postby Luke17 » Fri Oct 13, 2017 6:43 pm

In XPI I see file mozilla.cfg with this:

Code: Select all
//
// sample configuration to lock whitelist using the method explained here:
// http://ilias.ca/blog/2005/03/locking-mozilla-firefox-settings/


// you'd better copy the site list from the "capability.policy.maonoscript.sites"
// key in the prefs.js file found in a test profile
lockPref("noscript.default", "informaction.com https://informaction.com flashgot.net https://flashgot.net noscript.net https://noscript.net");

lockPref("noscript.ctxMenu", false); // hide context menu
lockPref("noscript.statusIcon", false); // hide statusIcon
lockPref("noscript.notify", false); // hide notification bar
lockPref("noscript.lockPrivilegedUI"); // disable DOM Inspector and Error Console (which may be used to programmatically unlock the prefs)


I think this is problem.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Luke17
 

Re: Pictogram NoScript

Postby join2 » Fri Oct 13, 2017 6:55 pm

therube wrote:Try...

restarting browser
restarting browser in Safe Mode, then normally
installing NoScript again
... ?


Thank you therube. Works!
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
join2
 

Re: NoScript icon disappeared on 5.1.2 update

Postby Giorgio Maone » Fri Oct 13, 2017 9:06 pm

join2 wrote:
therube wrote:Try...

restarting browser
restarting browser in Safe Mode, then normally
installing NoScript again
... ?


Thank you therube. Works!

What of all those things worked?
Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8146
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript icon disappeared on 5.1.2 update

Postby 520 » Fri Oct 13, 2017 9:24 pm

Giorgio Maone wrote:
join2 wrote:
therube wrote:Try...

restarting browser
restarting browser in Safe Mode, then normally
installing NoScript again
... ?


Thank you therube. Works!

What of all those things worked?
Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?

No, NoScript icon is also missing in Customize.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
520
 

Re: NoScript icon disappeared on 5.1.2 update

Postby Guest » Fri Oct 13, 2017 9:30 pm

Giorgio Maone wrote:
join2 wrote:
therube wrote:Try...

restarting browser
restarting browser in Safe Mode, then normally
installing NoScript again
... ?


Thank you therube. Works!

What of all those things worked?
Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?


No, it does not. The NoScript icon is not present in the available list.

I'm using Noscript with 64-bit Firefox 56.0, on Windows 7 Pro-64. When I realised the icon had disappeared, I removed NoScript from the extensions list and re-installed it. The icon appeared , but about 30 minutes later I noticed it had gone again.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Guest
 

Re: NoScript icon disappeared on 5.1.2 update

Postby Giorgio Maone » Fri Oct 13, 2017 9:32 pm

520 wrote:Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?

No, NoScript icon is also missing in Customize.

Could you please open your browser console, then go in about:addons and disable then re-enable NoScript? Does any NoScript-related error message show up?
Can you anyway still operate NoScript through the context menu (right clicking on the web pages) and/or the CTRL+SHIFT+S shortcut?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8146
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Postby klausi123456 » Fri Oct 13, 2017 9:49 pm

I think there is a mistake by you in the latest build because if I click here - https://addons.mozilla.org/de/firefox/addon/noscript/ (without delete the addon) on "add to firefox" the Icon appears instantly after "install".

So when I close FF 56 and reopen, the Icon disappears again until I "install" via addon site the addon again.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
klausi123456
 

Re: NoScript icon disappeared on 5.1.2 update

Postby 520 » Fri Oct 13, 2017 9:49 pm

Giorgio Maone wrote:
520 wrote:Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?

No, NoScript icon is also missing in Customize.

Could you please open your browser console, then go in about:addons and disable then re-enable NoScript? Does any NoScript-related error message show up?
Can you anyway still operate NoScript through the context menu (right clicking on the web pages) and/or the CTRL+SHIFT+S shortcut?

Security downgrade warning popped up when I clicked on disable.
Disabled and re-enabled NoScript with no difference- still appears to not be working.
NoScript doesn't appear on the context menu even though it is enabled in NoScript.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
520
 

Re: NoScript icon disappeared on 5.1.2 update

Postby Guest » Fri Oct 13, 2017 9:52 pm

Giorgio Maone wrote:
520 wrote:Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?

No, NoScript icon is also missing in Customize.

Could you please open your browser console, then go in about:addons and disable then re-enable NoScript? Does any NoScript-related error message show up?
Can you anyway still operate NoScript through the context menu (right clicking on the web pages) and/or the CTRL+SHIFT+S shortcut?


Done, with identical results to user 520 above.

No error messages appear. The icon is still missing.
NoScript is not present in the context menu.
CTRL+SHIFT+S opens a debugger - I cannot see any mention of Noscript. (I'm a bit out of my depth with this)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Guest
 

Re: NoScript icon disappeared on 5.1.2 update

Postby Giorgio Maone » Fri Oct 13, 2017 9:54 pm

520 wrote:Disabled and re-enabled NoScript with no difference- still appears to not be working.
NoScript doesn't appear on the context menu even though it is enabled in NoScript.

Does the CTRL+SHIFT shortcut work?
Any error message in the browser console upon disablement/enablement?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8146
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript icon disappeared on 5.1.2 update

Postby Guest » Fri Oct 13, 2017 9:58 pm

Giorgio Maone wrote:
520 wrote:Everyone else, does right click + Customize on the toolbar help you find the icon and drag it back there?

No, NoScript icon is also missing in Customize.

Could you please open your browser console, then go in about:addons and disable then re-enable NoScript? Does any NoScript-related error message show up?
Can you anyway still operate NoScript through the context menu (right clicking on the web pages) and/or the CTRL+SHIFT+S shortcut?


Disabling and re-enabling does not solve it for me. Context menu does not offer NoScript and I do not know how to work with the console/debugger.
One remark, in about:addons there is a tag next to NoScript: "VEROUDERD" which links to this page: https://support.mozilla.org/en-US/kb/firefox-add-technology-modernizing.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Guest
 

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Postby Giorgio Maone » Fri Oct 13, 2017 9:59 pm

Update: just received this email,
NoScript icon disappeared from the toolbar and from the customization after the 5.1.2 update, it reappeared in both places after I started Firefox with administrator privileages. The icon is still where it should be after I restarted Firefox normally.


Also, please check whether the problem persists after disabling all your extensions and reinstalling NoScript.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8146
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Next

Return to NoScript Support

Who is online

Users browsing this forum: Bing [Bot] and 17 guests