(New)Can't open youtube in URL bar unless disable in Firefox

General discussion about the NoScript extension for Firefox
Post Reply
User avatar
GIORGIO_IS_GREAT
Posts: 16
Joined: Thu Dec 07, 2017 7:17 pm

(New)Can't open youtube in URL bar unless disable in Firefox

Post by GIORGIO_IS_GREAT » Fri Oct 12, 2018 10:58 am

Suddenly when I type anything with youtube.com in the address bar in Firefox 61.0.2 with NoScript 10.1.6.2 or 10.1.9.8 it won't load the page (and the URL bar remains as e.g. https://www.google.com). Also I can't load any page with youtube.com from the History pane in Firefox. And get this: I can't even go "Back" (alt left-arrow) to a page with youtube. All of this bizarreness goes away when I open Firefox Add-ons page and disable NoScript. NoScript is preventing me from loading anything with youtube.com in this fashion. However, I can load those same videos by clicking on a link to them in Google. And they're fine if they were already in my Firefox Session. The URL bar and History and browser-back and browser-forward methods of loading youtube pages is suddenly farkled.

This just began happening in the past week, perhaps (coincidentally?) when I installed FX 61.0.2 (62.0.3 seemed to be slow so I loaded the prior FX version). I'm just mentioning that even though I would not think it to be meaningful.

Green lighting youtube.com is not the solution. That does permit videos to play but the problem with typing them in the URL bar remains.

Other domains are fine. I've only seen the problem with youtube.
alt-shift-N is outstanding. All NoScript is outstanding. :) :)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

barbaz
Senior Member
Posts: 9143
Joined: Sat Aug 03, 2013 5:45 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by barbaz » Fri Oct 12, 2018 12:16 pm

I'm not seeing this in Firefox 61.0.2, NoScript 10.1.9.8, new profile, following these steps -

1) open a new tab, go to google.com

2) Paste a Youtube video link in the URL bar, hit Enter

The Youtube video page loaded fine, video played fine.

Does disabling all extensions other than NoScript get it working for you? (Tools > Add-ons Manager)
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
GIORGIO_IS_GREAT
Posts: 16
Joined: Thu Dec 07, 2017 7:17 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by GIORGIO_IS_GREAT » Fri Oct 12, 2018 12:22 pm

Thanks for testing. With NoScript as the only add-on (everything else disabled), failure. Disable NoScript, works. Bizarre.

I'll now try a new profile, and maybe refresh the old profile. I'm reluctant to refresh because it sounds like I would lose about:config customizations.
alt-shift-N is outstanding. All NoScript is outstanding. :) :)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

barbaz
Senior Member
Posts: 9143
Joined: Sat Aug 03, 2013 5:45 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by barbaz » Fri Oct 12, 2018 12:24 pm

If the new profile works for you, please try exporting your entire NoScript settings from your main profile (NoScript Options > Export), and importing them into the new profile. Does the issue then show up in the new profile?
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
GIORGIO_IS_GREAT
Posts: 16
Joined: Thu Dec 07, 2017 7:17 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by GIORGIO_IS_GREAT » Fri Oct 12, 2018 1:52 pm

I've been toiling with shaping a new profile to imitate the old one step by step. You just did me an enormous favor because I didn't know about this Export; I just read your message while preparing to customize 60 sites one by one as before with screen prints and - yuck.

Your help is highly useful and appreciated, and right on point. But I've been at it for 11 straight hours so I need to walk away now and I'll report back later.
alt-shift-N is outstanding. All NoScript is outstanding. :) :)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

User avatar
GIORGIO_IS_GREAT
Posts: 16
Joined: Thu Dec 07, 2017 7:17 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by GIORGIO_IS_GREAT » Fri Oct 12, 2018 2:04 pm

Preliminary report, to satisfy your curiosity in appreciation for your assistance,

New profile on 61.0.2 with NoScript worked fine.
I copied in sessionstore which is enormous (maybe 90 or more separate windows); still fine (after 10 tries, then realizing that the fresh profile does not save sessions until you tell it to. Fresh profile also updates FX at its first good opportunity, fouling my testing a few times until I got in front of that, argggh)

Next I'll export old profile NoScript settings, put them in and report back, maybe later today.

If it looks like I end up with going with the new profile as my best choice, I suppose I might as well bite the bullet and refresh the old one in a last gasp to hang on.
If I still must go ahead w/ new profile, I have the sessionstore; I need to copy the big bookmark file from the old profile. As to about:config customizations I'll just visually look through them while on the old profile; I hope that there's a way just to display the modified (bold) ones.
alt-shift-N is outstanding. All NoScript is outstanding. :) :)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

User avatar
therube
Ambassador
Posts: 7407
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by therube » Fri Oct 12, 2018 5:22 pm

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

User avatar
GIORGIO_IS_GREAT
Posts: 16
Joined: Thu Dec 07, 2017 7:17 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by GIORGIO_IS_GREAT » Sat Oct 13, 2018 4:38 am

barbaz: Outstanding. Truly awesome instinct on your part. It all worked great then broke when I exported the old profile NoScript settings and imported to the new FX profile. Well done.

I don't see anything suspicious in the 4 tabs in the options UI but you're welcome to take a look if you're interested. I don't think there's anything incriminating or security-sensitive there so I can send it to you. (BTW I embarrassingly don't yet have the hang of Dropbox.) I don't see "attach" as an option here but I can just paste the entire .TXT contents. Or I can describe what's in the UI. The only tedious part is the 100 or so Per-Site Permission settings. One happens to be YouTube, though it's only one very specific address I was once testing with.
alt-shift-N is outstanding. All NoScript is outstanding. :) :)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

barbaz
Senior Member
Posts: 9143
Joined: Sat Aug 03, 2013 5:45 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by barbaz » Sat Oct 13, 2018 3:28 pm

Could you please PM me the contents of your export file and I'll take a look
*Always* check the changelogs BEFORE updating that important software!
-

barbaz
Senior Member
Posts: 9143
Joined: Sat Aug 03, 2013 5:45 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by barbaz » Sat Oct 13, 2018 5:10 pm

I can reproduce the problem with your export file.

This message appears in Browser Console (Ctrl-Shift-J) when the issue occurs -

Code: Select all

[NoScript] Blocking request from  to <the Youtube video page URL I pasted in the URL bar> by previous XSS prompt user choice log.js:6:37
In your export file, under "xssUserChoices", you have -

Code: Select all

    ">https://www.youtube.com": "block",
Try deleting that line from your export file, resetting NoScript, and importing the modified settings export file. Does that fix it?
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
GIORGIO_IS_GREAT
Posts: 16
Joined: Thu Dec 07, 2017 7:17 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by GIORGIO_IS_GREAT » Sat Oct 13, 2018 11:17 pm

Well that appears to have solved it! I have no idea how that was set - bizarre. And without going to the Console, I don't know if it would have shown up anywhere in the regular interface. Thanks for teaching me of the console resource.

BTW I don't know what you meant by "resetting NoScript" as all I did was edit the .TXT to remove the line, and imported to NoScript without even closing FX, and I got instant gratification when I typed youtube.com in the URL address bar.

Way to freakin' go, guy/gal! (Barbara?) :clap: :clap: :clap: :clap: :clap:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

barbaz
Senior Member
Posts: 9143
Joined: Sat Aug 03, 2013 5:45 pm

Re: (New)Can't open youtube in URL bar unless disable in Fir

Post by barbaz » Sun Oct 14, 2018 3:55 am

You're welcome Image
GIORGIO_IS_GREAT wrote:BTW I don't know what you meant by "resetting NoScript" as all I did was edit the .TXT to remove the line, and imported to NoScript without even closing FX, and I got instant gratification when I typed youtube.com in the URL address bar.
There is a "Reset" button next to the Import/Export buttons in NoScript Options. I suggested using it before the re-import because I wasn't 100% sure whether the NoScript 10 import is a "complete import" (overwriting everything), or whether, like the NoScript Classic whitelist import, some settings would get merged. Apparently the reset wasn't needed, so it's moot.
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply