NoScript and Firefox Sync

Ask for help about NoScript, no registration needed to post
lpthomas
Posts: 2
Joined: Fri Jul 01, 2016 12:32 am

Re: NoScript and Firefox Sync

Post by lpthomas » Tue Jul 31, 2018 6:28 pm

Is there any way to exempt NoScript from being sync'd with Firefox?

Because of the 100kb problem (I think), NoScript works differently anyway from device to device, even though I'm syncing with the same username. In fact, some sites I allow will sometimes disappear from my allowed list after a sync.

It would also be a great feature for me, to have different set of NoScript sites and behavior for my work and home laptops (for example).
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

barbaz
Senior Member
Posts: 9502
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript and Firefox Sync

Post by barbaz » Tue Jul 31, 2018 7:35 pm

lpthomas wrote:Is there any way to exempt NoScript from being sync'd with Firefox?
I would think it's possible in theory but would need to be implemented as part of NoScript. Maybe NoScript could have an option like "Always write all settings/data only to chrome.storage.local" or similar.
*Always* check the changelogs BEFORE updating that important software!
-

djk
Posts: 7
Joined: Fri Jul 27, 2018 10:53 pm

Re: NoScript and Firefox Sync

Post by djk » Fri Aug 10, 2018 1:58 pm

Does the syncing include the settings of trusted sites and customization? With the current release 10.1.8.16, it seems I am having to add the trusted site back in that were previously added.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

vanishpapkin
Posts: 1
Joined: Thu Oct 11, 2018 5:46 am

Re: NoScript and Firefox Sync

Post by vanishpapkin » Thu Oct 11, 2018 5:48 am

Giorgio Maone wrote:
confre wrote:I checked "Backup NoScript configuration in a bookmark for synchronization" but NoScript synchronization doesn't work.
This option doesn't work anymore on Fx 4.
Just grab latest NoScritp version from http://noscript.net/getit#direct (2.1.0.1 or above) and NoScript's settings will be transparently synchronized with the other Firefox preferences.

Thanks for the link.
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

mr.world

Re: NoScript and Firefox Sync

Post by mr.world » Tue Dec 10, 2019 9:56 pm

Hey,

sorry to bump this up but two simple questions, which require two simple answers:

a) is the firefox sync working with the latest version across desktop devices? (syncing also the whitelisted domains)
b) is the firefox sync working with the latest version across desktop and mobile devices (after installing manually the addons)? (syncing also the whitelisted domains)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

kalico
Posts: 1
Joined: Thu May 28, 2020 10:48 am

Re: NoScript and Firefox Sync

Post by kalico » Thu May 28, 2020 10:43 am

Has there been any update on this issue?

It is getting really frustrating to have to repeatedly whitelist sites that were previously whitelisted, just because I happen to have used Firefox from a different machine.

NoScript is generally great, but this is making it unusable.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Mad_Man_Moon
Junior Member
Posts: 38
Joined: Fri Oct 27, 2017 12:02 pm

Re: NoScript and Firefox Sync

Post by Mad_Man_Moon » Thu May 28, 2020 11:19 pm

OK, phew ... I misread ... this isn't an issue thread, it's an old one that's still stuck.

I wasn't ever expecting Sync to take my NS settings, but is it possible that it is now actually doing a little drive-by whilst syncing everything else?

There's a couple of nibbles in different forum topics below this --- and to be clear, again, I'm not expecting NS to sync at all --- but it's possible that the Sync function might be causing the normal functionality to have issues.

I just went long here:

viewtopic.php?f=7&t=25927&p=102165#p102165

So ... Has anyone confirmed that NS remembering its trusts is an issue with NS or an issue with Sync ... or perhaps something else entirely?

I've done a couple of tests, but not much, and given a bit of data in that link, if it helps. But I'm no pro!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Post Reply