Breaks auto downloads on Sourceforge

Ask for help about NoScript, no registration needed to post
vertigo
Posts: 4
Joined: Sat Apr 28, 2018 10:01 pm

Breaks auto downloads on Sourceforge

Post by vertigo » Thu May 31, 2018 9:28 pm

When downloading something from Sourceforge, the normal behavior of the site is to load the download page, after which it starts a timer that counts down from 5 and then initiates the download (opens the save dialog). With NS enabled, even when globally allowing, this functionality is broken, and the only way to download files is to click the "Problems downloading?" button then selecting the direct link or a mirror.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Breaks auto downloads on Sourceforge

Post by Giorgio Maone » Thu May 31, 2018 10:51 pm

Does it keep happening with 10.1.8.2 (latest release)?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Breaks auto downloads on Sourceforge

Post by therube » Fri Jun 01, 2018 12:10 am

No issue here.
Countdown timer (can't say I recall seeing that before) & then the dialog to download the file.
Completed successfully & runs.

I had sourceforge.net & fsdc.com allowed (though neither are really needed).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

barbaz
Senior Member
Posts: 9264
Joined: Sat Aug 03, 2013 5:45 pm

Re: Breaks auto downloads on Sourceforge

Post by barbaz » Fri Jun 01, 2018 5:36 am

vertigo is using Waterfox 56, which would mean NoScript Classic.

I'm not seeing this issue here with Waterfox 56.2 and NoScript 5.1.8.5rc3.

URL: https://sourceforge.net/projects/qt5ct/ ... rce=navbar
Temp-Allow sourceforge.net and fsdn.com
Download qt5ct-0.35.tar.bz2

I get a timer, then it redirects me to the download.

Likely not a NoScript bug. Moving to NoScript Support.


@vertigo:

Please create a clean profile from scratch. Install only NoScript latest development build, leaving all the defaults.
Does the problem still exist?
If not, what if you then import your NS settings into the clean profile using the Import and Export buttons *on the very bottom* of NS Options?
If that still doesn't reproduce the problem, NoScript is not the culprit... try Standard Diagnostic (leaving NS enabled) to isolate and correct the real cause.

Let us know, thanks.
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply