clarify AMO blip on NoScript version for Firefox 52

General discussion about the NoScript extension for Firefox
Post Reply
scripteze
Junior Member
Posts: 46
Joined: Wed Mar 14, 2012 6:15 pm

clarify AMO blip on NoScript version for Firefox 52

Post by scripteze » Fri Feb 02, 2018 4:26 am

I assume the blip on NoScript page https://addons.mozilla.org/en-US/firefo ... /noscript/,
says, "Fx52? https://noscript.net/getit" is a time saving / carpal tunnel avoiding way of saying, "If you're using Firefox 52 ESR, you need to use NoScript "Classic" (5.1.8.4)"?

Maybe could add just a few more clarifying words (bigger font - something?) on the AMO page - which NoScript & Firefox 52 ESR? I overlooked that tiny blurb several times.

A few other webext addons I have work in 52ESR. I don't know why they work (no webext APIs in 52ESR). Bugs I see are generally also seen by Fx 57, 58 users.

I've also seen discussions on "can't use a Firefox 53 - 56 profile & downgrade to use in Fx 52ESR. I had no trouble doing that (in Linux).
I pointed 52ESR to the same profile used in 56.x - no problems so far.

Thanks.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:34.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9178
Joined: Sat Aug 03, 2013 5:45 pm

Re: clarify AMO blip on NoScript version for Firefox 52

Post by barbaz » Fri Feb 02, 2018 5:20 am

Moving to NoScript General.
scripteze wrote:A few other webext addons I have work in 52ESR. I don't know why they work (no webext APIs in 52ESR).
err, WebExtensions were first introduced in Firefox 45.
scripteze wrote:I've also seen discussions on "can't use a Firefox 53 - 56 profile & downgrade to use in Fx 52ESR. I had no trouble doing that (in Linux).
I pointed 52ESR to the same profile used in 56.x - no problems so far.
Good for you, but that doesn't make it a good idea. Please read https://www.ghacks.net/2017/08/02/you-c ... -profiles/
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply