Noscript 10.1.3c2 problem with some sites

Ask for help about NoScript, no registration needed to post
User avatar
Just_Golem
Junior Member
Posts: 25
Joined: Tue Nov 28, 2017 11:04 am

Re: Noscript 10.1.3c2 problem with some sites

Post by Just_Golem » Tue Nov 28, 2017 11:26 am

Everything Google stopped working in Windows Firefox 57 after NoScript 10.1.3c2. For now it does not seem to affect Linux

NoScript icon says "X" (varies on different pages) number of things are Blocked, but when you click icon for a list, Nothing "is" blocked
Temporarily asking to Allow Everything does nothing different

GMail does not load (no error message)
Calendar tries to load but display Error message "Content cannot be shown, try again later"
Youtube NO longer plays Videos, just spinning circle, does NOT show comment section at all, NO longer displays Menu bar on left side
Google Bookmarks does not load
If logout, does NOT let me Login again, gets stuck at Password page and clicking (Next/Login) does nothing

I tried, like another poster here, to go back to 10.1.2 and chose No Update, but that does NOT work. Google properties do not work even after downgrade

Disable or Remove are only choices
:-(
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

NoScriptian

Re: Noscript 10.1.3c2 problem with some sites

Post by NoScriptian » Tue Nov 28, 2017 11:30 am

As it seems, currently checkboxes only work in Custom mode. Checkboxes in Trusted would not be remembered by NS, not even changing the debug code would have any effect. Is that intentional?
So I guess I've got to stick to Custom for the time being to have it work as supposed.

As for temporary allowing scripts: Maybe it would be handier to have the clock visible right away so I could deliberately choose what exactly I want to do: either permanently or temporarily allow scripts. That way, I would only need one click for either one.

Good thing though, auto-reload is back! :-D

As this newly programmed extension is still in its infancy and naturally has some quirks, I'll remain patient and am looking forward to its evolution into the addon I've been loving for all these years.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Jaysyn

Re: Noscript 10.1.3c2 problem with some sites

Post by Jaysyn » Tue Nov 28, 2017 11:36 am

I can no longer post to reddit when NoScript is enabled. I've checked my extensions one at a time & I only have this issue with NoScript being enabled.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

NoScriptian

Re: Noscript 10.1.3c2 problem with some sites

Post by NoScriptian » Tue Nov 28, 2017 11:43 am

Jaysyn wrote:I can no longer post to reddit when NoScript is enabled. I've checked my extensions one at a time & I only have this issue with NoScript being enabled.
Try Custom and check all boxes.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

FG

Re: Noscript 10.1.3c2 problem with some sites

Post by FG » Tue Nov 28, 2017 12:01 pm

NoScriptian wrote:Try Custom and check all boxes.
Which should be the correct/default checkboxes values for the "trusted"? Everything enabled?

Thanks
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

NoScriptian

Re: Noscript 10.1.3c2 problem with some sites

Post by NoScriptian » Tue Nov 28, 2017 12:06 pm

FG wrote:
NoScriptian wrote:Try Custom and check all boxes.
Which should be the correct/default checkboxes values for the "trusted"? Everything enabled?

Thanks
Yes, this is how Trusted was set up prior to the new update. Maybe this is just a minor bug and will be fixed soon.

Just tick the boxes you need in Custom and it'll work as supposed.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

emac2510
Posts: 2
Joined: Fri Nov 24, 2017 4:08 pm

Re: Noscript 10.1.3c2 problem with some sites

Post by emac2510 » Tue Nov 28, 2017 1:02 pm

....
Last edited by emac2510 on Tue Nov 28, 2017 5:36 pm, edited 1 time in total.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

fred84
Posts: 2
Joined: Tue Nov 21, 2017 9:27 pm

Re: Noscript 10.1.3c2 problem with some sites

Post by fred84 » Tue Nov 28, 2017 1:08 pm

I confirm the problem with 10.1.3c2 and that most of it has been solved reverting to 10.1.2

although it still does not unlock certain scripts, e.g.: ajax.googleapis is unlocked in the option page, but on some websites results blocked, and I can't unblock it and those websites are essentially unusable unless I disable noscript :(
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

NoScriptian

Re: Noscript 10.1.3c2 problem with some sites

Post by NoScriptian » Tue Nov 28, 2017 1:23 pm

fred84 wrote:I confirm the problem with 10.1.3c2 and that most of it has been solved reverting to 10.1.2

although it still does not unlock certain scripts, e.g.: ajax.googleapis is unlocked in the option page, but on some websites results blocked, and I can't unblock it and those websites are essentially unusable unless I disable noscript :(
Could you please try to set it to Default in your options and thus deleting it from your whitelist and re-apply Trusted in your web extension? If that doesn't work, go to the debug window at the bottom of the list and watch out for where ajax is listed.

In 10.1.2 "§:ajax.googleapis.com" should be listed under Trusted but perhaps it's currently listed under Untrusted?
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

xaex
Posts: 8
Joined: Tue Nov 28, 2017 2:02 pm

Re: Noscript 10.1.3c2 problem with some sites

Post by xaex » Tue Nov 28, 2017 2:38 pm

So it seems that Trusted only allows script and Default only allows frame, fetch and other. Editing the Debug script so that Trusted allows script, frame, fetch and other just reverts it back to only allow script :cry:

Not sure if Trusted was meant to merge with the Default options but it's not working???? So like NoScriptian mentioned, the only way for 10.1.3c2 to work is to use Custom (tweaking your Whitelisted items).


Some of the default Whitelisted items like ajax.googleapis.com don't work on some sites because the default is to only allow HTTPS. Some sites that I use (like the Intellicast interactive weather map) use ajax.googleapis.com but HTTP so if you tweak it's settings it will take it out of the Whitelist.

QUICK TIP: I always make a text file of the Debug script with each of Noscript's updates, so I can copy and paste it back if I mess something up when testing what's "new" with the update.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9873
Joined: Sat Aug 03, 2013 5:45 pm

Re: Noscript 10.1.3c2 problem with some sites

Post by barbaz » Tue Nov 28, 2017 2:54 pm

*Always* check the changelogs BEFORE updating that important software!
-

xaex
Posts: 8
Joined: Tue Nov 28, 2017 2:02 pm

Re: Noscript 10.1.3c2 problem with some sites

Post by xaex » Tue Nov 28, 2017 3:07 pm

Thank you :D Just updated to 10.1.3c3 and now the Debug script will let me change what can be Trusted (without it reverting back to just Script).
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply