NoScript "forgetting" whitelisted sites

Ask for help about NoScript, no registration needed to post
libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

NoScript "forgetting" whitelisted sites

Post by libove » Fri Oct 20, 2017 6:58 am

I see that this has been discussed a few times over history. None of the threads that I found about this seem to describe what I'm seeing. (Perhaps more correct to say, the proposed fixes don't seem to apply).

Firefox 56.0.1 64-bit on Windows 10 Enterprise.
Windows Domain connected machine, logged in to a Windows Domain user account.
NoScript currently at 5.1.3rc2. (I see that there has been a quick series of RC releases of NoScript recently. This has been going on for days at least, maybe weeks).
[ Not sure if I've noticed it on my other three computers, or just this one that I use the most. I think I have noticed it on others too ]

Basically, I access a site that I am absolutely certain I have whitelisted, and NoScript is blocking it again, as though my past whitelist action for the site has been forgotten.

Seems like there should be a FAQ for this problem. (Is there a FAQ for this problem? I don't see one in the NoScript FAQ)

So, how to diagnose what's going on here, and correct it?

thanks,
Jay
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript "forgetting" whitelisted sites

Post by barbaz » Fri Oct 20, 2017 5:05 pm

Do you have a user.js or lockpref file?

Do other changes to NoScript settings stick?
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7425
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript "forgetting" whitelisted sites

Post by therube » Fri Oct 20, 2017 7:05 pm

I mentioned:
Did the install of 5.1.3rc2 do a reset of Temporary Allows?
(I think it did.)
https://forums.informaction.com/viewtop ... 517#p90517

Didn't check to see if in fact that was the case.
If it were, possible whitelisted sites could similarly be affected?
(I could see where Temporary Allows might reset, but would be really surprise if permanent Allows were. Suppose one could test & see.)


KB: Preferences not saved.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript "forgetting" whitelisted sites

Post by libove » Fri Oct 20, 2017 9:23 pm

Hi barbaz,

Sorry, I should have commented, I saw that mentioned in other threads and I'd already checked - no, I do not have either of those files.

As for other settings, I don't recall what I might have changed, so I don't know what to look for.
Is there a commonly changed setting to which you could point me, and I'll look now?

thank you,
-Jay
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.62 Safari/537.36

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript "forgetting" whitelisted sites

Post by barbaz » Fri Oct 20, 2017 9:28 pm

Any NoScript setting will do. For example, you can go to NoScript Options > Appearance and change the About NoScript checkbox. Then you'll know if it reverts based on the presence/absence of the About NoScript menu item.
*Always* check the changelogs BEFORE updating that important software!
-

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript "forgetting" whitelisted sites

Post by libove » Tue Oct 24, 2017 4:32 am

I unset the "Show version", and that has stuck, but I'm pretty sure that I've now seen one particular whitelisted site get forgotten again.

So, should I try exporting settings, uninstalling NoScript, cleaning it up completely({how?), reinstalling and restoring?
And, is there a way to validate the format and content of the exported settings?

thanks,
Jay
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript "forgetting" whitelisted sites

Post by barbaz » Tue Oct 24, 2017 4:45 am

To be clear, when the site seems "forgotten", does it no longer show up in NoScript Options > Whitelist ?
*Always* check the changelogs BEFORE updating that important software!
-

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript "forgetting" whitelisted sites

Post by libove » Tue Oct 24, 2017 4:56 am

Hi barbaz, Yes, that's correct; I just exported the NoScript config, and indeed this site which I'm pretty sure I'd (re-)whitelisted recently, does not appear in the list of whitelisted sites in the exported configuration.
thanks,
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript "forgetting" whitelisted sites

Post by barbaz » Tue Oct 24, 2017 2:51 pm

Please create a clean profile from scratch. Install only NoScript, and import your NoScript settings from the exported configuration. Leave everything else default.

Does the problem occur in that setup?
*Always* check the changelogs BEFORE updating that important software!
-

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript "forgetting" whitelisted sites

Post by libove » Tue Oct 24, 2017 9:30 pm

barbaz wrote:Please create a clean profile from scratch. Install only NoScript, and import your NoScript settings from the exported configuration. Leave everything else default.

Does the problem occur in that setup?
Ugh, it's going to be at least a couple of weeks before I can devote that kind of time to testing, as I'm heading off on a business trip.
I'll return to this then. Thanks everyone for the help, and I'll be back when I can!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply