Noscript 5.0 massive lag PM x64

Bug reports and enhancement requests
Post Reply
User avatar
cartel
Junior Member
Posts: 46
Joined: Sun Jul 14, 2013 11:31 pm

Noscript 5.0 massive lag PM x64

Post by cartel » Fri Feb 03, 2017 7:15 am

https://www.bing.com/images/search?q=Old+Lady+Wat+Meme

I scroll down and its freezing and lagging real bad.
Switched back to 2.9.0.14 and its fine.

Any idea what could cause that or what info I could provide that would?

thanks

2.9.0.14

Image



5.0

Image
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Noscript 5.0 massive lag PM x64

Post by therube » Fri Feb 03, 2017 3:45 pm

Confirmed in SeaMonkey 2.46.

NoScript 5.0 is noticeably worse then 2.9.5.3.
(And that even more so is going to force me to check [going back to 2.9.5.3] in a particular Profile that has been running like a dog [to put it less then bluntly].)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 SeaMonkey/2.46

User avatar
Giorgio Maone
Site Admin
Posts: 8733
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Noscript 5.0 massive lag PM x64

Post by Giorgio Maone » Sat Feb 04, 2017 5:35 pm

@OP: why such an old Gecko version?
And why back on 2.9.0.x rather than 2.9.5.x?

@therube: any noticeable difference on stable Firefox?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

yes_noscript

Re: Noscript 5.0 massive lag PM x64

Post by yes_noscript » Sat Feb 04, 2017 6:50 pm

The OP doesnt use a old Gecko version just because he use Pale Moon.
This is just a useragent which works with most websites. As you can see my useragent doesnt have the gecko stuff included because i use the nativ Pale Moon useragent.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20170202 PaleMoon/27.1.0

User avatar
GH113
Senior Member
Posts: 57
Joined: Thu Dec 17, 2015 1:17 pm

Re: Noscript 5.0 massive lag PM x64

Post by GH113 » Thu Feb 09, 2017 5:01 pm

I've tried to open the suggested web page with live.com and bing.com enabled in NoScript drop-down menu and I haven't noticed any performance regressions. Nightly 09-02-17, NS5.0rc1. However, it took a while until the new images were loaded once I reached the bottom of the page.

Also, it is not worth creating a new thread for my report so I'll write it here. I am using Nightly 09-02-17 and NoScript 5.0rc1. The thing is with NoScript installed the contents of the loaded tabs take longer time to render (+40%) when there are other tabs loading in the background. In other words, browser is less responsive. Testing methodology:

Open 9 tabs with different web pages, wait until they load. Open 100 bookmarks using "Open all in tabs", switch to tab 1, wait until the contents of tab 1 are rendered, then switch to tab 2, wait until the contents of tab 2 are rendered, switch to 3... repeat until you reach tab 9. With uBlock Origin installed this test takes 12 seconds, with uBlock+NoScript installed it takes 17 seconds. I use 100 bookmarks because I have to eyeball all the measurements so I wouldn't be able to count the performance regression with less number of loading tabs.

I realize Noscript 5.0rc1 is a legacy version and that many users don't load that many pages in the background in order to make this performance regression really noticeable but I still wonder if anyone else tried to compare browser performance with and without NoScript in different scenarios.

Also, uBlock Origin almost doesn't slow down the browser while AdBlock Plus performance is laughable because it is still using synchronous content blocking API: https://bugzilla.mozilla.org/show_bug.cgi?id=1280368
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Noscript 5.0 massive lag PM x64

Post by therube » Thu Feb 09, 2017 6:15 pm

Just going to ramble a bit (as I was do)...


SeaMonkey 2.46 x86 (so no e10s or anything like that)
WinXP or Win7


Browser load time, browser memory usage, when loading on startup from Session Restore:
There seemed to be no difference in start up time or memory usage between 5.0 & 2.9.5.
(That was with a kind of "scientific" measurement. I used a stop-watch ;-).)


Code: Select all

UpTime  pByte  wSet   Shutdwn 
5.0
2:min   1415   1860   35.sec
2.9.5.3rc6
2:min   1414   1860   36.sec

so... startup time, time to "ready", & shutdown time, are unaffected by 2.9 vs 5.0



---


(And if that was "scientific), now, the unscientific...

I specifically put 2.9.5 in the particular Profile & was running like that.
I did not turn off automatic updates, so as it was, yesterday NoScript updated to 5.0.
Within minutes (of start up), I was like, whoa, something isn't jiving.
Quit, put 2.9.5 back in, restarted & loaded up (from Session Store) & proceeded on my way.
(And with that while things are never "great", given the memory I may eat up, it was definitely better.)

I'll mess some more, but seat of the pants says there is big enough difference here that 5.0 isn't cutting it.

My "regular" Profile, so with other extensions:
NoScript, FlashGot, Add-ons Manager Version Number, Copy URL+, Fetch Text URL, Nuke Anything Enhanced, uBlock Origin, (on xp at least, Yahoo Mail Hide Ad Panel, & Zoomr, slight differences on Win7, I'll note later).
No reason for me to "test" otherwise, because these are things I use.

My tab, window (& so RAM) usage, is often quite a bit higher then I'd think many others would use or run into.
(I'm, in my unscientific way of testing, thinking that SeaMonkey 2.46 performs worse then 2.40 or earlier.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 SeaMonkey/2.46

User avatar
cartel
Junior Member
Posts: 46
Joined: Sun Jul 14, 2013 11:31 pm

Re: Noscript 5.0 massive lag PM x64

Post by cartel » Sat Feb 11, 2017 5:57 pm

Giorgio Maone wrote:@OP: why such an old Gecko version?
And why back on 2.9.0.x rather than 2.9.5.x?

@therube: any noticeable difference on stable Firefox?

I'm using a user agent that works with least issues.
Some sites reject the palemoon defaults
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

barbaz
Senior Member
Posts: 9264
Joined: Sat Aug 03, 2013 5:45 pm

Re: Noscript 5.0 massive lag PM x64

Post by barbaz » Tue Feb 14, 2017 10:46 pm

@cartel Please try latest development build 5.0rc2, and let us know if it solves the problem.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Noscript 5.0 massive lag PM x64

Post by therube » Wed Feb 15, 2017 5:55 pm

More ramble... (& just that no specifics - yet)...

5.0rc2:

Something is up with video blocking, when you attempt to unblock it, you get the "mime type" or "codec" message ...

If I'm recalling, there was something about "NoScript blocked untrusted" kind of thing in Error Console (but AFAIK, there should have been no issue with the action.

This is a change from 2.9 or 5.0rc1.

Possible it might have to do with "ads" that many sites now try to popup on you ? or sometimes they'll reload the current page in a new tab, putting the ad in the current page, kind of thing... [or maybe not].

---

Then, & I'm not sure if this is 5.0rc2 specific (or just piss poor performance of the browser in general), I've had (1, so far), prolonged hang on what appeared to be a very basic page that should have had no issues.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 SeaMonkey/2.46

yes_noscript

Re: Noscript 5.0 massive lag PM x64

Post by yes_noscript » Sat Feb 18, 2017 6:25 pm

5.0rc2 looks good so far with PM 27.1.1 x64
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20170217 PaleMoon/27.1.1

Post Reply