youtube embed double activation (iframe, flash) problem

Bug reports and enhancement requests
Post Reply
al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

youtube embed double activation (iframe, flash) problem

Post by al_9x » Sat Nov 29, 2014 6:13 pm

Fx 33.1.1, NS 2.6.9.6rc1, new profile

  1. forbid iframe, apply to trusted
  2. open
  3. allow samsung.com
  4. activate one of the videos (first the iframe, then the flash embed), it won't play
Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: youtube embed double activation (iframe, flash) problem

Post by therube » Sat Nov 29, 2014 9:33 pm

I'm getting a "double" frame (placeholder).
First click gets you youtube.com, then a second click gets you ytimg.com, after which the clip loads & plays.

(I'm running from a less then clean Profile, but I'm not seeing anything odd.)


> 3. allow samsung.com

Not necessarily needed (for the videos).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: youtube embed double activation (iframe, flash) problem

Post by al_9x » Sat Nov 29, 2014 10:01 pm

therube wrote:I'm getting a "double" frame (placeholder).
First click gets you youtube.com, then a second click gets you ytimg.com, after which the clip loads & plays.

(I'm running from a less then clean Profile, but I'm not seeing anything odd.)


> 3. allow samsung.com

Not necessarily needed (for the videos).


I am giving repro directions, the steps are not optional
Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: youtube embed double activation (iframe, flash) problem

Post by Giorgio Maone » Sat Nov 29, 2014 11:22 pm

Investigating, thanks.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: youtube embed double activation (iframe, flash) problem

Post by therube » Sun Nov 30, 2014 1:40 pm

I see why it worked for me.
I also had Forbid <FRAME> enabled & with that it works.

Disabled it does not.
(But at the second click, there turns up a youtube.com related blocked object.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: youtube embed double activation (iframe, flash) problem

Post by Giorgio Maone » Wed Dec 03, 2014 9:43 pm

Please check latest development build 2.6.9.6rc3, thanks.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: youtube embed double activation (iframe, flash) problem

Post by al_9x » Sat Feb 07, 2015 2:54 pm

Giorgio Maone wrote:Please check latest development build 2.6.9.6rc3, thanks.


This has regressed for the 31 ESR.

Fx 31.4.0 ESR, NS 2.6.9.12, Flash 16.0.0.305, new profile

  1. forbid iframe, apply to trusted
  2. open
  3. allow samsung.com
  4. activate one of the videos (first the iframe, then the flash embed), flash never loads
Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: youtube embed double activation (iframe, flash) problem

Post by Giorgio Maone » Wed Feb 11, 2015 10:28 pm

Investigating, thank you.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: youtube embed double activation (iframe, flash) problem

Post by al_9x » Sun Feb 22, 2015 4:34 am

Giorgio Maone wrote:Investigating, thank you.


are you able to repro?
Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: youtube embed double activation (iframe, flash) problem

Post by Giorgio Maone » Sun Sep 06, 2015 8:33 pm

al_9x wrote:
Giorgio Maone wrote:Investigating, thank you.


are you able to repro?

I did manage to reproduce, but its causes are very difficult to isolate.
Are you going to stay with 31.x for long?
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: youtube embed double activation (iframe, flash) problem

Post by al_9x » Sun Sep 06, 2015 9:38 pm

Giorgio Maone wrote:
al_9x wrote:
Giorgio Maone wrote:Investigating, thank you.


are you able to repro?

I did manage to reproduce, but its causes are very difficult to isolate.
Are you going to stay with 31.x for long?


This problem is present in fx 38.2.1esr and 40.0.3 with NS 2.6.9.37rc1

directions here

In 38.2.1 the player is flash and it never loads (activation loop), in 40.0.3 the player is html5, which does load but the video does not play ("An error occurred"). I have encountered the second scenario (player loads, video does not) with the flash player, elsewhere. I've seen this bug in several other places: livejournal.com, vk.com.
Mozilla/5.0 (Windows NT 5.1; rv:38.0) Gecko/20100101 Firefox/38.0

User avatar
therube
Ambassador
Posts: 7458
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: youtube embed double activation (iframe, flash) problem

Post by therube » Mon Sep 07, 2015 9:34 pm

> This problem is present in fx 38.2.1esr and 40.0.3 with NS 2.6.9.37rc1

And SeaMonkey 2.35.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 SeaMonkey/2.35

Post Reply