1.9.9.05 Hides All HTML

Ask for help about NoScript, no registration needed to post
Aerik
Junior Member
Posts: 40
Joined: Fri Mar 20, 2009 5:24 pm

1.9.9.05 Hides All HTML

Post by Aerik » Fri Oct 02, 2009 8:07 am

Giorgio, what have you done? I updated from 1.9.9.01 to 1.9.9.05 and somewhere in there you made some kind of CSS error or something that makes it so that all the internet is hidden from view. If I hadn't had 1.9.9.01 saved as a backup, I'd have had to view-source: the 'previous versions' page at AMO to get it back. And this is the stable release youv'e put up at noscript.net. Uncool.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091001 Shiretoko/3.5.4pre

User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: 1.9.9.05 Hides All HTML

Post by Giorgio Maone » Fri Oct 02, 2009 8:43 am

Aerik, I believe you're wrong.
There's nothing new in 1.9.0.5 affecting CSS loading or HTML rendering, and nobody else reported anything like that beside you.
You're probably observing something else at work.
Did you see any error in Tools|Error Console?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Aerik
Junior Member
Posts: 40
Joined: Fri Mar 20, 2009 5:24 pm

Re: 1.9.9.05 Hides All HTML

Post by Aerik » Fri Oct 02, 2009 7:15 pm

Nothing in the error but the normal stupid errors from the Shareaholic and betterprivacy extensions that are always there, but don't seem to affect their functionality. And I've tried disabling all extensions but noscript, so I know noscript is the problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091002 Shiretoko/3.5.4pre

User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: 1.9.9.05 Hides All HTML

Post by Giorgio Maone » Fri Oct 02, 2009 7:22 pm

Aerik wrote:And I've tried disabling all extensions but noscript, so I know noscript is the problem.

Did you try on a clean profile with just NoScript?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Aerik
Junior Member
Posts: 40
Joined: Fri Mar 20, 2009 5:24 pm

Re: 1.9.9.05 Hides All HTML

Post by Aerik » Fri Oct 02, 2009 7:24 pm

I found the exact setting(s) that cause my problem.

It's my old friend, noscript.forbidIFramesContext . All html disappears if "disable iframe" is checked and noscript.forbidIFramesContext = 0 .
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091002 Shiretoko/3.5.4pre

User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: 1.9.9.05 Hides All HTML

Post by Giorgio Maone » Fri Oct 02, 2009 11:01 pm

OK, confirmed, thanks.
It will be fixed in next dev build (fortunately you seem to be the only one using that extra-paranoid setting).
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: 1.9.9.05 Hides All HTML

Post by Giorgio Maone » Sun Oct 04, 2009 9:40 pm

Fixed in 1.9.0.6.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Post Reply