Need Javascript on a site but Ns wont let me use it

Ask for help about NoScript, no registration needed to post
LooK

Need Javascript on a site but Ns wont let me use it

Post by LooK »

hello, i have a site where i need to enable javascript to run the features but even when i completely disable Ns it wont let me use the javascript features. What to do please ?
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36
User avatar
Giorgio Maone
Site Admin
Posts: 9454
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Need Javascript on a site but Ns wont let me use it

Post by Giorgio Maone »

Hard to tell without knowing which site this is.

Also, what do you mean by "completely disable NoScript"?
Mozilla/5.0 (X11; Linux x86_64; rv:120.0) Gecko/20100101 Firefox/120.0
Guest

Re: Need Javascript on a site but Ns wont let me use it

Post by Guest »

i mean when i press '' globally disable restrictions'', also i cannot link the site here since it is something personnal
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36
barbaz
Senior Member
Posts: 10830
Joined: Sat Aug 03, 2013 5:45 pm

Re: Need Javascript on a site but Ns wont let me use it

Post by barbaz »

As a test, does disabling NoScript entirely (in chrome://extensions , find NoScript and click its toggle switch off) get the site working?
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/119.0
Snowdog

Re: Need Javascript on a site but Ns wont let me use it

Post by Snowdog »

I am getting the same problem, mostly on banking websites. For example
https://auth.sainsburysbank.co.uk/login
keeps telling me ""You need to enable JavaScript to run this app." no matter how many times I click on "set all to temporarily trusted" or even "disable restrictions for this tab". Several other banks are doing the same though I'm not going to list them all.

BTW I notice on the NoScript options page, on the Trusted tab, the little box marked "script" is ticked but greyed out so I can't change it. What's that about?
Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/119.0
Guest

Re: Need Javascript on a site but Ns wont let me use it

Post by Guest »

I have the same issue in firefox 119.0.1.

It started a few days ago and it seems noscript is just not reacting to the setting changes:

Allowing a website to (temporarily) use javascript, or even allow all, will not change the behaviour of noscript/browser. In the development console I still see all calls blocked.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/119.0
barbaz
Senior Member
Posts: 10830
Joined: Sat Aug 03, 2013 5:45 pm

Re: Need Javascript on a site but Ns wont let me use it

Post by barbaz »

^ As a test, does disabling NoScript entirely (Tools > Add-ons and Themes > NoScript, click the toggle switch off) get the site working?
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/119.0
Le Me

Re: Need Javascript on a site but Ns wont let me use it

Post by Le Me »

@barbaz I have the same problem, e.g. on instaffo.com and on the AWS console (on other sites, NS works as expected).

Disabling NS as you suggested makes those sites work again.
Mozilla/5.0 (X11; Linux x86_64; rv:120.0) Gecko/20100101 Firefox/120.0
barbaz
Senior Member
Posts: 10830
Joined: Sat Aug 03, 2013 5:45 pm

Re: Need Javascript on a site but Ns wont let me use it

Post by barbaz »

instaffo.com works for me with the following sites set Trusted:

Code: Select all

instaffo.com
d3e54v103j8qbb.cloudfront.net
cdn.jsdelivr.net
website-files.com
What other extensions other than NoScript are you using?
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; Linux x86_64; rv:120.0) Gecko/20100101 Firefox/120.0
Le Me

Re: Need Javascript on a site but Ns wont let me use it

Post by Le Me »

Other extensions are coding related, so most likely don't do anything on a 3rd party site (Xdebug helper and Blackfire Profiler).

There are 2 strange things:

1. instaffo.com works since I disabled and re-enabled NS
2. NS doesn't show all of the domains you listed, but only instaffo.com, cookiebot.com, and d2yyd1h5u9mauk.cloudfront.net. Neither cdn.jsdelivr.net nor website-files.com, and those are also not mentioned in the preferences.

Thanks for your help!
Mozilla/5.0 (X11; Linux x86_64; rv:120.0) Gecko/20100101 Firefox/120.0
Post Reply