Page 1 of 1

[RESOLVED] "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Mon Jun 13, 2011 7:06 am
by ScriptOn
Using Firefox 4.01, My NoScript is configured to auto-update. Today morning when the system was started, NoScript had auto-updated from the latest stable build, 2.1.1.1 to a development build, (release-candidate,) 2.1.1.2rc1.

Though I'm quite OK with using beta programs, would like to bring these surprising points to your notice:-

01.) It's quite unprecedented that NoScript has auto-updated to a build not yet declared as stable. :o

02.) Moreover, instead of auto-updating to the latest development build 2.1.1.2rc3, it has elected to opt for a build 2 stages older . . . . . . 2.1.1.2rc1. :ugeek:

The above behavior is 100% reproducible - even if one does a manual install of the latest stable 2.1.1.1, NoScript insists on updating to the development build, 2.1.1.2rc1 . . . . . . . . even now.
:mrgreen:

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Mon Jun 13, 2011 12:47 pm
by dhouwn
That is indeed an issue because now people are on the RC versions path and will go on a rant that NoScript updates too often unless Giorgio does something about it like making all users update to the next stable version (which [accidentally?] happened several times the past if I remember correctly).

AFAIK, Giorgio tests all releases the same so from this standpoint these versions are not any less stable (therefore they all are "release candidates"); but on the other hand, that's where new features get introduced first and so unforeseen consequences (things Giorgio might have not considered and that did not show up in his testing) might more likely become visible there.

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Mon Jun 13, 2011 12:58 pm
by Giorgio Maone
I filed this bug report some hours ago, not sure about the extent of the consequences yet (see the end of my comment there).

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Mon Jun 13, 2011 2:38 pm
by ScriptOn
Thank you for the prompt response - believed that I was the only one to have been affected. Personally, no complaints from my end - the 2.1.1.2rc3 has been well-behaved on my system.

All said, I wouldn't mind using your development builds from this point, onwards - a big thanks to you for the lovely NoScript releases, over these years.

Wish you all the very best - thanks again.
:)

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Sun Jun 19, 2011 10:00 am
by Boelie
You're not the only one, after 2.1.1.1 stable I got rc1 recently as well(also when rc3 was already released) and now it just updated to rc4.

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Sun Jun 19, 2011 11:26 am
by Giorgio Maone
Boelie wrote:You're not the only one, after 2.1.1.1 stable I got rc1 recently as well(also when rc3 was already released) and now it just updated to rc4.

If you don't want to stay on the beta channel, you must opt-out, I'm afraid, by explicitly downgrading to 2.1.1.1.
This is an unfortunate consequence of this AMO bug

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Fri Jan 20, 2012 6:20 am
by Tom T.
Giorgio Maone wrote:If you don't want to stay on the beta channel, you must opt-out, I'm afraid, by explicitly downgrading to 2.1.1.1.
This is an unfortunate consequence of this AMO bug

Bug 663780 - NoScript 2.1.1.2rc1 (meant for the beta channel) is being served in the stable channel
Summary: NoScript 2.1.1.2rc1 (meant for the beta channel) is being served in the stabl...
Status: RESOLVED FIXED

Can this sticky now be removed? One user expressed concern that too many stickies clutter the board, and make current, topical ones less visible.
I agree with that viewpoint.

This also applies to the sticky on Firefox 4, which is also obsolete.

Thanks.

Re: "Stable 2.1.1.1 Auto Updates To Beta 2.1.1.2rc1"

Posted: Mon Jul 29, 2013 4:58 am
by Thrawn
Bump.