YouTube and about:blank

General discussion about the NoScript extension for Firefox
Post Reply
Tom Austin
Posts: 4
Joined: Sun Apr 18, 2010 6:13 pm

YouTube and about:blank

Post by Tom Austin » Sun Apr 18, 2010 6:20 pm

I use Firefox 3.5.9. Lately when I try to watch YouTube videos, I have to temporarily allow about:blank. I don't know what about:blank is or why it's now necessary. I've heard about:blank is dangerous.

QUESTION: Is there a way to automatically allow about:blank only for YouTube? I've whitelisted YouTube, but that doesn't work. Thanks.

Tom Austin
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: YouTube and about:blank

Post by Giorgio Maone » Sun Apr 18, 2010 7:00 pm

  1. Allowing about:blank is not dangerous
  2. Nevertheless, it's the first time I hear it is required to run Youtube movies. Can I see an URL where it happens?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Tom Austin
Posts: 4
Joined: Sun Apr 18, 2010 6:13 pm

Re: YouTube and about:blank

Post by Tom Austin » Sun Apr 18, 2010 11:04 pm

Here's one:

http://www.youtube.com/watch?v=9isKnDiJNPk

Thanks for checking on it. Now that I know about:blank is not dangerous, is there a way to allow about:blank globally or at least automatically for YouTube?

Tom
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: YouTube and about:blank

Post by Giorgio Maone » Sun Apr 18, 2010 11:06 pm

That video is working just fine for me, with or without about:blank, as soon as I allow the canonical youtube.com and ytimg.com pair.
Could you check if NoScript Options|Reset helps?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Tom Austin
Posts: 4
Joined: Sun Apr 18, 2010 6:13 pm

Re: YouTube and about:blank

Post by Tom Austin » Sun Apr 18, 2010 11:22 pm

Thanks, I've got it working now without having to allow about:blank. I revoked the temporary permissions, which in itself didn't fix it. I had a hunch it may be an interaction with Flashblock, which I disabled. Upon restarting FF, the video started playing. Then I enabled Flashblock, which allowed me to manually start the video, which now does not require about:blank to play.

I don't know why that made a difference, but it's working now. Thanks for the help!

Tom
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: YouTube and about:blank

Post by Giorgio Maone » Sun Apr 18, 2010 11:24 pm

BTW, did you try replacing FlashBlock with NoScript Options|Embeddings|Apply these restrictions to whitelisted sites as well?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Tom Austin
Posts: 4
Joined: Sun Apr 18, 2010 6:13 pm

Re: YouTube and about:blank

Post by Tom Austin » Mon Apr 19, 2010 1:08 am

I just now tried it. I knew NoScript has Flash blocking capability, but I didn't know how to implement it. I disabled Flashblock and it works just fine. Looks like I won't need Flashblock. THANKS!

Tom
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9

Post Reply