[RESOLVED] Still receiving popunders

General discussion about the NoScript extension for Firefox
Post Reply
KarlG
Posts: 5
Joined: Mon Mar 01, 2010 3:03 am

[RESOLVED] Still receiving popunders

Post by KarlG » Mon Mar 01, 2010 3:10 am

Hi

Just to let you know, that I am now receiving popunders again at http://www.wankspider.com. This is only a recent development, as up until about two or three weeks ago the popunders were being successfully blocked.

I believe the following is the code responsible..


function checkTarget(e)
{
var random = 1;//Math.round(Math.random());
var urls = new Array();
urls[0] = 'http://www.wankspider.com/showit.php';
urls[1] = 'http://creatives.livejasmin.com/iframes/wankspier/wankspier.html?psid=ed_wankspierpu&pstour=t1&psprogram=REVS&site=jsm';

var width = new Array();
width[0] = 920;
width[1] = 790;

var height = new Array();
height[0] = 580
height[1] = 680

//alert("Calling "+ getCookie('popundr_'+random));

if ( !getCookie('popundr_'+random) ) {
var e = e || window.event;

var win = doOpen(urls[random], width[random], height[random]);

setCookie('popundr_'+random, 1, 12*60*60*1000);
}
}
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Using Latest Development Build - Still receiving popunders

Post by Giorgio Maone » Mon Mar 01, 2010 9:32 am

I'm not getting them, and I tracing the calls I could verify the anti-popunder surrogate is still working correctly.
Are you sure that you didn't modify either the noscript.surrogate.popunder.replacement or the noscript.surrogate.popunder.sources about:config preference?
If you did (they should be displayed in bold), could you use the "Reset" command on them?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

KarlG
Posts: 5
Joined: Mon Mar 01, 2010 3:03 am

Re: Using Latest Development Build - Still receiving popunders

Post by KarlG » Mon Mar 01, 2010 10:01 am

Hi, yes I've checked and nothing was modified. I don't know if it makes any difference, but I have Cookie Monster installed, and I've disabled cookies completely for this site.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

KarlG
Posts: 5
Joined: Mon Mar 01, 2010 3:03 am

Re: Using Latest Development Build - Still receiving popunders

Post by KarlG » Mon Mar 01, 2010 10:11 am

I've never done any javascript debugging before, but I'd love to learn. If you could tell me how you traced the javascript, I'll try it myself and see what I can find out...

:-)
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

KarlG
Posts: 5
Joined: Mon Mar 01, 2010 3:03 am

Re: Using Latest Development Build - Still receiving popunders

Post by KarlG » Mon Mar 01, 2010 10:24 am

And sorry, I should have mentioned. The popunders don't come right away, only when you click on a video...
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Using Latest Development Build - Still receiving popunders

Post by Giorgio Maone » Mon Mar 01, 2010 10:32 am

KarlG wrote:I've never done any javascript debugging before, but I'd love to learn. If you could tell me how you traced the javascript, I'll try it myself and see what I can find out...

You could use either Venkman or Firebug, but what I did is much simpler: I edited my noscript.surrogate.popunder.replacement about:config preference, sticking alert() statements where I expected code to be executed.
KarlG wrote:The popunders don't come right away, only when you click on a video...

That's what I tested from the beginning.
Could you try on a clean profile?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

KarlG
Posts: 5
Joined: Mon Mar 01, 2010 3:03 am

Re: Using Latest Development Build - Still receiving popunders

Post by KarlG » Mon Mar 01, 2010 10:54 am

Ok, I tested it on a clean profile and *success*. No popups...

So I loaded my old profile again, and checked my popup settings and guess what?? Somehow or other, http://www.wankspider.com was set to ALLOW popups!!!

D'OH!!!!! :oops:

Oh man, I can't believe I could be so stupid!!!!! :roll:

Anyway, by way of an apology for wasting your time, I've donated €20 via paypal.

Sorry again...


P.S.

Tell me more (if you've got time) about how you used the alert() statements when debugging. I couldn't quite figure it out....
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

anthoy
Posts: 9
Joined: Sun Apr 05, 2009 3:01 pm

Re: [RESOLVED] Still receiving popunders

Post by anthoy » Tue Mar 02, 2010 12:28 pm

How can I block mediafire popup which appear after I allow script on "http://www.mediafire.com"?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Post Reply