Where can I get old v2.9.0.14?

General discussion about the NoScript extension for Firefox
Post Reply
slipkid
Posts: 2
Joined: Fri Mar 19, 2021 4:26 am

Where can I get old v2.9.0.14?

Post by slipkid » Fri Mar 19, 2021 4:33 am

I have old XP machines running Firefox 52.9.0 that was running Noscript 2.9.014.

It worked great.

A few days ago for an unknown reason on one of the PC's Firefox thought it had been "corrupted" when I started it up & it "repaired" itself. This destroyed all of my custom settings and removed all addons. I have been manually going back and fixing all of that and so far the only thing I cannot fix is reinstalling NoScript since older versions have been removed from the site.

Can anyone please tell me where I can get an old version of NoScript to install that works on Firefox 52.9.0, whether that be 2.9.014 or anything else?

Thanks. I'm sorry if this has been asked up here already, I tried looking but could not find anything and am short on time, cannot keep going through all the posts....again thx.
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

barbaz
Senior Member
Posts: 9870
Joined: Sat Aug 03, 2013 5:45 pm

Re: Where can I get old v2.9.0.14?

Post by barbaz » Fri Mar 19, 2021 12:43 pm

slipkid wrote:
Fri Mar 19, 2021 4:33 am
NoScript since older versions have been removed from the site.
No they haven't - https://noscript.net/getit
https://noscript.net/feed?classic&t=c

While 2.9.0.14 is directly linked on the main getit page, you don't need to go back that far. Your Firefox 52.9.0 can run the last NoScript Classic, 5.1.9 (also linked on the main getit page).
*Always* check the changelogs BEFORE updating that important software!
-

slipkid
Posts: 2
Joined: Fri Mar 19, 2021 4:26 am

Re: Where can I get old v2.9.0.14?

Post by slipkid » Fri Mar 19, 2021 3:17 pm

Wow thanks!

What the heck was I looking at. I tried to install it earlier from what I thought was the noscript site but all it had on the page was a bunch of versions which every single one had a red banner on top saying something like this will not work with your version of firefox, you need to upgrade, etc etc.

Ugh. When I try to install that v5 you mention Firefox keeps blocking the install, says "Firefox has prevented this site from installing an unverified addon". Thinking more about it I think that is what I started to do earlier today then that somehow led me to google around for the 2.x version & I found some other install page that only had newer stuff, hence my Q above.

Hmm. Reading more etc I am going to try to about:config change for xpsignatures.required thing to false...here goes..

SWEET!!! Let me install it. Gonna restart & test it out.... THANKS FOR YOUR HELP :-)
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

Post Reply