NoScript Icon shows no status (10.x) [SOLVED]

General discussion about the NoScript extension for Firefox
Post Reply
User avatar
Damnatus
Posts: 3
Joined: Tue Dec 19, 2017 6:15 am

NoScript Icon shows no status (10.x) [SOLVED]

Post by Damnatus » Tue Dec 19, 2017 6:31 am

Hi there,

I just found a discrepancy of the icons between what is presented https://hackademix.net/2017/12/04/noscr ... utshell-2/ and mine.
While it seem to have normally a status with the blocked counter and the little cross sign if not everything is allowed, my icon is just the plain S symbol. Even if I haven't allowed anything.
I have deleted the extension and re-installed it but it didn't solve the issue.
Some idea what else I can do?
Last edited by Damnatus on Wed Dec 20, 2017 8:43 pm, edited 1 time in total.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

bo elam
Senior Member
Posts: 190
Joined: Sat Oct 14, 2017 2:25 am

Re: NoScript Icon shows no status (10.x)

Post by bo elam » Tue Dec 19, 2017 9:36 pm

Perhaps, doing a Reset helps (NoScript Options, Click Reset).

Before doing that, do this and test. Make sure only boxes for Fonts, Fetch and Other are ticked for the Default preset (thats default for this Preset). You could also untick all boxes for that Preset. After verifying and/or making changes, test.

Bo
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Damnatus
Posts: 3
Joined: Tue Dec 19, 2017 6:15 am

Re: NoScript Icon shows no status (10.x)

Post by Damnatus » Wed Dec 20, 2017 4:04 pm

Yes. Reset has worked. Now the toolbar icon shows the status.

But on my preset for default it's frame, fetch, other ticked. Not fonts.

After your hint with the policies I have looked into my exported settings and guess what: they were messed up somehow. DEFAULT was like TRUSTED. no wonder the icon in the toolbar was that way. As I haven't never changed the presets it never occured to me that there was an issue with it. Thanks, Bo!
Find below my settings before the reset and after

Code: Select all

{
  "policy": {
    "DEFAULT": {
      "capabilities": [
        "other",
        "font",
        "frame",
        "media",
        "webgl",
        "script",
        "fetch"
      ],
      "temp": false
    },
    "TRUSTED": {
      "capabilities": [
        "other",
        "font",
        "frame",
        "media",
        "webgl",
        "script",
        "fetch"
      ],
      "temp": false
    },
    "UNTRUSTED": {
      "capabilities": [],
      "temp": false
    }

Code: Select all

{
  "DEFAULT": {
    "capabilities": [
      "frame",
      "fetch",
      "other"
    ],
    "temp": false
  },
  "TRUSTED": {
    "capabilities": [
      "script",
      "object",
      "media",
      "frame",
      "font",
      "webgl",
      "fetch",
      "other"
    ],
    "temp": false
  },
  "UNTRUSTED": {
    "capabilities": [],
    "temp": false
  }
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

bo elam
Senior Member
Posts: 190
Joined: Sat Oct 14, 2017 2:25 am

Re: NoScript Icon shows no status (10.x)

Post by bo elam » Wed Dec 20, 2017 6:38 pm

Damnatus wrote:Yes. Reset has worked. Now the toolbar icon shows the status.

But on my preset for default it's frame, fetch, other ticked. Not fonts.

After your hint with the policies I have looked into my exported settings and guess what: they were messed up somehow. DEFAULT was like TRUSTED. no wonder the icon in the toolbar was that way. As I haven't never changed the presets it never occured to me that there was an issue with it. Thanks, Bo!
Find below my settings before the reset and after
You are welcome, Dammatus. You are right, is frame instead of fonts (my memory went bad when I wrote that reply). In one of my computers, settings got corrupted when I updated to Firefox 57 and settings for NoScript were automatically imported by NoScript. So, in that computer I experienced what you were seeing. It was easy for me to figure the cause of your problem.

Bo
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Damnatus
Posts: 3
Joined: Tue Dec 19, 2017 6:15 am

Re: NoScript Icon shows no status (10.x)

Post by Damnatus » Wed Dec 20, 2017 8:45 pm

bo elam wrote:In one of my computers, settings got corrupted when I updated to Firefox 57 and settings for NoScript were automatically imported by NoScript. So, in that computer I experienced what you were seeing. It was easy for me to figure the cause of your problem.

Bo
That's most likely what happened to me, too!
So maybe there's a more widespread issue there.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply