Extremely disappointed in NoScript 10.1.3c3 & Firefox 57.0

General discussion about the NoScript extension for Firefox
Post Reply
XAP
Posts: 2
Joined: Fri Nov 24, 2017 10:06 pm

Extremely disappointed in NoScript 10.1.3c3 & Firefox 57.0

Post by XAP » Wed Nov 29, 2017 2:39 pm

I have used NoScript for some years now. I found it because I needed to block fake Firefox Security warnings. NoScript was simple for everyone in my family to use. If something you needed to use on a webpage didn't work, just hit "Temporarily Allow All". Occasionally, it might have had to be hit a second time, but that was it. I could easily figure out which items needed to be permanently allowed for certain websites and then easily permanently allow them. I loved how it blocked a lot of useless info, especially on the sides of webpages.

Now, sites I go to all the time will not load correctly, no matter how many times I hit "Temporarily Allow All". Certain buttons won't work (like a Submit button, for instance). I also keep getting gray boxes that ask things like if I want to allow such-and-such site to connect to Facebook.com, sometimes several in a row. I don't want to have to keep using Google Chrome -- I prefer Firefox.

I understand things need to be updated and that bumps need to be worked out. Please understand not all of us are experts at what NoScript does. We just know it used to work. Now it doesn't.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: Extremely disappointed in NoScript 10.1.3c3 & Firefox 57

Post by Pansa » Wed Nov 29, 2017 3:01 pm

can you check whether the specific presets are correctly configured?
"default", "trusted" , "untrusted" should have the checkmarks set to
none , all , none

As example for "all" in "trusted see : https://hackademix.net/2017/11/28/growi ... -1013-rcs/

You can/should also look at the debug log in the options.
It should say at the beginning:
{
"DEFAULT": {
"capabilities": [],
"temp": false
},
"TRUSTED": {
"capabilities": [
"script",
"object",
"media",
"frame",
"font",
"webgl",
"fetch",
"other"
],
"temp": false
},
"UNTRUSTED": {
"capabilities": [],
"temp": false
},


Also, if you have created top level domain rules (the ...webpage.com ones) check if you made a HTTPS only rule (black text, green lock, or showing as §:webpage in the debug log), but the page may be actually trying to run HTTP scripts.

Updating has sometime caused faulty base settings to be kept.
If the settings are fixed, the core experience as you describe it is back as well.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

XAP
Posts: 2
Joined: Fri Nov 24, 2017 10:06 pm

Re: Extremely disappointed in NoScript 10.1.3c3 & Firefox 57

Post by XAP » Thu Nov 30, 2017 1:58 pm

Thank you very much for the suggestions. I checked all of them. The NoScript version I have this morning is now 10.1.3.

My specific presets seem to be correct for each website.

I looked at the debug log (for those, like me, who have to look for it, it is little square button at the bottom of the allowed websites list). I had multiple items listed under "Default" so I made my list match yours.

You also informed me about the green locks vs. red locks. If the lock is green on a webpage that doesn't work, I will now change it to make it red.

I really appreciate the help. Right now everything seems to be running much more smoothly.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply