Massive CPU usage when switching to Tweetdeck tab

General discussion about the NoScript extension for Firefox
Post Reply
Codecat
Posts: 5
Joined: Tue Nov 21, 2017 6:34 pm

Massive CPU usage when switching to Tweetdeck tab

Post by Codecat » Tue Nov 21, 2017 6:40 pm

Since I got Noscript 10 installed, switching to my pinned Tweetdeck tab now causes about 5 whole seconds of 30% CPU usage, which also makes the entirety of Firefox very slow.

Image

Image

Is anyone else seeing this?

Also, here is a list of all the extensions I have installed. I'm going to disable them all except Noscript now and see if it still happens, and then I will edit my post.

Edit: The same behavior occurs when only Noscript is enabled, so I do believe this is a Noscript problem. The problem seems to get more noticable the longer the browser is open.

Edit 2: For reproduce steps, if I switch between a random tab and my Tweetdeck tab in quick succession, it spikes up to 30% very quickly. Any other tab it doesn't do this.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Codecat
Posts: 5
Joined: Tue Nov 21, 2017 6:34 pm

Re: Massive CPU usage when switching to Tweetdeck tab

Post by Codecat » Wed Nov 22, 2017 12:57 pm

Just noticed this happens on Soundcloud too. Basically huge script hogging pages have this problem.

Also, Youtube's homepage with its giant list of subscriptions in the sidebar takes a while to load, but I'm unsure if that's caused by Noscript. (It shows the same symptoms are Tweetdeck and Soundcloud though.)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Hasemo

Re: Firefox 57 and NoScript 10.1.2

Post by Hasemo » Fri Nov 24, 2017 2:25 am

I just wanted to report, that the problem described in this thread (NoScript+Tweetdeck being a very resource heavy and laggy combination) still persists in 10.1.2: https://forums.informaction.com/viewtop ... =8&t=23661
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9140
Joined: Sat Aug 03, 2013 5:45 pm

Re: Massive CPU usage when switching to Tweetdeck tab

Post by barbaz » Fri Nov 24, 2017 2:35 am

Hasemo wrote:I just wanted to report, that the problem described in this thread (NoScript+Tweetdeck being a very resource heavy and laggy combination) still persists in 10.1.2: https://forums.informaction.com/viewtop ... =8&t=23661
Moved your post to the appropriate thread.
*Always* check the changelogs BEFORE updating that important software!
-

Codecat
Posts: 5
Joined: Tue Nov 21, 2017 6:34 pm

Re: Massive CPU usage when switching to Tweetdeck tab

Post by Codecat » Fri Nov 24, 2017 12:04 pm

Can confirm, this still happens on 10.1.2. Good to hear I'm not the only one, by the way :)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Hasemo
Posts: 1
Joined: Mon Dec 04, 2017 1:47 am

Re: Massive CPU usage when switching to Tweetdeck tab

Post by Hasemo » Mon Dec 04, 2017 1:50 am

The problem still persists on version 10.1.5.3.
Switching to/from the Tweetdeck browser tab sometimes makes the whole browser unresponsive for a few seconds. The problem started happening after updating NoScript to version 10.*. Turning NoScript off fixes it.
I really hope this will be addressed in one of the future versions.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply