Wall Street Journal very hard to use

General discussion about the NoScript extension for Firefox
Post Reply
User avatar
glnz
Junior Member
Posts: 23
Joined: Sat Sep 04, 2010 12:43 pm

Wall Street Journal very hard to use

Post by glnz » Fri Aug 25, 2017 3:47 pm

Love NoScript and just made a donation to Mr. Maone.
Here's my issue: I go to the Wall Street Journal website on my Firefox browser frequently during the day, but that site is so full of scripts and other stuff that it's hard to use with NoScript security. It's the worst site I know.
Even worse, it is the only site that triggers NoScript warnings about XSS attacks (from itself). (See, for example, https://forums.informaction.com/viewtop ... et+journal on this forum.)
Right or wrong, with Firefox and NoScript, it's now hard to see and add Comments to the Wall Street Journal stories (lots of fun flaming), and its videos NEVER work.
What should I do?
Please go to http://www.wsj.com and try. What do you think?
By the way, I also use DisconnectMe. Should I UNinstall that one and just rely on NoScript? Am I being too protective?
My Firefox also has CookieMonster and I do NOT allow all cookies, but I DO allow from wsj.com, barrons.com, dowjones.com, etc.
I also have BetterPrivacy and AdBlock Plus and https everywhere.
But I only have trouble with www.wsj.com, not for example www.nytimes.com.
What should I do to have a compromise that does better on www.wsj.com?
Thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

barbaz
Senior Member
Posts: 9448
Joined: Sat Aug 03, 2013 5:45 pm

Re: Wall Street Journal very hard to use

Post by barbaz » Fri Aug 25, 2017 4:04 pm

Do you have an exact link that doesn't require subscription to view the comments?
glnz wrote:By the way, I also use DisconnectMe. Should I UNinstall that one and just rely on NoScript? Am I being too protective?
No and no. NoScript is a security tool, Disconnect is a privacy tool. I think having both types of protection is wise.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
glnz
Junior Member
Posts: 23
Joined: Sat Sep 04, 2010 12:43 pm

Re: Wall Street Journal very hard to use

Post by glnz » Fri Aug 25, 2017 4:19 pm

barbaz - thanks.
Unfortunately, there is NOT a link where a non-subscriber can check. I actually just called them to see if, for example, there was a link for seven days free (which I would then send you), but no luck.
So, I urge all visitors here who are wsj.com subscribers to check with NoScript and report here.
Thanks.
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

barbaz
Senior Member
Posts: 9448
Joined: Sat Aug 03, 2013 5:45 pm

Re: Wall Street Journal very hard to use

Post by barbaz » Fri Aug 25, 2017 4:44 pm

Thanks for checking.

If the XSS console messages you're getting match those in the thread you linked, that's unlikely to be the problem.

Can you troubleshoot this if we detail the steps?
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
glnz
Junior Member
Posts: 23
Joined: Sat Sep 04, 2010 12:43 pm

Re: Wall Street Journal very hard to use

Post by glnz » Fri Aug 25, 2017 4:49 pm

barbaz - I'm now badly tied up for rest of day. Can you send me the steps for troubleshooting -- for me to do later? Thanks.
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

barbaz
Senior Member
Posts: 9448
Joined: Sat Aug 03, 2013 5:45 pm

Re: Wall Street Journal very hard to use

Post by barbaz » Fri Aug 25, 2017 5:29 pm

Sure. I'll just leave them here, for whenever you can get to them.

First thing to check is create a new, clean profile without NoScript and test WSJ, to make sure it works. See http://kb.mozillazine.org/Profile_Manager for how to do this.

Then install NoScript, Allow Scripts Globally (don't mark anything untrusted), and test WSJ again. If it works, Forbid Scripts Globally and find the minimal needed permissions. Then go back to your main profile and set those permissions in NoScript. If you can't, or if that doesn't get it working, then probably something else is interfering.

If Allow Scripts Globally in the clean profile does *not* work, please check the Browser Console (Ctrl-Shift-J) when this issue happens and post here any messages related to NoScript.
(related messages usually start with either "[NoScript" or "[ABE]"; if you don't know what's related, turn off CSS warnings and post everything else you see)
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply