supported browsers

General discussion about the NoScript extension for Firefox
yes_noscript

Re: [FIXED] not compatible with Gecko < 51

Post by yes_noscript » Thu Nov 24, 2016 8:46 pm

barbaz wrote: when Pale Moon 27 is released, I can no longer use Pale Moon nor support it here.

Why?

cartel wrote:they removed pdf, custom address bar images, the classic download box, No "inspect element", No Dev tools (the old ones built-in were great) and no noscript support.
And its not that noscript doesn't work, it works fine but they blacklisted it in the code.

PDF.js was never a maintained part in Pale Moon.
remove custom addressbar images? I dont think so. You need update your theme.
classic download box is gone because of the new code, yes.
For the inspect and other dev tools see the devtools topics and alternatives.

Pale Moon support NoScript and i run it since day one. Don't know why you write such crap.

Edit: version NoScript 2.9.5.1 nor latest dev (2.9.5.2rc1) can be installed in Pale Moon 27 without any changes.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20161117 PaleMoon/27.0.0

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: [FIXED] not compatible with Gecko < 51

Post by barbaz » Thu Nov 24, 2016 9:49 pm

yes_noscript wrote:
barbaz wrote: when Pale Moon 27 is released, I can no longer use Pale Moon nor support it here.

Why?

:?:
Did you not read the rest of what I wrote?

viewtopic.php?p=84908#p84908
viewtopic.php?p=84924#p84924
*Always* check the changelogs BEFORE updating that important software!
-

yes_noscript

Re: supported browsers

Post by yes_noscript » Sun Nov 27, 2016 2:50 pm

Sorry, i doesn't see that.

Currently i have NoScript 2.9.0.14 installed but the latest is 2.9.5.1.
I hope Giorgio will fix that so Pale Moon users get the new NoScript too.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20161117 PaleMoon/27.0.0

yes_noscript

Re: supported browsers

Post by yes_noscript » Thu Dec 01, 2016 3:18 pm

Moonchild re-include the devtools in current beta version.
@barbaz: You can use then Pale Moon again :)

Also read this: https://forum.palemoon.org/viewtopic.php?p=99071#p99071
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20161125 PaleMoon/27.0.1

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: supported browsers

Post by barbaz » Thu Dec 01, 2016 3:56 pm

That is good news, thanks for sharing! Image

yes_noscript wrote:@barbaz: You can use then Pale Moon again :)

Yes, I would be able to use it for myself. Whether I could resume supporting it here depends on more than just me. I'll first have to re-check NoScript compatiblilty when Pale Moon 27.0.2 is released.
*Always* check the changelogs BEFORE updating that important software!
-

yes_noscript

Re: supported browsers

Post by yes_noscript » Fri Dec 02, 2016 3:05 pm

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20161125 PaleMoon/27.0.1

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: supported browsers

Post by barbaz » Fri Dec 02, 2016 4:07 pm

Pale Moon 27.0.2
NoScript 2.9.5.2rc5

With just an install.rdf change:
- Script blocking works
- Inclusion type checking works
- XSS filter seems OK
- ABE seems OK
- Surrogates seem OK
- HTTPS forcing seems OK

The only issue I hit is, sometimes the NoScript menu is positioned with the sites off-screen. Not a problem though, just moving the Pale Moon window is enough to correct that.

Do note that I haven't tested every NoScript feature. But I think with that list, it's fair to say NoScript works with Pale Moon 27.0.2.

You can tell the people in https://forum.palemoon.org/viewtopic.php?f=16&t=13813 that I will handle that. And many thanks to Moonchild for reinstating devtools. Image
*Always* check the changelogs BEFORE updating that important software!
-

yes_noscript

Re: supported browsers

Post by yes_noscript » Fri Dec 02, 2016 4:52 pm

Alright. Thats sound very good.
I will post that

Thanks for your help! :)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20161125 PaleMoon/27.0.1

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: supported browsers

Post by barbaz » Fri Dec 02, 2016 4:58 pm

You're welcome! Image
*Always* check the changelogs BEFORE updating that important software!
-

yes_noscript

Re: supported browsers

Post by yes_noscript » Sat Dec 03, 2016 12:45 am

barbaz can you confirm that with NoScript 2.9.5.2rc5 (only tested in Pale Moon 27.0.2) autoreload doesn't work after allow/ forbid a site in NoScript.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.0) Goanna/20161201 PaleMoon/27.0.2

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: supported browsers

Post by barbaz » Sat Dec 03, 2016 12:56 am

That issue happens in Firefox and SeaMonkey as well. viewtopic.php?f=10&t=22267
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
cartel
Junior Member
Posts: 46
Joined: Sun Jul 14, 2013 11:31 pm

Re: supported browsers

Post by cartel » Sun Jan 22, 2017 3:05 am

2.9.5.3 works on PM now, thanks!!

:D
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

Post Reply