Outlook and new webmail interface

General discussion about the NoScript extension for Firefox

Outlook and new webmail interface

Postby kinet1c » Thu Sep 20, 2018 5:30 pm

hi!!
first of all, thanks Giorgio and all the contributors for this firefox extension.

since 2 days, the new webmail interface of my account is not in beta anymore.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
NoScript 10.1.9.6rc3

the login page:
https://login.live.com/
Code: Select all
+live.com
+gfx.ms

or the other login page:
https://outlook.live.com/owa/
Code: Select all
+live.com
+r1.res.office365.com


i've got this error message at : https://outlook.live.com/mail/
Code: Select all
cId: DEB34CC37198487E825EBCF35364CBF6
app: Mail
st: 500
reqid: undefined
wsver: undefined
efe: undefined
ebe: undefined
et: ScriptLoadError
esrc: Script
err: ScriptLoadError: Failed to load script: https://owamail.azureedge.net/owamail/20180910.04.02/scripts/owa.mail.js
estack: undefined
ts: 20/09/2018 15:01:05


i edit my post, cause i forgot to look in the firefox console:
Code: Select all
Blocage d’une requête multiorigines (Cross-Origin Request) https:  //ow1.res.office365.com/owamail/20180910.04.02/scripts/owa.mail.js
Blocage d’une requête multiorigines (Cross-Origin Request) https:  //owamail.azureedge.net/owamail/20180910.04.02/scripts/owa.mail.js


Code: Select all
+live.com

and there is no possibility in the menu to allow "ow1.res.office365.com" or "owamail.azureedge.net"

adding manually "ow1.res.office365.com", then it works at: https://outlook.live.com/mail/inbox
Code: Select all
+live.com
+ow1.res.office365.com


maybe, "ow1.res.office365.com" (and "r1.res.office365.com" too) should be in the default whitelist (noscript faq 1.5 - 11) ?

if it could help...
kinet1c
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
kinet1c
 
Posts: 4
Joined: Thu Sep 20, 2018 5:14 pm

Re: Outlook and new webmail interface

Postby kinet1c » Wed Oct 10, 2018 3:30 pm

screenshots with:
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0 62.0.3
NoScript 10.1.9.7rc3
CookieAutoDelete 2.2.0
uBlock Origin 1.17.0

the login page:
Image

or the other login page:
Image
Image

error message at :
Image
Image

adding manually "ow1.res.office365.com", then it works :
Image

noscript doesn't detect the need of script from "ow1.res.office365.com" or "owamail.azureedge.net"
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
kinet1c
 
Posts: 4
Joined: Thu Sep 20, 2018 5:14 pm


Return to NoScript General

Who is online

Users browsing this forum: Google [Bot] and 2 guests