Firefox linux, Never Remember History disappears icon

General discussion about the NoScript extension for Firefox
Post Reply
x1097
Posts: 5
Joined: Fri Oct 20, 2017 8:41 am

Firefox linux, Never Remember History disappears icon

Post by x1097 » Fri Dec 18, 2020 4:47 pm

Ubuntu 18.04 x64
firefox 84 x64
Noscript 11.1.6
All other settings at Firefox defaults and NoScript defaults.

I use multiple profiles with Firefox.

I have a reproducible way to cause the Noscript toolbar icon to disappear from the Firefox toolbar.

The usual recovery methods do not work to restore the NoScript icon to the toolbar.
(i.e. restart safe mode, quite, restart normal mode, uninstall+reinstall Noscript, Enable/Disable Noscript).

Here are my steps:

firefox -ProfileManager
> create a new profile (non default) example name newProfile (any valid name will do)
> Exit the ProfileManager (quit, return to bash shell)
firefox -P newProfile -new-instance &
about:addons
install NoScript Security Suite, add to firefox. (The toolbar icon for NoScript now appears immediately).
close firefox
firefox -P newProfile -new-instance &
(the NoScript icon is visible in the toolbar of firefox now)
firefox menu > Preferences > Privacy & Security > History > Firefox will "Never Remember History"
"Firefox must restart to enable this feature" > Restart Firefox now
-on subsequent restart, the NoScript icon has disappeared.



Note 1: if I reverse the sequence , i.e. for a newly created profile to first change to "Never Remember History" setting, quit, restart firefox, then install NoScript then its icon will not appear on the toolbar.

Note 2: on another profile on the same hostname, firefox shows the NoScript icon in the toolbar.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0

barbaz
Senior Member
Posts: 9792
Joined: Sat Aug 03, 2013 5:45 pm

Re: Firefox linux, Never Remember History disappears icon

Post by barbaz » Fri Dec 18, 2020 5:01 pm

If you want NoScript to appear/work in that context, you must go Tools > Add-ons Manager > NoScript, set "Run in Private Windows" to "Allow".
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply