[RESOLVED] problem here

Ask for help about NoScript, no registration needed to post
bug

[RESOLVED] problem here

Post by bug » Sun Mar 22, 2009 5:03 pm

see this please :

JavaScript Error – JavaScript is Disabled.

Description: This site uses a limited amount of JavaScript. In some applications and Web pages, JavaScript is essential to proper functionality of the Web page. Please have JavaScript Support turned on (Netscape Navigator and Mozilla Firefox) or download a third party JavaScript Engine (Internet Explorer). In the case of Internet Explorer, if you need to download a JavaScript Engine for use on a certain page, Microsoft (Active X) will force a download utility to start. Chooose "Yes" and download the JavaScript Engine.

Once you have enabled JavaScript, select the following link to revisit the page you came from.


it wasn't happen in older versions but i don't remember exactly what version here the site http://seba14.org i wish this fixed next version.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

Alan Baxter
Ambassador
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: problem here

Post by Alan Baxter » Sun Mar 22, 2009 5:18 pm

Use the NoScript menu to Allow seba14.org. The site works for me if I do that.
NoScript 1.9.1.2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

bug

Re: problem here

Post by bug » Sun Mar 22, 2009 7:28 pm

yes i know that but what i means if i choose allow seba14.org then i can't use right click on any link ,in previous versions right click on any link then i can use it ,is there any fix to that please?
THANKS
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

Alan Baxter
Ambassador
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: problem here

Post by Alan Baxter » Sun Mar 22, 2009 8:25 pm

Well, that is curious! I can't right-click on any link either. And that's in a brand new test profile: default theme and no extensions at all. It's not a NoScript problem after all. If right-click used to work on that site, it looks like the site changed something. Maybe they added a JavaScript that disables right-clicking. Make sense?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

User avatar
Giorgio Maone
Site Admin
Posts: 8716
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: problem here

Post by Giorgio Maone » Sun Mar 22, 2009 8:34 pm

What about unchecking Tools|Options|Content|JavaScript|Advanced|Allow scripts to replace or disable context menus?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

bug

Re: problem here

Post by bug » Sun Mar 22, 2009 8:37 pm

yes understand ,but i wish u found solution for sits like that.

Thanks Man
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

bug

Re: problem here

Post by bug » Sun Mar 22, 2009 8:42 pm

Giorgio Maone wrote:What about unchecking Tools|Options|Content|JavaScript|Advanced|Allow scripts to replace or disable context menus?


yes ,its works now i appreciate your help thanks for your help.

Many Thanks and Best Wishes.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

Alan Baxter
Ambassador
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: problem here

Post by Alan Baxter » Sun Mar 22, 2009 8:45 pm

You're welcome. I'm glad Giorgio remembered the fix for that.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

User avatar
GµårÐïåñ
Lieutenant Colonel
Posts: 3339
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA
Contact:

Re: problem here

Post by GµårÐïåñ » Thu Apr 09, 2009 3:30 am

This is and has always been a solution for me. I bypass these kinds of JS implemented blocking very effectively in Fx. To further assist anyone, you can also install the JavaScript Options addon which integrates with Fx to give another interface for changing JS behavior as well. Just for the record: the built-in JS option of Fx now does not show "allow change image" since it breaks the function of map software like Google and Mapquest and so on, but the JSO addon WILL show you this option but I recommend you leave it intact if you want the map functions. This was provided just to be thorough.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
________________ .: [ Major Mike's ] :. ________________
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 NoScript/1.9.1.7 FlashGot/1.1.8.5 FirePHP/0.2.4

Post Reply