2.0.4 and Google Products (Webmasters, iGoogle)

Ask for help about NoScript, no registration needed to post

2.0.4 and Google Products (Webmasters, iGoogle)

Postby Suser » Fri Oct 29, 2010 10:42 am

Hi Giorgio:

First of all thanks a lot fo No Script. Great tool. A must have

I´ve been using No Script for the last 6 months and today i got the autoupdate to 2.0.4 and im experiencing problems when viewing Google Webmasters and iGoogle. Google is on my white list of course and everything is set as always but Webmasters page is showing in disorder. When I De-activate No-Script (The whole plug-in) i can see Webmasters and IGoogle fine again. And using the previous version of No Script i was able to watch them fine too. Since yesterday version 2.0.4 is giving me these issues.

I was trying to go back to previous version but it seems is not possible. Could you confirm this. Im pretty sure is "No Script" the one crashing with those pages but my apologize if im wrong about it ;)

Thanks for your support

Cheers
Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Suser
 

Re: 2.0.4 and Google Products (Webmasters, iGoogle)

Postby Suser » Fri Oct 29, 2010 10:54 am

Well, i can be more specific :) ....the problem is that when viewing those google pages they show in text mode, without any format.

i De-activate No Sript (and reinitiate firefox) , and it shows ok,
activate it (and reinitiate firefox), and it shows in text mode, no format
Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Suser
 

Re: 2.0.4 and Google Products (Webmasters, iGoogle)

Postby Giorgio Maone » Fri Oct 29, 2010 1:05 pm

I could not reproduce on iGoogle, but I could on webmasters tool.
This is due to a server-side error, i.e. the stylesheet for that page is served with the wrong Content-type header ("text/plain" instead of "text/css") and the "X-Content-Type-Options: nosniff" header is sent, prompting NoScript to apply stricter content-type checks:

Request:
GET /webmasters/tools/css/3376195746-wmt.css HTTP/1.1

Response:
HTTP/1.1 200 OK
Expires: Sun, 28 Nov 2010 12:55:39 GMT
Last-Modified: Thu, 28 Oct 2010 01:47:07 GMT
Content-Type: text/plain
Content-Encoding: gzip
Date: Fri, 29 Oct 2010 12:55:39 GMT
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
Server: GSE
Cache-Control: public
Content-Length: 14745
Age: 9


This should be fixed by Google, but if you can't wait you can disable X-Content-Type-Options support by setting the noscript.nosniff about:config preference to false.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
User avatar
Giorgio Maone
Site Admin
 
Posts: 8640
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: 2.0.4 and Google Products (Webmasters, iGoogle)

Postby Giorgio Maone » Fri Oct 29, 2010 1:35 pm

Update:
I've just talked with a Google employee friend of mine, and he filed an internal bug saying it will be fixed soon.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
User avatar
Giorgio Maone
Site Admin
 
Posts: 8640
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: 2.0.4 and Google Products (Webmasters, iGoogle)

Postby Guest » Fri Oct 29, 2010 11:26 pm

Giorgio Maone wrote:Update:
I've just talked with a Google employee friend of mine, and he filed an internal bug saying it will be fixed soon.


Great Giorgio. Great tool and great support. Let´s wait for google then, im sure they will fix it soon. I can browse that page with chrome in the meantime, so i don´t have to deactivate anything inside No Script.

Cheers
Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Guest
 

Re: 2.0.4 and Google Products (Webmasters, iGoogle)

Postby RefugeDenied » Wed Nov 10, 2010 5:01 am

More than a week later and it's still not fixed on Google's end ...
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0C)
RefugeDenied
 

Re: 2.0.4 and Google Products (Webmasters, iGoogle)

Postby Giorgio Maone » Wed Nov 10, 2010 8:40 am

RefugeDenied wrote:More than a week later and it's still not fixed on Google's end ...

It's worked around on NoScript's end, though: please check latest development build.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
User avatar
Giorgio Maone
Site Admin
 
Posts: 8640
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy


Return to NoScript Support

Who is online

Users browsing this forum: No registered users and 26 guests

cron