Launch FF go to NoScript Homepage every time

Ask for help about NoScript, no registration needed to post
wozofoz

Launch FF go to NoScript Homepage every time

Post by wozofoz » Thu Apr 02, 2009 6:20 am

Hi, first thanks for NoScript, it's great :)

I installed v 1.9.1.6 and now every time I launch Firefox I get 2 Tabs, one is my Homepage and the other 'active' Tab is your NoScript Homepage.
To put it another way, it is doing what it usually does when NoScript is updated but doing it every time I launch FF

I have tried restarting my laptop, disabled then enabled NoScript, re-installed v 1.9.1.6
Am I missing something :?:

All the best, woz of oz
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

Alan Baxter
Ambassador
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: Launch FF go to NoScript Homepage every time

Post by Alan Baxter » Thu Apr 02, 2009 6:43 am

Firefox supports multiple tabs for a home page: a list of urls separated by the "|" character. The NoScript home page may have been accidentally added somehow. Check Tools > Options > Main > Home Page to see if it's there. Reset your home page by closing all of the tabs except the one you want as a home page, and press the "Use Current Pages" button in the Options dialog. Or just drag the tab containing the desired home page onto the "Home" toolbar button.

Hope this helps. Please let us know whether it does.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

Charley M
Posts: 19
Joined: Tue Mar 31, 2009 4:35 am

Re: Launch FF go to NoScript Homepage every time

Post by Charley M » Thu Apr 02, 2009 6:53 am

Shouldn't be happening, because of the way NS checks for its own "you've been upgraded" message preference before throwing up that page.
Someone else had the problem though and it's been covered by the developer in a recent post.
Pretty comprehensively too.

viewtopic.php?f=7&t=161#p494

chaz the spaz :-)
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032711 Ubuntu/8.04 (hardy) Firefox/3.0.8

Alan Baxter
Ambassador
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: Launch FF go to NoScript Homepage every time

Post by Alan Baxter » Thu Apr 02, 2009 6:56 am

Thank you, chaz. That's even better. Bookmarked now.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

Guest

Re: Launch FF go to NoScript Homepage every time

Post by Guest » Thu Apr 02, 2009 1:52 pm

Hi, thanks for the help :)
I followed the link supplied by Charley M and followed the testing.
When I changed my FF Tools>Options>Main preference to 'Show a Blank Page' this did not 'stick' and it returned to 'Home Page' when I relaunched FF, so it seems my Profile was corrupt.
I read the instructions and was confused, I searched around and found some more instructions for creating a new Profile and deleting the old but I could not understand most of what was written, I'm old and new to computers ;)

So, I tried the long and winding road:
• I went to FF Bookmarks>Organize Bookmarks>Import and Backup>Export HTML and saved my Bookmarks to the Desktop.
• I uninstalled FireFox using RevoUnInstaller and set it for the full clean out. Sorry, I can't remember the name but it is the bottom option on the page.
• Restarted my Netbook
• Downloaded and installed FireFox
• Installed NoScript then restarted FF
• Exited FF and launched it again and only my HomePage came up, all is good :lol:
• Bookmarks>Organise Bookmarks>Import and Backup>Import HTML to get my Bookmarks back
• Installed my FF theme and AdBlock Plus
• Had a cup of coffee and thought what a great day it is :D
• Wrote this message

I guess there was an easier way like deleting the Default folder or something but I feel good about starting afresh and FF does seem 'snappier' or maybe it's just that my mood is better ;)

Thanks again for taking the time to help me it is very much appreciated :)

All the best, woz of oz
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

wozofoz

Re: Launch FF go to NoScript Homepage every time

Post by wozofoz » Thu Apr 02, 2009 1:55 pm

Sorry, I forgot to mention that I tried all the other stuff, turn off Anti-Virus etc, before I concluded the Profile was corrupt.
Thanks again :)

All the best, woz of oz
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

Charley M
Posts: 19
Joined: Tue Mar 31, 2009 4:35 am

Re: Launch FF go to NoScript Homepage every time

Post by Charley M » Thu Apr 02, 2009 2:29 pm


I read the instructions and was confused, I searched around and found some more instructions for creating a new Profile and deleting the old but I could not understand most of what was written, I'm old and new to computers ;)

So, I tried the long and winding road:
[...]snip

• Had a cup of coffee and thought what a great day it is :D
• Wrote this message

I guess there was an easier way like deleting the Default folder or something but I feel good about starting afresh and FF does seem 'snappier' or maybe it's just that my mood is better ;)

Thanks again for taking the time to help me it is very much appreciated :)


No wuckas woz,
Looks to me like you did understand the general idea and then taught yourself a lot more than a set of instructions would have, ay. The general idea with profile corruption is to hoik everything anyway (except the big ticket unreplaceables like bookmarks).
Koala stamp for you mate.


chaz the spaz
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032711 Ubuntu/8.10 (intrepid) Firefox/3.0.8

Post Reply