Page 1 of 1

1.9.9.05 Hides All HTML

Posted: Fri Oct 02, 2009 8:07 am
by Aerik
Giorgio, what have you done? I updated from 1.9.9.01 to 1.9.9.05 and somewhere in there you made some kind of CSS error or something that makes it so that all the internet is hidden from view. If I hadn't had 1.9.9.01 saved as a backup, I'd have had to view-source: the 'previous versions' page at AMO to get it back. And this is the stable release youv'e put up at noscript.net. Uncool.

Re: 1.9.9.05 Hides All HTML

Posted: Fri Oct 02, 2009 8:43 am
by Giorgio Maone
Aerik, I believe you're wrong.
There's nothing new in 1.9.0.5 affecting CSS loading or HTML rendering, and nobody else reported anything like that beside you.
You're probably observing something else at work.
Did you see any error in Tools|Error Console?

Re: 1.9.9.05 Hides All HTML

Posted: Fri Oct 02, 2009 7:15 pm
by Aerik
Nothing in the error but the normal stupid errors from the Shareaholic and betterprivacy extensions that are always there, but don't seem to affect their functionality. And I've tried disabling all extensions but noscript, so I know noscript is the problem.

Re: 1.9.9.05 Hides All HTML

Posted: Fri Oct 02, 2009 7:22 pm
by Giorgio Maone
Aerik wrote:And I've tried disabling all extensions but noscript, so I know noscript is the problem.

Did you try on a clean profile with just NoScript?

Re: 1.9.9.05 Hides All HTML

Posted: Fri Oct 02, 2009 7:24 pm
by Aerik
I found the exact setting(s) that cause my problem.

It's my old friend, noscript.forbidIFramesContext . All html disappears if "disable iframe" is checked and noscript.forbidIFramesContext = 0 .

Re: 1.9.9.05 Hides All HTML

Posted: Fri Oct 02, 2009 11:01 pm
by Giorgio Maone
OK, confirmed, thanks.
It will be fixed in next dev build (fortunately you seem to be the only one using that extra-paranoid setting).

Re: 1.9.9.05 Hides All HTML

Posted: Sun Oct 04, 2009 9:40 pm
by Giorgio Maone
Fixed in 1.9.0.6.