Firefox stops loading pages until NoScript disabled or Firefox restarted

Ask for help about NoScript, no registration needed to post
User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Fri Jun 03, 2022 3:42 pm

(In my case, I keep FF updates "blocked".
[At least, I set app.update.channel to something bogus.
Now that doesn't stop an attempted check for updates, but at least, seemingly, none should come through.])
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.13

BigWayne
Posts: 3
Joined: Fri Jun 03, 2022 11:35 pm

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by BigWayne » Fri Jun 03, 2022 11:40 pm

I have the same problem as the OP. It has been going on for months but i just now tied it back to being due to NoScript.
I had just been fixing it by restarting Firefox, but that is a big pain to do when I have a lot of tabs going.
I had noticed it seemed to always do a Firefox update when I did the restart, so maybe that is part of it.
I have turned off FF auto update now and will see if that improves things.

Right at this second, when I disable NoScript, pages load immediately. Then if I turn it back on, it breaks again immediately.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

arabflavor
Posts: 4
Joined: Sat Jan 08, 2022 12:19 pm

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by arabflavor » Mon Jun 06, 2022 7:47 am

I have been using firefox for years now but I never faced this type of issue until recently (or maybe I never noticed it before but it's hard not to notice such a significant issue). I updated my firefox and it's loading fine now. I thought it is just me but a lot of you are facing the same issue maybe it's some sort of firefox bug or something. I cannot tell. Hopefully, someone can come up with a solid solution. Do not forget to report it to firefox as well, so that if it is a firefox bug they can fix it.
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.63 Safari/537.36

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Thu Jun 09, 2022 7:08 pm

Any ideas on how to diagnose this?
Could browsing (primarely, but not exclusively) in a Private Window be part of the issue?

To note, about:memory, Measure, does not measure (i.e., nothing is returned*).
Various other about:'s do seem to work.
(*Actually, it eventually simply returned, "No results found.".)

Could the fact that I do not use Profile Manager be part of the issue?
(Instead firefox -profile PROFILE)

Code: Select all

Error: Can't find profile directory. XULStore.jsm:66:15
    load resource://gre/modules/XULStore.jsm:66
    XULStore resource://gre/modules/XULStore.jsm:24
I can do DNS Lookup's, about:networking#dnslookuptool, just can't load any web pages.
I can load & do things on my NAS, http://10.0.0.9:5000/
Unregistering "service workers" made no difference.

Image
(I would have posted this using FF, but I can't :twisted:.)

During this period of time, I really couldn't determine if NoScript was enabled or not, & I'm still not really sure?
about:addons, enable/disable wasn't... wasn't... determinable. Sometimes it would say disabled, yet the NoScript icon remained. And then I would get it "disabled", icon gone, only for the next moment, the icon was back, & page loading stopped - all by itself...

Image


(Absolutely incredible how much sheat is in FF nowadays. Peruse some of those about:'s, like about:telemetry.
Use sync? Even if you don't, it's still working on your behalf. Wonderful.)


When broken, neither http: nor https: load (on the WAN).
(I'd try ftp:, but yeah, heh.)
I can load, file:///c:/tmp/xxx.txt.


And to top it off, FF hung in memory when I Quit.
Oh, wait, it's now gone. Took a long time to exit memory. (I didn't pay attention to memory usage.)
(Putting in 101.0.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.13

BigWayne
Posts: 3
Joined: Fri Jun 03, 2022 11:35 pm

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by BigWayne » Sun Jun 12, 2022 4:40 am

It is not related to private windows as I never use those and get this problem repeatedly. I did have better luck for a bit when I disabled automatic firefox updates. Then, as soon as I downloaded an update, it happened again.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

BigWayne
Posts: 3
Joined: Fri Jun 03, 2022 11:35 pm

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by BigWayne » Mon Jun 13, 2022 2:23 pm

Well now it is happening to me more frequently and is not being triggered by Firefox updates.
Remains the same, disabling Noscript instantly lets the pages load. Turning Noscript back on brings the problem back right away.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Fri Jun 17, 2022 5:51 pm

FF has been open, oh, for a few days or so.
Along with various (computer) sleep/awake cycles during that time.
(Oh, didn't realize that Process Hacker can give historical uptime [for FF], so, 3 days and 23 hours ago.)

During that time, mainly had been using FF to access my NAS "software".
Thinking, I did that as recently as yesterday.

Anyhow, still open, just now I go to load a website, & nothing.
Not even able to get into my NAS, 10.0.0.13:5000/index.cgi#/signin.

So...

about:addons, "click" disable

NoScript icon goes away (so I suppose NoScript has been disabled ?)
- but, oh, OK, after jumping away then coming back, about:addons now shows as grayed out & "disabled" (where a moment ago it did not - so initially I wasn't sure just where I stood...)

So...

assuming disabled, I should (again) be able to load websites... ?

Yes.

And by the same token...

Enable NoScript in about:addons, &...

And with that, again, can't load anything.

---

Nothing special going on; system-wise or FF specific.
No undue CPU or RAM usages.
(19 FF processes, 1.6 GB RAM, so that's nothing, & essentially 0% CPU.)
No different usage patterns in general. I do what I do, & that's it.
(On 6-8-2022, I installed some video drivers [for not, as it turns out], & prior to that, I'd not rebooted in 47 days.)


---


Things like; view-source:resource://gre/actors/ViewSourceChild.jsm, do continue to work.
Though context-menu, Copy all Messages (from Browser Console) fails.
While at the same time, I can Copy (individual) Message.

Code: Select all

Security Error: Content at moz-extension://6460bdcc-7826-4318-b961-f1779c7da8b4/ attempted to load chrome://global/locale/intl.css, but may not load external data when being used as an image.

NS_NOINTERFACE: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface] network-events-content.js:66
    httpFailedOpeningRequest resource://devtools/server/actors/resources/network-events-content.js:66
    httpFailedOpeningRequest self-hosted:1115

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.loadURI] ViewSourceChild.jsm:146
    loadSourceFromURL resource://gre/actors/ViewSourceChild.jsm:146
    loadSource resource://gre/actors/ViewSourceChild.jsm:120
    viewSource resource://gre/actors/ViewSourceChild.jsm:67
    receiveMessage resource://gre/actors/ViewSourceChild.jsm:21

TypeError: toolbox is null
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.13

M-R

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by M-R » Sun Jun 19, 2022 6:27 am

Hello! I had the same problem today. I have a lot of open tabs, some in a private window some not, and I keep firefox open for a long time between reboots. Today, after 4 days from the last reboot, firefox stopped loading any page. And I mean any page, everything, it couldn't even refresh the pages that were cached (the pages didn't disappear, but the "loading" icon stayed on forever)

I the same moment everything else worked perfectly, other programs could get online without any hassle.

I could not find a solution for hours until I tried switching noscript "off" on the add-on page, and every page loaded immediately, even the ones that were loading for hours. I switched noscript "on" again... and the pages stopped loading. I switched noscript off and on again... but this time the PC hang for a while, turning noscript on did consume too much memory. After a while the PC un-froze... and everything is working normally. I thought that noscript was still "off" but after checking it I( saw that it was turned "on". I don't know what happened, but I hope that this can help somebody figure the problem...
Mozilla/5.0 (X11; Linux x86_64; rv:101.0) Gecko/20100101 Firefox/101.0

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Mon Jun 20, 2022 3:01 pm

I'll note that my Profile is NOT in a "standard" location.
Nor am I even using Profile Manager.
(Instead, firefox -profile PROFILE.)



(I have not restarted FF... [from the other day])


So I go to see if I happen to be able to connect...

I open a (new) Private Window, attempt to load google.com
AND
I get an ADD for Firefox Focus.
(What hog !!!!)

Code: Select all

1655735927861	app.normandy.action.PreferenceExperimentAction	WARN	Skipping recipe Search Experiment: Measuring the Impacts of Different Search Providers because PreferenceExperimentAction was disabled during preExecution.
1655735927871	app.normandy.action.PreferenceExperimentAction	WARN	Skipping recipe Search Experiment: Measuring the Impacts of Different Search Providers - Part 2 because PreferenceExperimentAction was disabled during preExecution.
1655735927879	app.normandy.action.PreferenceExperimentAction	WARN	Skipping recipe Impact study for Total Cookie Protection (TCP) because PreferenceExperimentAction was disabled during preExecution.
1655735928118	app.normandy.action.BranchedAddonStudyAction	WARN	Skipping recipe DoH US Engagement Study V2 - Add-on helper because BranchedAddonStudyAction was disabled during preExecution.
[code]
(So FF attempts "experiments" - even though I have that crap disabled.  What hog !!!!)

[code]
Error: Can't find profile directory. XULStore.jsm:66:15
    load resource://gre/modules/XULStore.jsm:66
    XULStore resource://gre/modules/XULStore.jsm:24

Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xhtml

TypeError: event.target.closest is not a function    UrlbarInput.jsm:3024:26
_on_mousedown resource:///modules/UrlbarInput.jsm:3024
    handleEvent resource:///modules/UrlbarInput.jsm:446
Image
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.13

NikosE

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by NikosE » Mon Jun 27, 2022 4:49 am

I have exact same problem. I also use "-profile X:\folder" but I don't know if that matters.

Happens every day. Disable NoScript and everything works again.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0

Curly

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by Curly » Tue Jun 28, 2022 2:46 am

The same thing has been happening to me for months. Firefox stops being able to load pages. I try the same page in Edge and it loads fine. I go back to Firefox, disable NoScript, and the page loads immediately. Then many times NoScript re-enables itself and pages won't load again. I disable NoScript, page loads, NoScript re-enables itself. Repeat ad nauseum. NoScript is the only extension I have installed. It makes no difference what page I'm trying to open; once it gets into this state, they all fail to load.

If I close Firefox, wait for all instances to disappear from Task Manager, restart it, everything is fine for a while until eventually pages won't load again.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Tue Jul 05, 2022 9:01 pm

So I've been contemplating... do I or don't I?
Do I come in here & say, oh, since I created a "new" Profile, it hasn't happened... ?
Do I or don't I?


Well before I had the chance to do that, I can firmly say, "it is not working" - kind of.

Still on 101.0.1 (purposely did not update to 102, now 102.0.1 - because I didn't want to restart).

So... a week ago (12:39:03 PM 06/22/2022), I created a "clean" Profile.
Took my existing & deleted EVERYTHING - except for places.sqlite, cookies.sqlite - only cause they held my history...

Since then, all has been fine.
FF has not been opened, has not been closed.
Is not using undo CPU (almost none, actually), nor undo RAM 2.5 GB (& 47 FF processes).

The other day, I could not reach (even ping) palemoon.org.
Not in FF, not in SeaMonkey, not from other computers, not after restarting my modem & router, doing IPCONFIG stuff.
That lasted a few days.
With that, I figured it was my something on my ISP's end. (I did not have DoH enabled).
With FF, it was kind of easy to check that. Enable DoH, & palemoon.org fired right up.
With SeaMonkey, a little harder, so I didn't try.
Anyhow, a couple of days after that, SeaMonkey too - without change or restart, was also able to reach it.
Again, I attribute that to an ISP issue (that they must have cleared on their own).
(I would have called Comcast, but have you ever tried ;-).)


So here I am, now, do I or don't I... ?

And literally, up to a few minutes ago, all was good.
Doing nothing special, just some lazy browsing. Youtube, where I rarely go. Imgur, where I rarely go.
Other odd sites, here & there. Not trying to push anything...
(Previously, during the past week, I did purposely open sites that I would normally open in SeaMonkey, in FF [given that I rarely run FF], just to see if I could get things to break - but I couldn't.)

So just now, as I'm about to go (i.e., leave - & instead, I am here), for whatever reason I clicked something in FF, & guess what?
Nada! Nothing! Zip! Zilch!
Can't load google.com. Can't load noscript.net nor informaction.com nor anything* else!


You heard that, didn't you?


*Anything

Anything.
For whatever reason, I clicked Help | About FF.
And in that dialog is something that says, "Firefox Help".
And for whatever reason, I clicked it, & lo & behold, it LOADS, https://support.mozilla.org/en-US/produ ... =inproduct.

And I'm like, what?
(Still) Can't load google.com. Can't load noscript.net nor informaction.com nor anything* else!

Yet I *can load "support" (cough) pages from that page that did open?

*Can

As I'm typing this (kind of timely), so I again go through those steps, yet this time "Firefox Help" does NOT load?
How's that for confusing.
So I type more here...
And I go back & try it yet again, & this time it does load.
(Still) Can't load google.com. Can't load noscript.net nor informaction.com nor anything* else!
And I can (again) load various (cough) support.mozilla.org pages.

Network.
Use system proxy settings.
DoH is not enabled. NoScript is enabled.
about:addons -> (click to disable) NoScript... Takes time to register, to go from blue to gray.
Google.com fires right up.
Enable, & browsing is now *dead.

*Dead.
But support.mozilla.org - still works!


Enable DoH (Cloudflare) & NoScript enabled...
*Dead.
But support.mozilla.org - still works!
(I just canceled my subscription to MDN Plus & recommend that all do so too, https://support.mozilla.org/en-US/kb/ho ... n-mdn-plus.)


So there you go.
I eeked out 1 weeks worth of usage before FF died on me (again).


And now that it has died... I shall stick in 102.0.1, necessitating a (FF) restart, so I should be good for another... week?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.13

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Mon Jul 18, 2022 6:03 pm

a week ago (01:45:43 PM 07/06/2022)

"new" Profile in FF's default location & profile name (where ever & whatever that/they may be)
i kept existing places.sqlite, cookies.sqlite... & that's it.

its been running (since 7-6-2022), was running fine on Friday, & running fine today too - until just now, when it simply, STOPPED (opening sites).

oh wait, 5 minutes (ok, ok, 4.59 minutes) it took from when i (opened F12 &) typed in "www.google.com", it finally loaded.
& i search for "ncmain.exe", & it too loaded.

so... seems i was only dead for 5 minutes - this time.


(looks like i need to [continue] to keep it open, till it dies for good)


& just that quick, dead again...

HTTPS-First Mode: Upgrading insecure speculative TCP connection “http://www.gena01.com/” to use “https”.
HTTPS-First Mode: Upgrading insecure request “http://www.gena01.com/” to use “https”.
Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”). 2 chrome:511:24
Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”). chrome:62:22
Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”). 2 chrome:511:24
Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”).


& at this point FF is using 15% CPU & site load (more often, not) is erratic (to say the least).

(once again) https://support.mozilla.org loads
but not www.google.com

could it be particular websites that are triggering whatever is happening?
if so, maybe peruse https://www.franchot.com/
I can't even get through all of its 'About' items before hitting at least some periods of non-loading
maybe open 2 tabs, 1 with franchot, 1 with google
go down franchot 'About' till things "stop"
then try a google search for "abc" - tab should reflect same (or maybe it will - if the page ever loads)
anyhow, /if/ the 2 pages should ever load, the tab change might clue you in on the fact that it has (without actually looking at it)

& throughout all of this support.mozilla.org/... still continues to load - when nothing else will

& FF is eating CPU (which i have not see before)
on franchot, i just loaded the page & Temporarily Allowed whatever showed up - once

even though on google, i "changed" the search term, & given that things are currently dead,
the only thing logged is the initial search, not my new term (which is "go go")
curl "https://www.google.com/search?gbv=1&q=abcde&oq=&aqs=" -H "User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:102.0) Gecko/20100101 Firefox/102.0" ...

9.82 min later, google search of "abcde" finally loaded
likewise, CPU dropped to nil

during that time, i couldn't even Revoke Temporary Permissions,
instead getting a non-modal (NoScript) dialog (which someone else here recently saw...)
viewtopic.php?f=7&t=26690

---

i cut the grass, it's now 3:32 PM, & FF is officially deal - it ain't loadin' a no'more.

got 1 (FF) process using 12% cpu & 2.5 GB...
kill that *1* process & i'm back in business
(in no time in the past did i have high CPU & huge RAM like that)

1 tab did show a crash, but no associated crash report
i'm back in business
short lived!

well, that page, franchot, certainly does generate high CPU - at times
& that may very well be affecting things
- but that said, before today, i'd never been to /that/ page

piece of drek website
wonder how Chrome fares there?

with that site - in a different (not new, different) Profile, i quickly killed that Profile too
so maybe that site will give you something to work with?

likewise, this time, FF gave me a "This page is slowing Firefox...".
("Stop", made no difference)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.13

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Mon Aug 01, 2022 7:34 pm

Today, is 6 days.
And all had been going well.

But, FF, in its wisdom ;-), pushed out a .1.
So I (manually) download 103.0.1 & did my thing.
Quit FF (after only 6 days, instead of what had been the "normal" 7), "installed" (I don't actually "install") 103.0.1.
Fired up 103.0.1 - at which point FF opened a new Profile (instead of my existing - no clue why it does that [now, since 102->103]).
Set FF to load my existing Profile instead. (Deleted its' newly created "new" Profile.)

My existing Profile loaded fine.
I wanted to check one thing (that the Bookmarks Toolbar loaded - it does have a tendency to vanish ? it is gone, ATM), so I quit & restarted. (Restarted from Session Restore - just my typical stuff.)


And now, only "an hour ago (02:24:09 PM 08/01/2022)" FF is dead - having done nothing particularly - except browse some of my normal set of sites that I visit. Absolutely nothing out of the ordinary. I had not been trying to push anything in any way, I had visited no "crap" sites at all - just the normal sites I look at day in & day out.

This is the quickest I have ever had FF die on me.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 SeaMonkey/2.53.14

User avatar
therube
Ambassador
Posts: 7809
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox stops loading pages until NoScript disabled or Firefox restarted

Post by therube » Thu Aug 04, 2022 4:53 pm

2 days and 21 hours ago (03:38:37 PM 08/01/2022)

CPU 1.5%, RAM 33% (2.6 GB of 8 GB)

103.0.1.8245
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:103.0) Gecko/20100101 Firefox/103.0

Post Reply