Just installed noscript - where's the settings?

Ask for help about NoScript, no registration needed to post
Trip

Just installed noscript - where's the settings?

Post by Trip » Fri Aug 06, 2021 9:26 am

I've just installed noscript on firefox 90.0.2. It's enabled in the extension settings. As far as I can tell I should be able to see a noscript logo somewhere near the <-, -> and reload buttons but it's not there. Any ideas?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

User avatar
Giorgio Maone
Site Admin
Posts: 9143
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Just installed noscript - where's the settings?

Post by Giorgio Maone » Fri Aug 06, 2021 10:47 am

By default it should be on the opposite (right) side, with the other extension icons, or hidden in the overflow (">>") menu if the icons are too many.
You can move it wherever you want in the toolbar by using the "Customize Toolbar..." context menu.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Trip

Re: Just installed noscript - where's the settings?

Post by Trip » Fri Aug 06, 2021 12:03 pm

Thanks for the response.

It's not there, and it does not appear in the list of items I can move onto the toolbar in the customize toolbar context menu.

Screenshots:

https://yoyo.org/~steve/noscript1.jpg
https://yoyo.org/~steve/noscript2.jpg
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

musonius
Senior Member
Posts: 161
Joined: Sun Jul 08, 2018 5:38 pm

Re: Just installed noscript - where's the settings?

Post by musonius » Fri Aug 06, 2021 1:01 pm

Have you set the option "Never remember history" (or "Always use private browsing mode", respectively)? If this is the case, have you allowed NoScript to "Run in Private Windows" (about:addons -> there is a checkbox named that way, if you click at NoScript)?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

Trip

Re: Just installed noscript - where's the settings?

Post by Trip » Fri Aug 06, 2021 2:39 pm

Thanks - removing the 'no history' option got me the logo.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

Post Reply