Noscript 11.2.9 going highwire! over 9gigs of ram!!

Ask for help about NoScript, no registration needed to post
Maximum

Noscript 11.2.9 going highwire! over 9gigs of ram!!

Post by Maximum » Sun Jul 04, 2021 10:25 am

Image
Image
Image
Been using Noscript for more than 10 years, first time having problems with it. Taps become non responsive, new taps can't load anything unless I disable Noscript then everything works fine. How can I debug this/send stats/log info?
I feel like walking naked without Noscript enabled.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

User avatar
Giorgio Maone
Site Admin
Posts: 9130
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Noscript 11.2.9 going highwire! over 9gigs of ram!!

Post by Giorgio Maone » Sun Jul 04, 2021 10:29 am

Did you check about:performance to be sure it was NoScript and not some web content?
How many tabs were opened?
Did it start when visited some site in particular?
If so, what were your permissions?

Thank you.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0

Guest

Re: Noscript 11.2.9 going highwire! over 9gigs of ram!!

Post by Guest » Sun Jul 04, 2021 10:39 am

[img]blob:https://imgur.com/9396b22f-b5bf-491a-b346-af9f7e5f7dc5[/img]
Same tabs with Noscript disabled
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Maximum

Re: Noscript 11.2.9 going highwire! over 9gigs of ram!!

Post by Maximum » Sun Jul 04, 2021 10:47 am

Giorgio Maone wrote:
Sun Jul 04, 2021 10:29 am
Did you check about:performance to be sure it was NoScript and not some web content?
How many tabs were opened?
Did it start when visited some site in particular?
If so, what were your permissions?

Thank you.
Hi, thanks for the quicl reply.
Let me check the about:performance
But I'm very sure this came from Noscript since everything works fine after disabling it
With Noscript disabled.
Image
Opend tabs over 2000(inactive) active about 8 to 10 (always been like that and worked fine with Noscript).
First noticed this on some .blogspot sites with heavey external tweaks(custom themes..etc) then froze on FB page.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Maximum

Re: Noscript 11.2.9 going highwire! over 9gigs of ram!!

Post by Maximum » Sun Jul 04, 2021 1:10 pm

Giorgio Maone wrote:
Sun Jul 04, 2021 10:29 am
Did you check about:performance to be sure it was NoScript and not some web content?
How many tabs were opened?
Did it start when visited some site in particular?
If so, what were your permissions?

Thank you.
It is working fine for now, I'll keep an eye out for the about:performance and let you if it behaved like this again.
Many thanks for your time
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Maximum

Re: Noscript 11.2.9 going highwire! over 9gigs of ram!!

Post by Maximum » Thu Jul 08, 2021 7:53 pm

Giorgio Maone wrote:
Sun Jul 04, 2021 10:29 am
Did you check about:performance to be sure it was NoScript and not some web content?
How many tabs were opened?
Did it start when visited some site in particular?
If so, what were your permissions?

Thank you.
Hi
I've been keeping an eye on the performance and that case never happened again.
I concluded that it had something to do with cache, Firefox had 1.1GB of cache, after clearing it that issue seemed to have been resolved. I guess something about the cached content broke something and caused the issue with Noscript.
Thanks.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Post Reply