Page 1 of 2

[NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Thu Jun 10, 2021 9:15 pm
by dave9
Firefox 54, Noscript

Upon first launching Firefox, trying to go to certain secure https sites (maybe non-secure too but I've only observed it on secure) for example NoScript prevents the page from loading.

I have noticed the same behavior on other sites too, but can't recall which ones at the moment. I'll update with others as I encounter them if helpful.

Firefox shows "Page could not be loaded. The requested page could not be loaded. Check your internet connection and try again. Certain browser extensions may block pages unexpectedly." etc, etc No specific error code or message.

If in Firefox I click reload page, the page loads, and will keep reloading until firefox is closed and reopened, then the page will not load again until firefox reload button is clicked. I have cleared firefox cache numerous times.

If Noscript is disabled in firefox add-ons then firefox relaunched, the page always loads on the first try. I put the above example linked site on Noscript's whitelist, but still when this example site loads from the reload button, Noscript does not show that it is blocking anything!

If Noscript is not blocking anything then why does having it enabled prevent the page from loading on the first try, and is there a fix for this ?

Re: Page Won't Load But Nothing Showing Blocked

Posted: Thu Jun 10, 2021 9:42 pm
by dave9
More weird behavior. If I try to load the webpage and it fails, if I just close the tab, shut down firefox then restart and try again, it again fails.

If I try to load the page and it fails then I close the tab, clear the firefox cache, then shut down and restart, it loads on the first try.

If it then shut down firefox and restart, it fails to load until I clear the cache again. Once it loads, it won't load again on next firefox restart unless the cache is cleared again. This keeps happening but only if Noscript is enabled.

To recap: Firefox with noscript enabled will never load the page on the first try unless the cache is cleared beforehand, despite noscript showing nothing blocked when it does load, nothing blocked when it doesn't load, and the site it is trying to load is trusted (noscript drop down gives the option to mark it is untrusted) despite it being unable to load on first try with noscript enabled.

Re: Page Won't Load But Nothing Showing Blocked

Posted: Thu Jun 10, 2021 11:15 pm
by barbaz
We no longer support NoScript Classic. If you must continue using such insecure browser, please at least upgrade your NoScript to last Classic (5.1.9, available from for your own safety.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 12:36 am
by dave9
^ I had hopes that you were trying to be helpful, so I installed the v5.1.9 which just turned out to be a waste of time.

Nobody asked your opinion of the security of older browsers in this topic. If you would be exploited using Firefox v54 then upgrading is the right choice for you. I have no security or safety problems, this is not a critical system holding valuable data (that isn't backed up). It has never been exploited but if it were, it would take about 5-10 minutes to restore a backup. Gotta luv SSDs!

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 1:17 am
by barbaz
Showing ignorance of what exploits can do and having an attitude problem is not the way to get people to go the extra mile and help you with unsupported software. If you continue that way, this topic will be closed.

Let's try again.
dave9 wrote:
Fri Jun 11, 2021 12:36 am
^ I had hopes that you were trying to be helpful,
Those hopes were correct. The first thing to try for NoScript Classic problems on Firefox >= 45 is make sure you're running NoScript 5.1.9 (which is also a significant security update compared to and see if the issue persists. Thanks for doing that.

Since your issue does persist with 5.1.9, next thing to check is: When this issue occurs, do you see anything related in the Browser Console? (Ctrl-Shift-J)
(if you don't know what's related, turn off CSS warnings and post everything else you see)

If nothing of note shows up there, see if you can isolate which NoScript feature is causing the issue. Can you narrow it down to any one of these? -
barbaz wrote: feature whac-a-mole time?
As a test, please disable these features of NoScript, in order, one at a time, re-enabling each after testing, until the issue stops occurring:
1) XSS: NoScript Options > Advanced > XSS, un-check everything
2) ABE: NoScript Options > Advanced > ABE > un-check "Enable ABE"
-> 2a) if that works, try re-enabling ABE and setting about:config > noscript.doNotTrack.enabled to false
3) ClearClick: NoScript Options > Advanced > ClearClick, un-check everything
4) Inclusion type checking: about:config > set noscript.inclusionTypeChecking to false
5) The other XSS filter: about:config > set noscript.xss.checkInclusions to false
6) surrogates: about:config > noscript.surrogate.enabled to false

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 3:18 am
by dave9
Followed that in the order presented. Disabling ABE fixed it. Reenabling ABE then setting about:config > noscript.doNotTrack.enabled to false broke it again.

I suppose I'll have to look into the supposedly simply rules for ABE, which aren't at all simple when you don't know what the ABE is because noscript shows nothing.

I'm still wanting to know why it won't work the first time the page tries to load but clicking reload makes it work with no changes, as does clearing the cache before closing and opening Firefox to try again. There has to be some clue in that.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 4:06 am
by barbaz
With that info, I spun up a test VM with FF 54.0.1 but I can't reproduce this issue with NoScript 5.1.9 in default configuration.
(FF 54.0.1 on Linux 64-bit, new profile and new install, only modifications were to install NoScript and apply the disable-signing-requirement hack.)

If you go to NoScript Options > Export (the one *on the very bottom* of NoScript Options, *not* the one unique to the whitelist panel), and PM me the contents of that file, I would take a look when I get the chance.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 5:49 pm
by dave9
PM with export file sent, had to break it up into 2 PMs due to 60K character limitation.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 6:17 pm
by barbaz
So far I have not been able to reproduce the problem with your NoScript settings.

While testing with your NoScript settings, I noticed that the link in your OP is redirecting to ABE can be quirky regarding redirects. I wonder if something else in your Firefox profile is conflicting with how ABE handles redirects?

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 7:15 pm
by dave9
If I click the link you just posted, it does the same thing, fails to load until I click reload.

I've no idea if anything else in my profile is causing an ABE problem. I did disable add-ons in groups to see what was causing this before it was narrowed down to Noscript, after verifying that the problem doesn't occur running in safe mode. In particular I had adblock plus running and disabling that doesn't help.

The same browser config (except for some juggling of UI elements in the browser toolbar) and Noscript version was loading all sites (AFAIK) correctly before last fall. I recall reporting the issue to an admin at and rereading that report I realize that the Firefox message has changed since then.

Formerly it read "Corrupted Content" while on same site now it only reads as already mentioned, "Page could not be loaded", but on some other sites it still reads "Corrupted Content" but I don't recall which sites, "maybe" certain links to ebay.

Regardless I don't really want to give up my current profile and start over from scratch, would take far far more work to get it back to where I want it than clicking reload, even multiple times daily. I do vaguely recall that when I first started getting the Corrupted Content message last fall (on sites I practically visit daily like, I did try 2 different backups of my entire user profile made prior to that (one about a month and the other 8 months prior) and it still generated the same Corrupted Content message.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 7:58 pm
by dave9
It gets stranger still. Since the pages that won't load on 1st try, do load on first try if I clear cache before shutting down firefox, I set firefox to automatically clear the cache and offline files when it closes.

This did not work. I then looked at what I was clearing when I was clearing cache manually and it included "Browsing and download history". So I went back into the settings for what firefox does when closing and only selected to clear "Browsing and download history" and that makes it work, now loads on the first try.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 8:12 pm
by barbaz
Sorry if I missed it, but does this issue occur if NoScript is the only extension enabled in Tools > Add-ons Manager and you've restarted Firefox with -purgecaches command-line option once after setting that up?

If so, if this were happening to me the next things I'd try would get pretty invasive in the Firefox profile. Do you have a disposable/snapshotted virtual machine running Firefox 54 with a profile where you can reproduce this issue?

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 8:40 pm
by dave9
Is this the correct syntax? "C:\Program Files\Mozilla Firefox\firefox.exe" -purgecaches

If so then I just tried that. If Noscript is the only extension enabled, it does still fail to load on first try but still load if I click the reload button, and the same is true if I add the above -purgecaches to restart it.

I don't have a VM running to do the rest of what you describe, but if I did and a new/clean profile with only Noscript did not reproduce the problem, then I am about at the end of what I'd be willing to do as clicking reload, or even losing all my browsing history when I close firefox, is far less significant to me than starting over with a new profile... It took years to build this profile up to where i want it and while I could probably graft some of the old profile on a bit at a time and test that, still a significant additional job to do it.

It makes me wonder if there is a way to make firefox forget the history for only 'sites that won't load on first try, "IF" that would resolve it.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Fri Jun 11, 2021 10:00 pm
by barbaz
dave9 wrote:
Fri Jun 11, 2021 8:40 pm
Is this the correct syntax? "C:\Program Files\Mozilla Firefox\firefox.exe" -purgecaches
Looks right to me.
dave9 wrote:
Fri Jun 11, 2021 8:40 pm
starting over with a new profile
That's not how I roll. 8-)

It sounds like you and I feel the same way about our profiles. I've held tenaciously to my current main profile for longer than I've been on this forum, carrying it through many different Firefox/Gecko-based applications (including some pre-releases), and I've had my share of tricky issues I've ferreted out and corrected without starting over.

Let me outline my method and based on that, you can decide whether you want to continue troubleshooting this or just tolerate automatic clearing history. I follow these steps, in order, checking after each one whether the issue exists, until pinning down the culprit(s).

*** Again, I would *not* do this in a production or otherwise non-disposable environment. ***


0) Completely quit Firefox and make a backup copy of your main profile. The following steps will involve deleting and replacing stuff from the profile folder, and if nothing else it will be more convenient to have the pristine copy available throughout this.
Also, make sure to always completely quit Firefox before making any manual changes to a profile.

1) Try a new, separate, clean profile with only NoScript (you might consider temporarily disconnecting from the Internet to avoid Firefox auto-updating before you can disable that). If the issue exists here, there is no point continuing on with these steps. If it doesn't exist...

2) Back to your main profile, move or rename prefs.js (and user.js if it exists). Create a new user.js with ONLY the following contents (this should be just the very minimum necessary to disable updating) -

Code: Select all

user_pref("", false);
user_pref("app.update.enabled", false);
Start Firefox with -purgecaches command-line option.

3a) If the issue is gone after (2): Keep the minimal user.js in place to disable updating. Put back your prefs.js and bisect it: delete about half the user_pref lines, and then restart with -purgecaches command-line option. If issue is still gone there, replace with only the other half and test with -purgecaches. Repeat descending into each half, being sure to use -purgecaches after every manual change.

3b) If the issue still exists after (2): Bisect all the top-level files and folders in your profile, except the minimal user.js for disabling Firefox updates. Delete about half the files, start Firefox with -purgecaches after every manual change and re-install NoScript or re-confirm the install of NoScript as needed. If no issue, put back the first half and delete the other half instead. Repeat descending into halves based on occurrence of the issue, again being sure to use -purgecaches after every manual change.

4) If the issue is profile-specific, at this point you should know what it is. Confirm the culprit by replacing your entire profile with a copy of the full backup from (0), except for what this procedure points to, and start Firefox with -purgecaches to re-test.

Re: [NoScript Classic] Page Won't Load But Nothing Showing Blocked

Posted: Sun Jun 13, 2021 6:48 pm
by dave9
I think I figured it out! A long time ago, I'd tweaked Firefox 54 to use multiple processes and at the time, every site I used including loaded on the first try. I might have been running an older version of NoScript at the time too.... Probably, at least 5.1.7 if not older. These are the changes I'd made... ... -manually/

Even pages that won't load on first try now, were loading back then after enabling multi-process, so I thought nothing of the change being related, but I happened upon some post recently... don't recall where now, that mentioned a problem with a different add-on which reminded me I was running multi-process, so I set all that back to defaults and now Firefox loads on the first try.

Digging a little more, seems this was a known issue and the initial fix came with v, maybe further improved up through 5.1.9, but apparently there are still cases where it causes pages to fail to load on 1st try due to ABE.

By resetting all changes shown on the fossbytes link above, back to defaults, verifying that worked properly, then changing browser.tabs.remote.force-enable;true I was able to reproduce it.

Now another dilemma... do I want to give up multi-process, or ABE, or browsing history, just to avoid clicking reload on first load of a minority of sites for each browser session? Not really, I'd be more inclined to just close my browser less often.

It still seems strange to me that clearing browsing history made a difference, unless loading that involves a 2nd process that can't talk to the other process Noscript's ABE is using? I don't know, but I checked several times to determine that the lone setting that kept it from working was the browser.tabs.remote.force-enable;true