How to enable material-icons from fonts.googleapis.com?

Ask for help about NoScript, no registration needed to post
Knofbath
Posts: 3
Joined: Wed Jun 09, 2021 9:07 pm

How to enable material-icons from fonts.googleapis.com?

Post by Knofbath » Wed Jun 09, 2021 9:18 pm

NoScript 11 is aggressively blocking all @font-face, even when "font" permission is allowed. Even disabling NoScript for the website doesn't do anything.

I understand the risk of allowing any site to inject through @font-face. But, how do I create an exception for fonts.googleapis.com or fontawesome.com specifically.

Really getting annoyed by the lack of material-icons, since nearly every web page seems to use it these days.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

User avatar
Giorgio Maone
Site Admin
Posts: 9106
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: How to enable material-icons from fonts.googleapis.com?

Post by Giorgio Maone » Wed Jun 09, 2021 9:55 pm

It might be a bug in the checks which can be disabled by checking the "unrestricted CSS" capability.
Could you provide me with a page where it happens and the list of your permissions there?
Thanks.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Knofbath
Posts: 3
Joined: Wed Jun 09, 2021 9:07 pm

Re: How to enable material-icons from fonts.googleapis.com?

Post by Knofbath » Wed Jun 09, 2021 10:02 pm

Well, it happens everywhere. Let's just use a google link for simplicity.

https://developers.google.com/fonts/doc ... leshooting

Image
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

barbaz
Senior Member
Posts: 9945
Joined: Sat Aug 03, 2013 5:45 pm

Re: How to enable material-icons from fonts.googleapis.com?

Post by barbaz » Wed Jun 09, 2021 10:04 pm

Ensure "font" permission is enabled for gstatic.com and it works for me.

EDIT Are you sure it's NoScript blocking the fonts?
*Always* check the changelogs BEFORE updating that important software!
-

Knofbath
Posts: 3
Joined: Wed Jun 09, 2021 9:07 pm

Re: How to enable material-icons from fonts.googleapis.com?

Post by Knofbath » Wed Jun 09, 2021 10:38 pm

Sigh, guess it's not NoScript. I disabled all my Add-ons and no change.

Edit: Refresh Firefox fixed it, now to go back through and reinstall add-ons, and see what breaks it.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Post Reply