[CLOSED] Issue with wargaming.net sites

Ask for help about NoScript, no registration needed to post
Geolim4
Posts: 3
Joined: Tue May 18, 2021 4:47 pm

[CLOSED] Issue with wargaming.net sites

Post by Geolim4 » Tue May 18, 2021 4:51 pm

There an issue caused by noscript on wargaming.net website.
Especially the login management at (https://eu.wargaming.net/shop/auth/oid/verify/)

Despite I allow the scripts to load, the JS console still returns this kind of message:
"Content Security Policy: Les paramètres de la page ont empêché le chargement d’une ressource à data: (« default-src »)."

If I disable NS, the login work fine again.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

barbaz
Master Bug Buster
Posts: 9986
Joined: Sat Aug 03, 2013 5:45 pm

Re: Issue with wargaming.net sites

Post by barbaz » Tue May 18, 2021 5:02 pm

What's broken? Does it require a login to reproduce?

How are you determining that is the related message?
Does "Disable restrictions for this tab" also get it working?
Temporarily off forum staff at my own request
*Always* check the changelogs BEFORE updating that important software!
-

Geolim4
Posts: 3
Joined: Tue May 18, 2021 4:47 pm

Re: Issue with wargaming.net sites

Post by Geolim4 » Tue May 18, 2021 5:05 pm

The page stays blank, probably caused by the console error.
Allowing site/disabling restriction change nothing, it only works when disabling NS extension.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Geolim4
Posts: 3
Joined: Tue May 18, 2021 4:47 pm

Re: Issue with wargaming.net sites

Post by Geolim4 » Tue May 18, 2021 5:12 pm

Anyway NS is too much bugged since some weeks, I noticed a lot of annoying like that lately.
Too bad, long time user since years, I have to disable NS permanently now to browse internet quietly.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

barbaz
Master Bug Buster
Posts: 9986
Joined: Sat Aug 03, 2013 5:45 pm

Re: Issue with wargaming.net sites

Post by barbaz » Tue May 18, 2021 5:54 pm

Geolim4 wrote:
Tue May 18, 2021 5:12 pm
Anyway NS is too much bugged since some weeks, I noticed a lot of annoying like that lately.
Too bad, long time user since years, I have to disable NS permanently now to browse internet quietly.
Ok, thanks for letting us know. Marking as Closed.

Not locking, so that you can still post here if you decide to try NoScript again.

For the record, I still get the blank page even visiting that link with NoScript disabled.
Temporarily off forum staff at my own request
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 9130
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Issue with wargaming.net sites

Post by Giorgio Maone » Tue May 18, 2021 6:27 pm

barbaz wrote:
Tue May 18, 2021 5:54 pm

For the record, I still get the blank page even visiting that link with NoScript disabled.
Yes, I've tried as well and I get a 405 error on Chromium, a blank page on Firefox (probably because a different way of handling internal error pages), without NoScript.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Guest

Re: [CLOSED] Issue with wargaming.net sites

Post by Guest » Sat Jul 10, 2021 3:00 pm

I saw the same issue but found that turning off "Sanitize cross-site suspicious requests" (XSS) in NoScript's Advanced tab allows me to log in.

I haven't found out how to create an exception--I can no longer add/edit exceptions.
Mozilla/5.0 (Windows NT 10.0; rv:78.0) Gecko/20100101 Firefox/78.0

Post Reply