NoScript doesn't retain selection for some sites

Ask for help about NoScript, no registration needed to post
BruceW
Posts: 1
Joined: Tue May 04, 2021 12:47 am

NoScript doesn't retain selection for some sites

Post by BruceW » Tue May 04, 2021 12:54 am

I frequently access my work e-mail from home. We use Outlook from Office 365. NoScript doesn't seem to remember my selection for my work URLs. When I try to load the login page scripts are turned off sending me to a error page. I have to use the back button and enable scripts and then try again.


BTW InformAction Forums isn't whitelisted by NoScripts. :)
Mozilla/5.0 (Windows NT 10.0; rv:78.0) Gecko/20100101 Firefox/78.0

barbaz
Senior Member
Posts: 9899
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript doesn't retain selection for some sites

Post by barbaz » Tue May 04, 2021 5:53 pm

Do you have NoScript Options > Advanced, "Enable setting permanent permissions in incognito/private tabs" checked?
Are you using Firefox Sync?
BruceW wrote:
Tue May 04, 2021 12:54 am
BTW InformAction Forums isn't whitelisted by NoScripts. :)
I brought this up in viewtopic.php?f=8&t=25412 but never got any response.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 9087
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript doesn't retain selection for some sites

Post by Giorgio Maone » Tue May 04, 2021 6:06 pm

BruceW wrote:
Tue May 04, 2021 12:54 am
I frequently access my work e-mail from home. We use Outlook from Office 365. NoScript doesn't seem to remember my selection for my work URLs. When I try to load the login page scripts are turned off sending me to a error page.
May I see your NoScript Options>Export file before and after this happens? Thanks.

The forums aren't in the whitelist to prevent people to think it's a conflict of interest.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Post Reply