After allowing "Vimeo", VimeoCDN needs allowing but NS doesn't show it does

Ask for help about NoScript, no registration needed to post
MusicGuy

After allowing "Vimeo", VimeoCDN needs allowing but NS doesn't show it does

Post by MusicGuy » Mon Mar 15, 2021 5:21 am

Hi,

Thanks for having this plugin, it's great!

One thing I did notice though was when I go to a site that has an embedded video from Vimeo that I have to temp allow Vimeo, then the page loads like normal after allowing something and then more loads (in this case VimeoCDN), but unlike normal there is no red or numbers on the little NoScript button up in the toolbar as there were before I allowed Vimeo.

So, I would assume a lot of people would think the video's just not working as it's just a blurry picture of the video that only goes to clear looking and being able to be played once I go to the NS button, click it and allow VimeoCDN, but since it doesn't tell me something new popped up needing a decision to allow or not like with a lot of other sites and content, I would guess most or many people won't think they need to allow something else and will skip the video or leave whatever site they are on.

I hope that makes sense.

Thanks again!

Peace.
Mozilla/5.0 (Windows NT 10.0; rv:78.0) Gecko/20100101 Firefox/78.0

barbaz
Senior Member
Posts: 9870
Joined: Sat Aug 03, 2013 5:45 pm

Re: After allowing "Vimeo", VimeoCDN needs allowing but NS doesn't show it does

Post by barbaz » Mon Mar 15, 2021 4:46 pm

MusicGuy wrote:
Mon Mar 15, 2021 5:21 am
a site that has an embedded video from Vimeo
URL?
*Always* check the changelogs BEFORE updating that important software!
-

MusicGuy

Re: After allowing "Vimeo", VimeoCDN needs allowing but NS doesn't show it does

Post by MusicGuy » Fri Mar 19, 2021 2:30 am

Hi,

Sorry for not including it and sorry for the delay in responding.

Here's a page where that happens...

https://abetterworldwithsteveandmusic.c ... borate-on/

Thanks.

Peace.
Mozilla/5.0 (Windows NT 10.0; rv:78.0) Gecko/20100101 Firefox/78.0

User avatar
therube
Ambassador
Posts: 7692
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: After allowing "Vimeo", VimeoCDN needs allowing but NS doesn't show it does

Post by therube » Fri Mar 19, 2021 5:56 pm

So you allow vimeo.
Then you allow abetterworldwithsteveandmusic.

At that point, the icon shows no "numbers", & its white.

Confirmed.

And based upon that, one might assume there is nothing more to allow.
But in fact, at that point, vimeocdn is there, silently, if you will.
And the video won't play without it.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.6

MusicGuy

Re: After allowing "Vimeo", VimeoCDN needs allowing but NS doesn't show it does

Post by MusicGuy » Mon Mar 22, 2021 12:59 am

Yes, exactly and better said than I.
Thanks.
Mozilla/5.0 (Windows NT 10.0; rv:78.0) Gecko/20100101 Firefox/78.0

Post Reply