Some sites not loading fonts

Ask for help about NoScript, no registration needed to post
BrainDedd
Posts: 2
Joined: Fri Oct 09, 2020 5:53 am

Some sites not loading fonts

Post by BrainDedd » Fri Oct 09, 2020 6:29 am

I have been having issues for the last two days where despite allowing fonts they are blocked in a few sites like Reddit and Deezer.
Disabling NoScript or disabling restrictions globally fixes this.
I have tested with only NoScript enabled an no other addons and it still does this.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Some sites not loading fonts

Post by Giorgio Maone » Fri Oct 09, 2020 7:11 am

Tried on Reddit.
Are both reddit.com and redditstatic.com set to a preset allowing the "font" capability?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Some sites not loading fonts

Post by Giorgio Maone » Fri Oct 09, 2020 7:33 am

I mean, it should not happen anyway: by default 3rd party fonts (from reddistatic.com) should be able to load if the 3d party has the capability even if the top document (reddit.com) doesn't.
It was a regression, fixed in latest development build, thanks:

v 11.1.2rc1
============================================================
x Fixed regression: document media and font restrictions
always cascaded (thanks BrainDedd for report)
x Remove domPolicy logging when debugging is off
x Trivial reordering from Mozilla source
x Updated TLDs
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

BrainDedd
Posts: 2
Joined: Fri Oct 09, 2020 5:53 am

Re: Some sites not loading fonts

Post by BrainDedd » Fri Oct 09, 2020 9:38 am

Sorry for the slow reply. Fix confirmed. Many thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0

barbaz
Senior Member
Posts: 9678
Joined: Sat Aug 03, 2013 5:45 pm

Re: Some sites not loading fonts

Post by barbaz » Fri Oct 09, 2020 2:03 pm

Giorgio Maone wrote:
Fri Oct 09, 2020 7:33 am
latest development build, thanks:

v 11.1.2rc1
============================================================
x Fixed regression: document media and font restrictions
always cascaded (thanks BrainDedd for report)
x Remove domPolicy logging when debugging is off
x Trivial reordering from Mozilla source
x Updated TLDs
(11.1.2rc1 is not signed.)
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 8954
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Some sites not loading fonts

Post by Giorgio Maone » Sat Oct 10, 2020 6:50 am

barbaz wrote:
Fri Oct 09, 2020 2:03 pm
(11.1.2rc1 is not signed.)
Fixed, thanks.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

Post Reply