troubleshoot broken site/broken images

Ask for help about NoScript, no registration needed to post
Longwinded

troubleshoot broken site/broken images

Post by Longwinded » Tue Oct 06, 2020 10:10 pm

So I'm having trouble with BedBathBeyond.com website where I cannot get images. It only works if disable NoScript. There are about 40 scripts to check off, but even if they are all temporarily enabled, I still cannot get images. It always sucks trying to figure out which of the long list of thirdparty is broken. I just want the images to work.

https://www.bedbathandbeyond.com/store/ ... &view=GRID
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:81.0) Gecko/20100101 Firefox/81.0

User avatar
therube
Ambassador
Posts: 7680
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: troubleshoot broken site/broken images

Post by therube » Wed Oct 07, 2020 7:08 pm

Not seeing any issues on my end - even with nothing allowed.
Thumbs look to be coming from scene7.com.

Are you blocking - elsewhere?
Adblocker or third-party cookies or image blocking in FF or similar (or are you using Private Browsing) in FF?

If you disable all extensions except for NoScript, does the site work?


As a test, if you create a new, clean Profile, does the page with images load?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

Longwinded

Re: troubleshoot broken site/broken images

Post by Longwinded » Thu Oct 08, 2020 12:31 am

I restarted in firefox safemode (no add-ons enabled) and the images came back.
I restarted without safemode (still no add-ons enabled) and the images were fine.
I enabled only NoScript and reloaded the page and the images disappeared.
The "Quickview" link is still there but if I click it to an individual product page, the image is missing with a "This image is no longer available" message.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:81.0) Gecko/20100101 Firefox/81.0

Longwinded

Re: troubleshoot broken site/broken images

Post by Longwinded » Thu Oct 08, 2020 12:44 am

I restarted firefox with ONLY NoScript disabled (all other add-ons enabled such as Adblock Plus, DuckDuckGo, Nuke Anything, Shodan) and I could see the images.
Once NoScript was re-enabled the images disappear.
I set Disable Restrictions Globally and the images are still gone.
I specifically located scene7.com permissions and set to trusted and still no images.

The only solution is to stop using NoScript. I have spent literally hours trying to show how NoScript could not be causing this and yet it is the only thing that creates a problem.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:81.0) Gecko/20100101 Firefox/81.0

Longwinded

Re: troubleshoot broken site/broken images

Post by Longwinded » Thu Oct 08, 2020 12:54 am

I cleared the dang site cookies and the images came back. So I'm a dope. I'm putting a post-it on the monitor now.

But I really don't understand how cookies for the site somehow became a catalyst to prevent images from showing only when using NoScript.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:81.0) Gecko/20100101 Firefox/81.0

User avatar
therube
Ambassador
Posts: 7680
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: troubleshoot broken site/broken images

Post by therube » Thu Oct 08, 2020 3:04 pm

It's possible something similar to, access denied after firefox update is going on.

In that instance, "FF" was being blocked.
Here, maybe the only thing affected were (some of) the images on the site.

So "something", seemingly & possibly "unrelated" to the site in question, is actually "wanted" by the particular site, & if it is not there, not seen, or "broken", then the site barfs.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

Longwinded

Re: troubleshoot broken site/broken images

Post by Longwinded » Fri Oct 09, 2020 2:32 am

That actually makes a lot of sense.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:81.0) Gecko/20100101 Firefox/81.0

Post Reply