ABE blocking my Internet connection

Ask for help about NoScript, no registration needed to post
User avatar
computerfreaker
Senior Member
Posts: 220
Joined: Wed Sep 16, 2009 10:03 pm
Location: USA

ABE blocking my Internet connection

Post by computerfreaker » Tue Sep 15, 2009 6:59 pm

I'm trying to do some web browsing at my local library, using their free wireless connection; however, ABE keeps blocking the login script.
I'm not sure how to disable ABE only for the library's IP address... can somebody help me to create a ruleset?

Thanks! :D

computerfreaker
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13) Gecko/2009073022 Firefox/3.0.13

Grumpy Old Lady
Senior Member
Posts: 240
Joined: Fri Jul 03, 2009 7:20 am

Re: ABE blocking my Internet connection

Post by Grumpy Old Lady » Wed Sep 16, 2009 6:25 am

So that someone may write an ABE rule for you, please post the full ABE message about the site you want to allow.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

User avatar
computerfreaker
Senior Member
Posts: 220
Joined: Wed Sep 16, 2009 10:03 pm
Location: USA

Re: ABE blocking my Internet connection

Post by computerfreaker » Wed Sep 16, 2009 11:58 am

Grumpy Old Lady wrote:So that someone may write an ABE rule for you, please post the full ABE message about the site you want to allow.

Drat... I didn't save the message, and I'm not going to be back at the library until next Tuesday.

However, I do recall that the message said a GET call on port 3990 had been blocked from a certain IP (the IP was listed, but I can't for the life of me remember it... :oops: )
Could you explain how to write a generic ABE script that would enable a certain IP for a certain port, or even enable the entire IP? (Especially if the library's IP changes, the proverb about teaching a man to fish applies here... besides, I don't want to keep bothering everyone every time ABE sits on a website... :lol: ;) )

Thanks! :mrgreen:

computerfreaker
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13) Gecko/2009073022 Firefox/3.0.13

User avatar
Giorgio Maone
Site Admin
Posts: 8970
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: ABE blocking my Internet connection

Post by Giorgio Maone » Wed Sep 16, 2009 1:34 pm

http://noscript.net/abe

Anyway, provided that you're probably hitting the "LocalRodeo" rule in the SYSTEM ruleset, you may try to insert this rule at the beginning of the SYSTEM ruleset file (editing it from NoScript Options|Advanced|ABE):

Code: Select all

Site ^https?://[^/:]*:3990/
Accept
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

User avatar
computerfreaker
Senior Member
Posts: 220
Joined: Wed Sep 16, 2009 10:03 pm
Location: USA

Re: ABE blocking my Internet connection

Post by computerfreaker » Wed Sep 16, 2009 7:25 pm

Giorgio Maone wrote:http://noscript.net/abe

Anyway, provided that you're probably hitting the "LocalRodeo" rule in the SYSTEM ruleset, you may try to insert this rule at the beginning of the SYSTEM ruleset file (editing it from NoScript Options|Advanced|ABE):

Code: Select all

Site ^https?://[^/:]*:3990/
Accept

Ah, thanks!
I tried allowing the library's IP by creating a rule in the USER ruleset, but apparently I didn't go "high-level" enough... I will try your rule next time I visit the library. Thanks! :)
(btw, it looks like your rule is a simple RegEx, which I am very familar with... I will try again to create a rule just for the library's IP. Less of a hole = less security risk... :))
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13) Gecko/2009073022 Firefox/3.0.13

Post Reply