[Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Ask for help about NoScript, no registration needed to post
noscriptuser52

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by noscriptuser52 » Sun Sep 06, 2020 6:06 am

Apologies for the late reply.

I followed barbaz instructions, created a new profile, used it for maybe a day or two, then switched backed to my original profile and never had the problem since.

Back then I'm not even sure I was on Firefox 80, today I'm on v80.0.1.
Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Sun Sep 06, 2020 11:09 am

Thanks all for the reports! Marking as Unrelated, this seems to be a Firefox 79 issue, not caused by NoScript.
*Always* check the changelogs BEFORE updating that important software!
-

yoyo

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by yoyo » Mon Sep 07, 2020 12:07 am

I tried upgrading to FF 88.0 and NoScript 11.0.42rc5.

Noscript is still silently dying.

There doesn't appear to be a particular webpage causing this.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Mon Sep 07, 2020 12:39 am

yoyo, you are also the only user who also reported this occurring with Firefox 78. Are you running some third party software that could be interfering? usually, security software e.g. antivirus or firewall, or some sort of "cleaner" software?
*Always* check the changelogs BEFORE updating that important software!
-

yoyo

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by yoyo » Mon Sep 07, 2020 12:57 am

barbaz wrote:
Mon Sep 07, 2020 12:39 am
yoyo, you are also the only user who also reported this occurring with Firefox 78. Are you running some third party software that could be interfering? usually, security software e.g. antivirus or firewall, or some sort of "cleaner" software?
Hey Barbaz,

I am not running any third party "cleaner" software.

Is there any other debugging I can enable, to help me investigate this deeper and provide you more meaningful feedback ?

If by your response this is not a big enough issue to investigate, I can appreciate that too - Just let me know.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Mon Sep 07, 2020 11:30 am

yoyo wrote:
Mon Sep 07, 2020 12:57 am
I am not running any third party "cleaner" software.
No third-party antivirus, firewall, or other always-running security software either? nor any accessibility software? nor anything else that has legitimate reason to be that pervasive?
yoyo wrote:
Mon Sep 07, 2020 12:57 am
Is there any other debugging I can enable, to help me investigate this deeper and provide you more meaningful feedback ?
Can you have the Browser Console (Ctrl-Shift-J) open while browsing, and look at it when NoScript dies? Anything related there?

Also how did you update to Firefox 80? Did you do a full uninstall, selecting to keep your data when prompted, and download & install a fresh Firefox 80 from Mozilla website?
yoyo wrote:
Mon Sep 07, 2020 12:57 am
If by your response this is not a big enough issue to investigate, I can appreciate that too - Just let me know.
No I only mean it is not caused by NoScript, and based on the other reports it seems what's causing this for you may not directly a Firefox issue either.
*Always* check the changelogs BEFORE updating that important software!
-

mrputter

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by mrputter » Mon Sep 07, 2020 2:22 pm

So FWIW, I've also been running into this issue, and have been keeping an eye on this thread for the last week or two. Like the others, it seems to die about once or twice a day for me, and is maddeningly elusive; I haven't actually been able to catch it when it dies, no matter how hard I try.

It started about 3 months (ish?) ago, but was very infrequent at first: once every couple of weeks, or less. But it's been getting more and more frequent over time, and currently happens a couple of times a day.

You'll notice I'm still running an older version of Firefox (75). I've been waiting to see whether upgrading to 80 actually fixed it for others in this thread, and so far the consensus seems to be: maybe? I'll try upgrading myself in the next day or two (right now I have too much work ongoing that I will lose if I restart Firefox, so I don't want to do it right now, but will as soon as I'm able) and will report back as well.

In my case, the only other add-on that I'm running is AdBlock. No other custom software, or any antivirus/accessibility/etc. software.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

User avatar
therube
Ambassador
Posts: 7669
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

[Firefox 79.0/x64] NoScript turning off by itself

Post by therube » Mon Sep 07, 2020 3:53 pm

(How did this get to [Unrelated]? Not seeing anything one way or the other?)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Mon Sep 07, 2020 4:06 pm

therube wrote:
Mon Sep 07, 2020 3:53 pm
(How did this get to [Unrelated]?
I marked it that way based on multiple reports of updating to Firefox 80 fixing this problem. It seems not caused by NoScript.
*Always* check the changelogs BEFORE updating that important software!
-

doIneedaname

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Mon Sep 07, 2020 6:03 pm

Posting an update now that I've been on 80.0.0 for a sufficient period. Had no incidents of the issue since upgrading to 80.0.0.
The issue seemed to start around the time I updated to FF 79.0, and seems to have ended when I updated from FF 79.0.
My recent update sequence is ... -> 74.0 (Mar 19) -> 75.0 (Apr 18) -> 77.0.1 (Jun 10) -> 79.0 (Aug 5) -> 80.0 (Aug 28)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

doIneedaname

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Fri Sep 11, 2020 12:21 am

Back to occurring. Happened once yesterday and once just now. These two times, the exact same scenario. Was on the car forums (audiworld/audizine), went for food or gaming or whatever, come back, reload the main forum thread list and notice "why are things moving around, oh the banners are back, yep, noscript is dead again".

Interestingly, Noscript seems to have updated itself on 9-7, to 11.0.42. The changelog lacks deployment dates, so no idea if I was running clean with 80.0 and a non-changing previous Noscript version. I notice the Noscript changelog shows a 11.0.43, but my autoupdate enabled installation is still 11.0.42.

The inspect - console log doesn't seem to be flooding with those prior messages that were making leaving it open impossible. I'll leave it there and see if it can provide any enlightenment.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

doIneedaname

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Fri Sep 11, 2020 12:27 am

I notice there is one message this time in the inspect - console that predates my going into Addons and "stop"/restarting NoScript by about 15 minutes. I have no clue what this message means or if it's useful on this subject at all.

19:54:57.365 sendRemoveListener on closed conduit {73a6fe31-595d-460b-a920-fcc0f8843232}.274878040318 (ConduitsChild.jsm:108)
_send resource://gre/modules/ConduitsChild.jsm:108
_send self-hosted:1275
removeListener resource://gre/modules/ExtensionChild.jsm:663
removeListener resource://gre/modules/ExtensionChild.jsm:886
onClicked chrome://browser/content/child/ext-menus.js:282
removeListener resource://gre/modules/ExtensionCommon.jsm:2517
revoke resource://gre/modules/ExtensionCommon.jsm:2539
close resource://gre/modules/ExtensionCommon.jsm:2544
unload resource://gre/modules/ExtensionCommon.jsm:909
unload resource://gre/modules/ExtensionPageChild.jsm:261
unload resource://gre/modules/ExtensionPageChild.jsm:298
destroyExtensionContext resource://gre/modules/ExtensionPageChild.jsm:482
observe resource://gre/modules/ExtensionPageChild.jsm:395

The (...) part of the first line is right justified, not with the rest of the text that is left justified.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Fri Sep 11, 2020 12:28 am

doIneedaname wrote:
Fri Sep 11, 2020 12:21 am
The inspect - console log doesn't seem to be flooding with those prior messages that were making leaving it open impossible. I'll leave it there and see if it can provide any enlightenment.
Please instead leave open the Browser Console (Ctrl-Shift-J) and let us know any related messages there around the time this issue recurs.

Also, in case it's relevant, what other extensions do those of you experiencing this issue have?
*Always* check the changelogs BEFORE updating that important software!
-

mrputter

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by mrputter » Fri Sep 11, 2020 3:37 pm

Ok, so here's another data point; hopefully it may be helpful!

I haven't had the chance to update my browser yet (still on 75), but with any luck this may be relevant anyway.

Had to leave my computer for a few hours this morning; when I left, I verified that NoScript was still running, and left the Browser Console open, as per the request by barbaz in his last post (I also cleared away any previous messages, so the window was blank).

Came back, opened a new tab, and noticed that NoScript had died, yet again. Went to the Browser Console, and saw the following messages. I live in UTC-7 (with Daylight Saving Time in effect) so per the timestamps these occurred at exactly 8:00 AM (when I was not at the computer).

By peeking at the .xpi file being referenced, I've verified that these messages do pertain to NoScript. (There were a couple of other very similar messages relating to AdBlock -- the only other add-on that I'm running -- I haven't included them here.) So it looks to me like there's some kind of permission error happening, and NoScript is dying? AdBlock, which again is receiving similar messages, is still going.

Anyway, here we go (I've anonymized a few path names here, but I assume that's not an issue. I've also saved a copy of the xpi and can provide if it's in any way helpful)...

Arrgh. This is triggering the forum's anti-spam filters. Please see a dump of the error messages here:
http://trichotomy.ca/junk/20200911_fire ... ssages.txt
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Fri Sep 11, 2020 3:43 pm

mrputter wrote:
Fri Sep 11, 2020 3:37 pm
Arrgh. This is triggering the forum's anti-spam filters. Please see a dump of the error messages here:
Let me see if I can post them:

Code: Select all

1599832830215	addons.xpi	ERROR	Failed to move file C:\Users\seann\AppData\Roaming\Mozilla\Firefox\Profiles\nx7qndcq.default-release\extensions\{73a6fe31-595d-460b-a920-fcc0f8843232}.xpi to C:\Users\XXXXXXXX\AppData\Roaming\Mozilla\Firefox\Profiles\XXXXXXXX\extensions\trash: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.moveTo]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIInstall.jsm :: _installFile :: line 1092"  data: no] Stack trace: _installFile()@resource://gre/modules/addons/XPIInstall.jsm:1092
moveUnder()@resource://gre/modules/addons/XPIInstall.jsm:1121
moveOldAddon()@resource://gre/modules/addons/XPIInstall.jsm:3152
installAddon()@resource://gre/modules/addons/XPIInstall.jsm:3159
install()@resource://gre/modules/addons/XPIInstall.jsm:1765
update()@resource://gre/modules/addons/XPIProvider.jsm:2074 Log.jsm:723
    append resource://gre/modules/Log.jsm:723
    log resource://gre/modules/Log.jsm:379
    error resource://gre/modules/Log.jsm:387
    _installFile resource://gre/modules/addons/XPIInstall.jsm:1095
    moveUnder resource://gre/modules/addons/XPIInstall.jsm:1121
    moveOldAddon resource://gre/modules/addons/XPIInstall.jsm:3152
    installAddon resource://gre/modules/addons/XPIInstall.jsm:3159
    install resource://gre/modules/addons/XPIInstall.jsm:1765
    update resource://gre/modules/addons/XPIProvider.jsm:2074
    InterpretGeneratorResume self-hosted:1156
    AsyncFunctionNext self-hosted:695


1599832830217	addons.xpi	WARN	Failed to remove trash directory when installing {73a6fe31-595d-460b-a920-fcc0f8843232}: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIInstall.jsm :: recursiveRemove :: line 990"  data: no] Stack trace: recursiveRemove()@resource://gre/modules/addons/XPIInstall.jsm:990
recursiveRemove()@resource://gre/modules/addons/XPIInstall.jsm:1004
installAddon()@resource://gre/modules/addons/XPIInstall.jsm:3204
install()@resource://gre/modules/addons/XPIInstall.jsm:1765
update()@resource://gre/modules/addons/XPIProvider.jsm:2074


1599832830217	addons.xpi	WARN	Failed to install C:\Users\XXXXXXXX\AppData\Local\Temp\tmp-s0i.xpi from https://addons.cdn.mozilla.net/user-media/addons/722/noscript_security_suite-11.0.43-an+fx.xpi?filehash=sha256%3A79395f62e7df98813847e1ffb28ec33e8271dbf826646b022917d13126a29414 to C:\Users\XXXXXXXX\AppData\Roaming\Mozilla\Firefox\Profiles\XXXXXXXX\extensions\staged\{73a6fe31-595d-460b-a920-fcc0f8843232}.xpi: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.moveTo]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIInstall.jsm :: _installFile :: line 1092"  data: no] Stack trace: _installFile()@resource://gre/modules/addons/XPIInstall.jsm:1092
moveUnder()@resource://gre/modules/addons/XPIInstall.jsm:1121
moveOldAddon()@resource://gre/modules/addons/XPIInstall.jsm:3152
installAddon()@resource://gre/modules/addons/XPIInstall.jsm:3159
install()@resource://gre/modules/addons/XPIInstall.jsm:1765
update()@resource://gre/modules/addons/XPIProvider.jsm:2074
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply