[Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Ask for help about NoScript, no registration needed to post
noscriptuser52

[Unrelated; Firefox 79.0/x64] NoScript turning off by itself

Post by noscriptuser52 » Thu Aug 13, 2020 8:37 am

Hello.

This week I experienced an issue with NoScript being automatically disabled.

It's the only extension on my Firefox, version 79.0/x64.

To have NoScript back:
Tools > Addons > Disable NoScript > Enable NoScript

Anyone can help me understand why this is happening?
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

barbaz
Senior Member
Posts: 9717
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Thu Aug 13, 2020 2:48 pm

Please create a clean profile from scratch. Install only NoScript latest development build, leaving all the defaults.
Does the problem still exist?
If not, what if you then import your NoScript settings into the clean profile using the Import and Export buttons in NoScript Options?
If that still doesn't reproduce the problem, it's not a NoScript issue... try Standard Diagnostic (leaving NoScript enabled) to isolate and correct the real cause.

Let us know, thanks.
*Always* check the changelogs BEFORE updating that important software!
-

noscriptuser52

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by noscriptuser52 » Fri Aug 14, 2020 7:43 am

Thank you for the update barbaz.

It happened again, it's happening daily, intermittent.

I followed your instructions, I'm now using a 100% new profile with the NoScript addon only, it's the profile I'm using to post this.

I'll keep using this profile for 48 hours and update if it happens.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

yoyo

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by yoyo » Mon Aug 24, 2020 12:18 am

Hey Guys,

I am having exactly the same problem - FF 78.0.2 (64-bit) / NoScript 11.0.35.

Noscript silently dies without any error. To turn noscript back on, I have to toggle the on/off button in Add-ons to restart it.

Is there a log I can provide to help diagnose the issue further ?

Thanks for the great plugin.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

barbaz
Senior Member
Posts: 9717
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Mon Aug 24, 2020 1:21 am

yoyo wrote:
Mon Aug 24, 2020 12:18 am
Is there a log I can provide to help diagnose the issue further ?
When the issue occurs, anything significant in about:debugging > This Firefox > NoScript > Inspect > Console ?
*Always* check the changelogs BEFORE updating that important software!
-

yoyo

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by yoyo » Mon Aug 24, 2020 2:01 am

barbaz wrote:
Mon Aug 24, 2020 1:21 am
When the issue occurs, anything significant in about:debugging > This Firefox > NoScript > Inspect > Console ?
After writing my previous post, I upgraded to FF 79.0 (64-bit) and NoScript dev Version 11.0.40rc2, to see if the issue went away. I'll report back on my findings.

The challenge with providing meaningful logs to you is that about:debugging logs don't go back far enough and it is further complicated by the fact that the NoScript stops working silently, so it is hard to pin-point the exact time Noscript stopped working (and correlate that to a log).

Having said that, there was nothing particularly interesting in the about:debugging logs I just saw.

I have around 100+ tabs open, but there is sufficient sufficient memory on the host to deal with this -
The issue started happening around a month ago - I think I have upgraded FF twice during that time and have also tried reinstalling NoScript.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

doIneedaname

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Thu Aug 27, 2020 1:19 am

I've been seeing this recently as well. I'll open a tab and go to a page and notice there's a lot more junk on it than normal. Look up and there's no Noscript icon. If I bring up any preexisting window that was loaded when NoScript was working, I see the icon is gone there now too.

If I go to add-ons manager, NoScript is showing with the blue "on" toggle. If I attempt to do inspect in about:debugging, I get a page that says TypeError: target is null. If I toggle NoScript off and back on again in add-ons manager, it works again. Of course, then inspect has nothing about the events prior to the restart. In about:memory, NoScript is not in any of the Extensions listings.

The Troubleshooting section in the FAQ doesn't say anything about logging or debugging. Is there anything to enable to capture events up to the issue? The issue is maybe once a day or every other day for me.

This has been going on for at least over a week now. I updated from 77.0.1 to 79.0 21 days ago. So that's close. Apparently, 80 is now available; guess I could try that.

NoScript shows as 11.0.39, updated 5 days ago. The issue is certainly older than that latest update date.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

doIneedaname

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Thu Aug 27, 2020 1:38 am

Another comment; not sure if it's related or a completely separate concern. But when I do reenable NoScript and go into the Inspect, I get a flood of 316 messages of:
Uncaught (in promise) Error: Could not establish connection. Receiving end does not exist.
send moz-extension://d5b05579-df7e-4daf-abba-d880262580d3/lib/Messages.js:67

It seems I can just leave this Inspect window sitting here, so guess I'll do that and hope something is posted when NoScript goes south again.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

barbaz
Senior Member
Posts: 9717
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Thu Aug 27, 2020 1:24 pm

doIneedaname wrote:
Thu Aug 27, 2020 1:19 am
80 is now available; guess I could try that.
It is looking like this is not a NoScript issue. Everyone who has this issue, please do try Firefox 80 and report back, thanks.
*Always* check the changelogs BEFORE updating that important software!
-

doIneedaname

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Fri Aug 28, 2020 12:42 am

Just an update. So just happened again; been on the computer all day, but just did it. So 19 hours or so?

I was trying to leave that inspect window open, but the 316 error messages issue, refreshing every time I unminimized the inspect window, was just not acceptable.

Maybe it's just when I notice, but I always seem to notice it when browsing car forums.

So will try 80 then.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

doIneedaname

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by doIneedaname » Mon Aug 31, 2020 3:56 pm

Several days on 80 now and no event of NoScript phantom dying yet.
So seems like it was something with 79 (never ran 78).
But want to see how the week goes before declaring resolved.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

Martymoz
Posts: 2
Joined: Fri Oct 13, 2017 10:07 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by Martymoz » Wed Sep 02, 2020 7:29 pm

I am encountering the same thing. It is happening very frequently - many times per day. I have to go to add-ins and disable and then enable Noscript to get it back up and running. Then I notice the tcon is missing from my screen and sure enough it is off again. I updated Firefox and all apps and it still happens. It's been happening since the last update on 8/21/20.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

barbaz
Senior Member
Posts: 9717
Joined: Sat Aug 03, 2013 5:45 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by barbaz » Wed Sep 02, 2020 10:09 pm

Martymoz wrote:
Wed Sep 02, 2020 7:29 pm
I updated Firefox and all apps and it still happens.
But it appears the updating was unsuccessful, as you posted from Firefox 79. Please try Firefox 80.
*Always* check the changelogs BEFORE updating that important software!
-

Martymoz
Posts: 2
Joined: Fri Oct 13, 2017 10:07 pm

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by Martymoz » Wed Sep 02, 2020 11:33 pm

9/4/20: Update - Noscript appears to be working properly after restarting with Firefox 80. Thanks for the help!


________________
I'm in Firefox 80.0.1 64 bit and it says Firefox is up to date.

I honestly don't recall exactly when I updated. I tend to give updates a few days before installing them. It could be fixed and I hadn't restarted or something.

I'll give it a day or two and let you know if the problem resurfaces.

Thank you for the followup!
Last edited by Martymoz on Fri Sep 04, 2020 5:42 pm, edited 1 time in total.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

User avatar
therube
Ambassador
Posts: 7681
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: [Firefox 79.0/x64] NoScript turning off by itself

Post by therube » Thu Sep 03, 2020 7:18 pm

(So we've got 78's & 79's in here, it seems.

And 80.0/80.0.1s seem to be giving others issues with different extensions; FVD Speed Dial (or some such), Bad Bug in New Version of FF.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

Post Reply