Having issues with NoScript overwriting per site permissions

Ask for help about NoScript, no registration needed to post
freakybear
Posts: 2
Joined: Wed Jul 29, 2020 1:05 pm

Having issues with NoScript overwriting per site permissions

Post by freakybear » Wed Jul 29, 2020 1:11 pm

I started noticing yesterday that NoScript was suddenly not remembering what I thought were random settings .
I open the settings and looked at the Per-Site permissions tab and noticed that the tab shows 39 trusted sites. Whenever I try to add a 40th site , Noscript seems to be randomly deleting some other site from the Per-Site list.
Is this intended to work this way , or is there some setting I need to change to allow the list to be a little longer?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

Guest

Re: Having issues with NoScript overwriting per site permissions

Post by Guest » Wed Jul 29, 2020 1:38 pm

I too am seeing wierd behavoir from noscript since Firefox 79.0 came out; top level isn't handled the same way anymore, tho
when reverting to noscript 11.0.32 it seems slightly better, so I'm not sure if the issue is with changes made by FF 79 or with the most recent NS [11.0.33 was definately buggy, with endless looping on some domains, google being the most promient].

sorry for being so vague, but "it's just not the same..."
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

barbaz
Senior Member
Posts: 9584
Joined: Sat Aug 03, 2013 5:45 pm

Re: Having issues with NoScript overwriting per site permissions

Post by barbaz » Wed Jul 29, 2020 1:53 pm

Guest wrote:
Wed Jul 29, 2020 1:38 pm
I'm not sure if the issue is with changes made by FF 79
Do you see this issue in latest Firefox 78 ESR?
*Always* check the changelogs BEFORE updating that important software!
-

another guest

Re: Having issues with NoScript overwriting per site permissions

Post by another guest » Wed Jul 29, 2020 4:37 pm

fyi: using FF79, NoScript 11.0.34, and CCleaner 5.69.7865 - using CCleaner resets NoScript back to defaults (removing any custom per-site permissions) but only since FF79 update today.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

User avatar
Giorgio Maone
Site Admin
Posts: 8863
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Having issues with NoScript overwriting per site permissions

Post by Giorgio Maone » Wed Jul 29, 2020 4:40 pm

It might be related to the changes to sync storage in Firefox 79.
Can you see any error message in about:sync-log, or any seemingly storage/sync related error message in the browser console (ctrl+shift+J)?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:79.0) Gecko/20100101 Firefox/79.0

another guest

Re: Having issues with NoScript overwriting per site permissions

Post by another guest » Wed Jul 29, 2020 6:47 pm

shut FF, used CCleaner, opened FF, came to this page, opened browser console, copied below (sorry, I didn't find an option to give you a screen print)
then checked but nothing in the sync log.
I hope this helps you.
-

Code: Select all

Error while loading 'jar:file:///C:/Program%20Files/Mozilla%20Firefox/browser/omni.ja!/chrome/browser/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:570
1596047744848	addons.xpi	WARN	Exception running bootstrap method startup on twitter@search.mozilla.org: Error: Error while loading 'jar:file:///C:/Program%20Files/Mozilla%20Firefox/browser/omni.ja!/chrome/browser/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:570:20) JS Stack trace: readJSON/</<@Extension.jsm:570:20
onStopRequest@NetUtil.jsm:128:18
Unknown category for SetEventRecordingEnabled: fxmonitor
a11y.sitezoom - Unknown scalar.
[Exception... "Illegal value"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://extensions/content/parent/ext-webRequest.js :: registerEvent :: line 46"  data: no] ext-webRequest.js:46:20
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xhtml
WebExtension context not found! ExtensionParent.jsm:1047
Last edited by barbaz on Wed Jul 29, 2020 7:06 pm, edited 1 time in total.
Reason: wrap console messages in code tags
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

barbaz
Senior Member
Posts: 9584
Joined: Sat Aug 03, 2013 5:45 pm

Re: Having issues with NoScript overwriting per site permissions

Post by barbaz » Wed Jul 29, 2020 7:13 pm

@another guest: Your issue sounds more related to viewtopic.php?f=7&t=26046 than what this OP is experiencing. The problem you face is a CCleaner issue, not a NoScript issue or even a Firefox issue.
*Always* check the changelogs BEFORE updating that important software!
-

freakybear
Posts: 2
Joined: Wed Jul 29, 2020 1:05 pm

Re: Having issues with NoScript overwriting per site permissions

Post by freakybear » Wed Jul 29, 2020 11:21 pm

Whatever was causing the issue has self-rectified since this morning , and it is now letting me add more than 39 sites to the per-site whitelisting.
Spent all afternoon running with various other addons enabled/disabled , using CCleaner , PC shutdown/restar, and everything seems to be working.
Only thing I can think of is if there is a "load order" to addons that I somehow reset to a good state. If it pops up again ,I'll watch the logs and post back
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

Post Reply