Big Troubles with Noscript - Whitelist empty, Objects be missing ...

Ask for help about NoScript, no registration needed to post
Perseus
Posts: 2
Joined: Fri Jun 05, 2020 5:57 pm

Big Troubles with Noscript - Whitelist empty, Objects be missing ...

Post by Perseus » Fri Jun 05, 2020 6:29 pm

I use Noscript for years. On the whole - no problems. Ok it is complex, so I have maintained a whitelist over the years.

But now: all my entries in the whitelist are missing!! There is no entry!! This is all the more annoying since it was a long-term job.

Next Problem: although i trust all sites - the url works not correct. Somehow not all objects are listed. For example the informaction.com - it was for me not possible to register, because i can´t see the captcha, .. or i can not login in my Email-Accout, there is missing the Object-url "login.yahoo.com".
These are just a few examples, i have this problems almost every Site.

When i acitvate Noscript '"trust all sites", or turn off - all works fine.

I use FF 77.01. With Chrome, so it seems no Problems.
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36

Kiimanjaro

Re: Big Troubles with Noscript - Whitelist empty, Objects be missing ...

Post by Kiimanjaro » Fri Jun 05, 2020 11:13 pm

Try check your trusted template. Captcha missing, is probably because of frame not checked.
Mozilla/5.0 (Android 10; Mobile; rv:77.0) Gecko/77.0 Firefox/77.0

Perseus
Posts: 2
Joined: Fri Jun 05, 2020 5:57 pm

Re: Big Troubles with Noscript - Whitelist empty, Objects be missing ...

Post by Perseus » Sat Jun 06, 2020 7:03 am

Thx, ... in the NoScript Options "frame" was not activated.

ok, .. and about my lost "whitlist" - it's not unusual?
When can something like that happen?
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36

kiimanjaro

Re: Big Troubles with Noscript - Whitelist empty, Objects be missing ...

Post by kiimanjaro » Mon Jun 15, 2020 10:31 am

Sorry, I don't know about your lost whitelist problem. Maybe some senior member here can help you with that
Mozilla/5.0 (Android 10; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

User avatar
therube
Ambassador
Posts: 7598
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Big Troubles with Noscript - Whitelist empty, Objects be missing ...

Post by therube » Mon Jun 15, 2020 4:52 pm

Using sync or similar?

Does, could "cleaning" data also clear (where ever it is that NoScript stores its settings)?


(Couldn't NoScript store its settings in a NoScript.ini file [even if that file happened to [[actually]] be a .sqlite?
Otherwise, I have to remember [each time] what that [dumbly, IMO] named file is, each time.]
Hell, you could be call it, NoScript.sqlite ;-).)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

Post Reply