[FIXED] The NoScript Font has changed to symbols.

Ask for help about NoScript, no registration needed to post
VanOlden

[FIXED] The NoScript Font has changed to symbols.

Post by VanOlden » Sun Mar 15, 2020 8:20 pm

I recently installed some Fonts on my Windows 10 PC and now i noticed, that the NoScript Font has turned into symbols with Firefox 74.0.
Don´t know if that´s the reason. On Chrome it works just fine.

https://imgur.com/a/8HLyXkt
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

barbaz
Senior Member
Posts: 9427
Joined: Sat Aug 03, 2013 5:45 pm

Re: The NoScript Font has changed to symbols.

Post by barbaz » Mon Mar 16, 2020 1:18 pm

What NoScript version are you using in Firefox?
What NoScript version are you using in Chrome?

If you visit the following URL in Firefox, does any part of it show with the symbols font? -

Code: Select all

data:text/html,<div id=%22a%22>Test</div><div id=%22b%22>Test</div><style>%23a{font-family:Inter,sans-serif;}%23b{font-family:sans-serif;}</style>
*Always* check the changelogs BEFORE updating that important software!
-

doctordruidphd
Posts: 2
Joined: Mon Mar 16, 2020 3:31 pm

Re: The NoScript Font has changed to symbols.

Post by doctordruidphd » Mon Mar 16, 2020 3:38 pm

I am having the same problem since the "upgrade" to firefox 74.
This is kubuntu linux 19.10, firefox 74.0 64-bit, NoScript version 11.0.17.

If I have firefox Edit > Preferences > Fonts and colors set to allow web pages to choose their own fonts, then NoScript comes up with a symbol font. If I uncheck the "Allow pages to choose their own fonts" box, then NoScript comes up with a normal font, but unfortunately many web pages don't work properly this way.

I tried the URL in the previous message, and the first line comes up symbols, while the second line says Test
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

barbaz
Senior Member
Posts: 9427
Joined: Sat Aug 03, 2013 5:45 pm

Re: The NoScript Font has changed to symbols.

Post by barbaz » Mon Mar 16, 2020 4:03 pm

While waiting for Giorgio to get to this, try temporarily downgrading NoScript to version 11.0.15.

Old NoScript @
https://addons.mozilla.org/addon/noscript/versions
*or*
https://noscript.net/feed?quantum&c=100
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 8802
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: The NoScript Font has changed to symbols.

Post by Giorgio Maone » Mon Mar 16, 2020 6:01 pm

Have you got a font called "Inter" installed?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

User avatar
Giorgio Maone
Site Admin
Posts: 8802
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: The NoScript Font has changed to symbols.

Post by Giorgio Maone » Mon Mar 16, 2020 6:41 pm

Could you please check whether NoScript 11.0.18rc1 (from https://noscript.net/getit#devel ) fixes this problem?
Thanks.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

doctordruidphd
Posts: 2
Joined: Mon Mar 16, 2020 3:31 pm

Re: The NoScript Font has changed to symbols.

Post by doctordruidphd » Mon Mar 16, 2020 8:36 pm

Yes, there is a font called Inter (Thin) installed.

NoScript 11.0.18rc1 fixed the problem, at least for me. Thanks.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

VanOlden

Re: The NoScript Font has changed to symbols.

Post by VanOlden » Mon Mar 16, 2020 11:21 pm

@barbaz: I could´t tell because everything was in symbols.

I tried NoScript 11.0.15 and then 11.0.18rc. Both fixed the problem.
Thank you!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Post Reply