NoScript could not be verified for use if Firefox and has been disabled.

Ask for help about NoScript, no registration needed to post
~Zubla

NoScript could not be verified for use if Firefox and has been disabled.

Post by ~Zubla » Wed Mar 04, 2020 3:55 pm

Firefox 55.0.3 and been using it with NoScript for ages. Extension Armageddon last year. Installed hotfix 1.1.4 and intermediate xpi hotfix 1.0.6. All good so far.

This week updated to NoScript 5.1.9. So added mozilla.cfg and defaults\pref\autoconfig.js.
Restarted Firefox. It wouldn't. Oops. Forgot to remove the above two files. Removed. Firefox started. Everything good for a few hours.

Closed laptop. Came back. Without me touching anything Firefox removed NoScript, with "could not be verified". And called it Legacy--maybe it had been so flagged. The only button available is Remove this AddOn.

Waiting for advice before trying to restart Firefox. It also took out a legacy mouse addon but left 6 other legacy addons alone.

Read:
Firefox deactivates NoScript...and calls it Legacy

Then should I try?:
[Resolved] Updating from 11.0.12rc2 to 11.0.13rc1 - Failed, XPI is not signed
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

User avatar
therube
Ambassador
Posts: 7528
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript could not be verified for use if Firefox and has been disabled.

Post by therube » Wed Mar 04, 2020 5:23 pm

5.1.9 is the latest version you can use.
And you'll also have to enable any hacks needed to allow it into FF (55)

5.1.8.7rc4 is not signed.


(Also, IMO it makes no sense to be on 55 when 52.9.0 ESR has later security fixes [then either 55 or 56].)


NoScript 11.x is a webextension & will not work.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

Post Reply