[RESOLVED] NoScript is Not Blocking Anything

Ask for help about NoScript, no registration needed to post
ambrosia

[RESOLVED] NoScript is Not Blocking Anything

Post by ambrosia » Tue Jan 28, 2020 6:43 pm

Today, using Firefox, I noticed that the Drudge site was doing auto refresh despite the fact that I have the site blocked in NoScript.

I checked some other sites and had the same problem. In particular, I checked https://www.whatismybrowser.com/detect/ ... pt-enabled and http://www.bom.gov.au/australia/radar/a ... ckme.shtml These sites tell you if javascript is working. It wasn't. As a control experiment I used NoScript in Edge. It worked fine. I tried reverting NoScript to 11.0.11. That didn't help.

Help me if you can.
Thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

barbaz
Senior Member
Posts: 9319
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript is Not Blocking Anything

Post by barbaz » Tue Jan 28, 2020 7:04 pm

ambrosia wrote:
Tue Jan 28, 2020 6:43 pm
the Drudge site was doing auto refresh
URL?
*Always* check the changelogs BEFORE updating that important software!
-

Guest

Re: NoScript is Not Blocking Anything

Post by Guest » Tue Jan 28, 2020 7:07 pm

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

ambrosia

Re: NoScript is Not Blocking Anything

Post by ambrosia » Tue Jan 28, 2020 7:20 pm

I just realized I made an error in my original post. Javascript WAS working at the two test sites, which meant that NoScript wasn't working on them either because I blocked them with NoScript. It doesn't seem to be working anywhere with Firefox, but it works fine in Edge.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

barbaz
Senior Member
Posts: 9319
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript is Not Blocking Anything

Post by barbaz » Tue Jan 28, 2020 7:26 pm

To be clear, you have drudgereport.com DEFAULT in NoScript?
How have you configured your DEFAULT preset? (NoScript Options > General)
*Always* check the changelogs BEFORE updating that important software!
-

ambrosia

Re: NoScript is Not Blocking Anything

Post by ambrosia » Tue Jan 28, 2020 7:45 pm

You nailed it! The default option was set to "Disable restrictions globally". That fixed it.

I'm almost certain I didn't change this setting because 1) I never disable NoScript , 2) It would have had to have happened in the last 24 hours because it worked on Drudge yesterday. If I had disabled NoScript in the last 24 hours I'd remember because it would be a big event.

Thank you very much barbaz. I appreciate your efforts.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Post Reply