Edge: Opening NoScript Icon Looks Awkward

Ask for help about NoScript, no registration needed to post
User avatar
therube
Ambassador
Posts: 7518
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Edge: Opening NoScript Icon Looks Awkward

Post by therube » Thu Jan 16, 2020 1:57 am

Edge: Opening NoScript Icon Looks Awkward

no big deal
just saying
just looks awkward

click the icon & you see, oh, i don't know just what
flashes of black, flashes of white
kind of like you get black first, then it populates the "menu" bar, then the site list, & it all looks to draw, awkwardly

whatever


Pretty sure some time back I ran Edge #dev, & I must have had NoScript installed?
Don't recall seeing such issue?
I'm running sandboxed, but that would have been how I would have run older #dev too.

Windows 7 Service Pack 1 (Build 7601.24540)
79.0.309.65 (Official build) (64-bit)


Actually, looking now, I see Chrome (Chromium) is doing the same thing.
Chromium 79.0.3945.117 (Official Build) (64-bit)


No other extensions, so can't say if it's an inherent "Chrome" thing?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.2 Lightning/5.8.1

bo elam
Senior Member
Posts: 195
Joined: Sat Oct 14, 2017 2:25 am

Re: Edge: Opening NoScript Icon Looks Awkward

Post by bo elam » Mon Jan 20, 2020 2:12 am

Hi therube. I tested the new Edge a couple of days ago in W10. It ran nice and everything related to NoScript seemed to be just fine. There was a little delay when clicking the icon for the NoScript Menu to open, it didn't look perfect like in Firefox but it opened fine and it was OK.

I uninstalled Edge and only had it for a few hours but I like to ask you, do you know where Edge Chromiun is saving NoScript settings? I tried to figure that out to allow Edge access to this file while running sandboxed in Sandboxie, but couldn't.

I tested allowing access to the file below and the entire NoScript folder in Settings, but didn't work. So, NoScript must be storing settings elsewhere.

C:\Users\Bo\AppData\Local\Microsoft\Edge\User Data\Default\Extensions\doojmbjmlfjjnbmnoijecmcbfeoakpjm\11.0.13_0\bg\Settings
C:\Users\Bo\AppData\Local\Microsoft\Edge\User Data\Default\Extensions\doojmbjmlfjjnbmnoijecmcbfeoakpjm\11.0.13_0

Bo
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

User avatar
therube
Ambassador
Posts: 7518
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Edge: Opening NoScript Icon Looks Awkward

Post by therube » Mon Jan 20, 2020 11:05 am

The extension itself is "installed" (unpacked as it is) where you have shown above.
(I kind of thought that "random" part of the path was unique, but I guess it is not. And if it is not, what is the point?)

NoScript setting themselves are stored in your Profile Folder in... Firefox (in, don't recall offhand).
In Chrome, oh, I don't know?

Perhaps, /Default/Code Cache/js/random..._0 or /Default/Session Storage/00000#.log ?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.2 Lightning/5.8.1

bo elam
Senior Member
Posts: 195
Joined: Sat Oct 14, 2017 2:25 am

Re: Edge: Opening NoScript Icon Looks Awkward

Post by bo elam » Mon Jan 20, 2020 9:51 pm

I only had the new Edge for a few hours, but eventually it will be pushed upon us, so I really like to know this information. Is important for me to know this for convenience and security. Perhaps someone knows the answer and can tell.

FWIW, in Firefox, NoScript saves settings in storage-sync.sqlite.

Bo
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

bo elam
Senior Member
Posts: 195
Joined: Sat Oct 14, 2017 2:25 am

Re: Edge: Opening NoScript Icon Looks Awkward

Post by bo elam » Wed Jan 29, 2020 12:40 am

I reinstalled Edge and found the file where NoScript settings are saved. This is the file and the location:

AppData\Local\Microsoft\Edge\User Data\Default\Sync Extension Settings\doojmbjmlfjjnbmnoijecmcbfeoakpjm\000003.log

Bo
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Post Reply