Site Matching with subnet still not working (11.0.3)

Ask for help about NoScript, no registration needed to post
fidelisoris
Posts: 2
Joined: Sat Oct 05, 2019 1:33 am

Site Matching with subnet still not working (11.0.3)

Post by fidelisoris » Sat Oct 05, 2019 1:44 am

As far as I can remember the ability to add entries based on site matching with partial subnet has not worked.

The website states:
https://noscript.net/features wrote:Subnet matching - an address with a partial numeric IPv4 IP will match all the subnet. You must specify at least the 2 leftmost bytes, e.g. 192.168 or 10.0.0. Again, matching sites will be temporarily allowed on demand.
Although even the website has inconsistencies (Is the trailing "." required or not?) I have tried with both methods:
  • Using "10.2" does not whitelist "10.2.0.1"
  • Using "10.2." does not whitelist "10.2.0.1"
Firefox Quantum 69.0.2 (64-bit) on Windows 10 Pro x64 1903.
NoScript 11.0.3.

This seems like the most trivial of bugs to fix and has been reported here in the past. Any word on this?

Edit: The reason I'm interested is because my config is too large for FireFox Sync to work properly, as demonstrated:

Code: Select all

1569842631875	Sync.Engine.Extension-Storage	ERROR	Syncing {73a6fe31-595d-460b-a920-fcc0f8843232}: request failed: Error: HTTP 507 Insufficient Storage: Resource access is forbidden for this user (Maximum bytes per object exceeded " "(17743 > 16384 Bytes.)
( {73a6fe31-595d-460b-a920-fcc0f8843232} is the add-on key for NoScript)

So my Sync logs are being pounded with this error and I would like to eliminate as many redundant whitelist entries as possible.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

User avatar
Giorgio Maone
Site Admin
Posts: 8715
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Site Matching with subnet still not working (11.0.3)

Post by Giorgio Maone » Sat Oct 05, 2019 1:58 pm

fidelisoris wrote:
Sat Oct 05, 2019 1:44 am
This seems like the most trivial of bugs to fix and has been reported here in the past. Any word on this?
Not exactly the most trivial, but here we are. Please check latest dev build:

v 11.0.4rc9
============================================================
x IPv4 subnet shortcut matching

(do not use trailing dots).
fidelisoris wrote:
Sat Oct 05, 2019 1:44 am

Code: Select all

1569842631875	Sync.Engine.Extension-Storage	ERROR	Syncing {73a6fe31-595d-460b-a920-fcc0f8843232}: request failed: [Error: HTTP 507 Insufficient Storage: Resource access is forbidden for this user (Maximum bytes per object exceeded " "(17743 > 16384 Bytes.)
I've got some ideas to work-around this problem I'd like to try ASAP, indeed. Thanks for the reminder.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

User avatar
Giorgio Maone
Site Admin
Posts: 8715
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Site Matching with subnet still not working (11.0.3)

Post by Giorgio Maone » Tue Oct 08, 2019 9:10 pm

Giorgio Maone wrote:
Sat Oct 05, 2019 1:58 pm
fidelisoris wrote:
Sat Oct 05, 2019 1:44 am

Code: Select all

1569842631875	Sync.Engine.Extension-Storage	ERROR	Syncing {73a6fe31-595d-460b-a920-fcc0f8843232}: request failed: [Error: HTTP 507 Insufficient Storage: Resource access is forbidden for this user (Maximum bytes per object exceeded " "(17743 > 16384 Bytes.)
I've got some ideas to work-around this problem I'd like to try ASAP, indeed. Thanks for the reminder.
... and they are in latest dev build:
v 11.0.4rc10
============================================================
x Support for splitting sync storage items into chunks, to
allow synchronization of big policies across devices

x [L10n] Updated ca, nl
x Overwrite Chromium zip on reiterated builds
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

fidelisoris
Posts: 2
Joined: Sat Oct 05, 2019 1:33 am

Re: Site Matching with subnet still not working (11.0.3)

Post by fidelisoris » Wed Oct 09, 2019 2:48 am

Now that's what I call an agile response.

Thank you.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Post Reply