Noscript Plugin Firefox for Linux Mint

Ask for help about NoScript, no registration needed to post
New User

Noscript Plugin Firefox for Linux Mint

Post by New User » Sat Aug 03, 2019 1:59 pm

Hello everybody!

I installed Noscript for my firefox browser on Linux Mint but it doesn't show the button (on the upper left side) to configure Noscript.
I already searched for any solution but nothing I found worked.
Could someone help me?

Greetings,
New User
Mozilla/5.0 (Android 8.0.0; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

barbaz
Senior Member
Posts: 9230
Joined: Sat Aug 03, 2013 5:45 pm

Re: Noscript Plugin Firefox for Linux Mint

Post by barbaz » Sat Aug 03, 2019 3:34 pm

What version of Firefox and how did you install it?
What version of NoScript and how did you install it?
*Always* check the changelogs BEFORE updating that important software!
-

New User

Re: Noscript Plugin Firefox for Linux Mint

Post by New User » Sat Aug 03, 2019 5:54 pm

Hello Barbaz,

Firefox was already installed.
The packetmanager shows Packet: Firefox Version: 67.0+linuxmint2+tessa

Noscript was installed through add-ons of Mozilla Firefox. It is version 11.0.2.

Does that help?

Greetings and have a nice day,
New User
Mozilla/5.0 (Android 8.0.0; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

barbaz
Senior Member
Posts: 9230
Joined: Sat Aug 03, 2013 5:45 pm

Re: Noscript Plugin Firefox for Linux Mint

Post by barbaz » Sat Aug 03, 2019 6:04 pm

Oh, you mean you're missing this icon in the NoScript popup -
Image

Do you see a "gravestone" icon on the top bar of the NoScript popup? If so, click that and you should find the NoScript Options icon available to drag to somewhere on the top bar of the popup.

You can also get to NoScript Options through Tools > Add-ons Manager > NoScript > Preferences.

(BTW, are you intentionally not updating to Firefox 68?)
*Always* check the changelogs BEFORE updating that important software!
-

New User

Re: Noscript Plugin Firefox for Linux Mint

Post by New User » Sat Aug 03, 2019 6:21 pm

Hello Barbaz,

I found the mistake: I clicked on > Add-ons Manager > NoScript > Preferences and allowed Noscript to be executed also in private mode of Firefox.
I would update firefox to the newest version but the packetmanager doesn't show that there would be some available. Maybe because this is a configurated version of firefox especially for linux... I don't no...
Thank you for your quick answers :)

Greetings,
New User
Mozilla/5.0 (Android 8.0.0; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

barbaz
Senior Member
Posts: 9230
Joined: Sat Aug 03, 2013 5:45 pm

Re: Noscript Plugin Firefox for Linux Mint

Post by barbaz » Sat Aug 03, 2019 7:46 pm

Thanks for reporting back, glad you got it resolved. Image
New User wrote:
Sat Aug 03, 2019 6:21 pm
I would update firefox to the newest version but the packetmanager doesn't show that there would be some available.
off-topic: According to Linux Mint website, the latest Firefox version available to you through package manager is 68.0.1 - http://packages.linuxmint.com/search.ph ... rd=firefox

Try running sudo apt-get update in terminal?
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply